python-dev_2.7.15~rc1-1_amd64.deb


Advertisement

Description

python-dev - header files and a static library for Python (default)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name python-dev
Package version 2.7.15~rc1
Package release 1
Package architecture amd64
Package type deb
Installed size 18 B
Download size 1.23 KB
Official Mirror archive.ubuntu.com
Header files, a static library and development tools for building
Python modules, extending the Python interpreter or embedding Python
in applications.
This package is a dependency package, which depends on Debian's default
Python version (currently v2.7).

Alternatives

Package Version Architecture Repository
python-dev_2.7.15~rc1-1_i386.deb 2.7.15~rc1 i386 Ubuntu Main
python-dev - - -

Requires

Name Value
libpython-dev = 2.7.15~rc1-1
python = 2.7.15~rc1-1
python2.7-dev >= 2.7.15~rc1-1~

Download

Type URL
Binary Package python-dev_2.7.15~rc1-1_amd64.deb
Source Package python-defaults

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-dev deb package:
    # sudo apt-get install python-dev

Files

Path
/usr/bin/python-config
/usr/bin/python2-config
/usr/lib/x86_64-linux-gnu/pkgconfig/python.pc
/usr/lib/x86_64-linux-gnu/pkgconfig/python2.pc
/usr/share/doc/python-dev
/usr/share/man/man1/python-config.1.gz
/usr/share/man/man1/python2-config.1.gz

Changelog

2018-04-16 - Matthias Klose <doko@debian.org>
python-defaults (2.7.15~rc1-1) unstable; urgency=medium
* Bump version to 2.7.15~rc1.
* debian/control.in (Michael Vogt):
- add Cnf-Visible-Pkgname hint to ensure command-not-found recommends
installing "python" instead of "python-minimal" when it is missing.
2017-12-13 - Matthias Klose <doko@debian.org>
python-defaults (2.7.14-4) unstable; urgency=medium
* Stop building the python-examples and idle2 packages.
* python: Stop shipping the 2to3 symlink (now in the 2to3 package).
2017-12-08 - Matthias Klose <doko@debian.org>
python-defaults (2.7.14-3) unstable; urgency=medium
* Stop using priority extra for the -dbg packages.
* pycompile, pyclean, pyversions: Use python2 as the shebang to guard
against people fiddling around with the python symlink or having a
python3 installed as python in /usr/local. Closes: #864599. LP: #1715062.
* Rename the idle package to idle2. idle is now built for python3.
* Fix quoting in the prerm-clean autoscript. Closes: #815134.
* README.Debian: Reference 2.7 and point to the python3 package for the
Debian Python Policy.
* Mark python-examples as M-A: foreign.
2017-09-18 - Matthias Klose <doko@debian.org>
python-defaults (2.7.14-1) unstable; urgency=medium
* Bump version to 2.7.14.
* python-examples: Fix Multi-Arch warning.
* Change policy format from debiandoc SGML to DocBook/XML (W. Martin Borgert).
Closes: #872421.
2017-01-24 - Matthias Klose <doko@debian.org>
python-defaults (2.7.13-2) unstable; urgency=medium
[ Matthias Klose ]
* Lower priority of packages from standard to optional.
[ Scott Kitterman ]
* Make another attempt at Django specific binary naming
2016-12-20 - Matthias Klose <doko@debian.org>
python-defaults (2.7.13-1) unstable; urgency=medium
[ Matthias Klose ]
* Bump version to 2.7.13.
* Mark python-doc as M-A: foreign.
* Bump debhelper version.
[ Helmut Grohne ]
* Fix FTCBFS: Annotate python build dependencies with :any (Closes: #841682)
[ Chris Lamb ]
* Consistently order python substvars to support reproducibility (Closes:
#844111)
[ Scott Kitterman ]
* Add Django specific binary naming policy to align to current practice.
2016-06-03 - Matthias Klose <doko@debian.org>
python-defaults (2.7.11-2) unstable; urgency=medium
[ Scott Kitterman ]
* Python policy updates for Stretch (Many thanks to Ben Finney for all the
updates)
- Change focus in text to python3
- Remove/deprecate features no longer needed due to only a single Python 2
version
- Discuss update process in more detail
- Revamp tools section to better align to current practice
[ Matthias Klose ]
* Update valgrind suppression file. Issue #12612. LP: #1512622.
* Rebuild to pick up the GNU triplet change on i386 archs. Addresses: #826128.
2015-12-09 - Matthias Klose <doko@debian.org>
python-defaults (2.7.11-1) unstable; urgency=medium
* Bump version to 2.7.11.
* Stop shipping menu files.
* Fix some lintian warnings.
2015-03-16 - Matthias Klose <doko@debian.org>
python-defaults (2.7.9-1) unstable; urgency=medium
* Bump version to 2.7.9.
2015-03-02 - Scott Kitterman <scott@kitterman.com>
python-defaults (2.7.8-4) unstable; urgency=medium
[ Barry Warsaw ]
* Update policy document to clarify the purpose and use of the wheel
files.  No actual change in policy is made.

See Also

Package Description
python-django-appconf-doc_1.0.2-3_all.deb helper class handling configuration defaults of apps - doc
python-django-appconf_1.0.2-3_all.deb helper class handling configuration defaults of apps - Python 2.7
python-django-common_1.11.11-1ubuntu1_all.deb High-level Python web development framework (common)
python-django-compressor_2.2-4_all.deb Compresses linked, inline JS or CSS into single cached files - Python 2.7
python-django-doc_1.11.11-1ubuntu1_all.deb High-level Python web development framework (documentation)
python-django-horizon_13.0.0-0ubuntu1_all.deb Django module providing web based interaction with OpenStack
python-django-openstack-auth_13.0.0-0ubuntu1_all.deb Django authentication backend for Openstack - Python 2.7
python-django-pyscss_2.0.2-8_all.deb makes it easier to use PySCSS in Django - Python 2.7
python-django_1.11.11-1ubuntu1_all.deb High-level Python web development framework (Python 2 version)
python-dnspython_1.15.0-1_all.deb DNS toolkit for Python
python-doc_2.7.15~rc1-1_all.deb documentation for the high-level object-oriented language Python
python-docutils_0.14+dfsg-3_all.deb text processing system for reStructuredText (implemented in Python 2)
python-dogpile.cache-doc_0.6.2-5_all.deb caching front-end based on the Dogpile lock - doc
python-dogpile.cache_0.6.2-5_all.deb caching front-end based on the Dogpile lock - Python 2.x
python-egenix-mx-base-dev_3.2.9-1_all.deb development files for the egenix-mx-base distribution
Advertisement
Advertisement