printer-driver-splix_2.0.0+svn315-6fakesync1_amd64.deb


Advertisement

Description

printer-driver-splix - Driver for Samsung and Xerox SPL2 and SPLc laser printers

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name printer-driver-splix
Package version 2.0.0+svn315
Package release 6fakesync1
Package architecture amd64
Package type deb
Installed size 177 B
Download size 37.50 KB
Official Mirror archive.ubuntu.com
Support for printing to SPL2- and SPLc-based printers. These are most
of the cheaper Samsung laser printers which do not understand standard
languages like PostScript or PCL. Both monochrome (ML-15xx, ML-16xx,
ML-17xx, ML-2xxx) and color (CLP-5xx, CLP-6xx) models are supported.
Also some rebranded Samsungs like the Xerox Phaser 6100 work with this
driver.
Note that older SPL1-based models (ML-12xx, ML-14xx) do not work. Use
these printers with the older "gdi" driver which is built into
GhostScript.

Alternatives

Package Version Architecture Repository
printer-driver-splix_2.0.0+svn315-6fakesync1_i386.deb 2.0.0+svn315 i386 Ubuntu Main
printer-driver-splix - - -

Requires

Name Value
cups >= 1.5.0-3~
cups-client -
cups-filters >= 1.0.36
libc6 >= 2.14
libcups2 >= 1.4.0
libcupsimage2 >= 1.4.0
libgcc1 >= 1:3.0
libjbig0 >= 2.0
libstdc++6 >= 5

Replaces

Name Value
splix << 2.0.0+svn299-1

Download

Type URL
Binary Package printer-driver-splix_2.0.0+svn315-6fakesync1_amd64.deb
Source Package splix

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install printer-driver-splix deb package:
    # sudo apt-get install printer-driver-splix

Files

Path
/usr/lib/cups/filter/pstoqpdl
/usr/lib/cups/filter/rastertoqpdl
/usr/share/apport/package-hooks/source_splix.py
/usr/share/cups/drv/splix-dell.drv
/usr/share/cups/drv/splix-lexmark.drv
/usr/share/cups/drv/splix-samsung.drv
/usr/share/cups/drv/splix-toshiba.drv
/usr/share/cups/drv/splix-xerox.drv
/usr/share/cups/ppd-updaters/splix.ppd-updater
/usr/share/doc/printer-driver-splix/changelog.Debian.gz
/usr/share/doc/printer-driver-splix/copyright

Changelog

2016-11-06 - Colin Watson <cjwatson@ubuntu.com>
splix (2.0.0+svn315-6fakesync1) zesty-proposed; urgency=medium
* Fake sync due to mismatching orig tarball.
2016-09-11 - Didier Raboud <odyx@debian.org>
splix (2.0.0+svn315-6) unstable; urgency=medium
* Team upload
[ Helmut Grohne ]
* Fix FTCBFS: Use triplet-prefixed compilers (Closes: #837182)
[ Didier Raboud ]
* Drop splix transitional package which reached stable
2016-06-12 - Didier Raboud <odyx@debian.org>
splix (2.0.0+svn315-5) unstable; urgency=medium
* Team upload
* Bump S-V to 3.9.8 without changes needed
* Add patch to avoid letting bash trim whitespace when compiling .drv files;
should make the build reproducible
* Add patch to fix the aready/already typo
* Set hardening=+all in DEB_BUILD_MAINT_OPTIONS
2014-09-18 - Didier Raboud <odyx@debian.org>
splix (2.0.0+svn315-4) unstable; urgency=medium
* Team upload
[ Didier Raboud <odyx@debian.org> ]
* Depend on cups-filters (>= 1.0.36) instead of ghostscript-cups for the
gstoraster filter (Closes: #761316)
2014-04-17 - Didier Raboud <odyx@debian.org>
splix (2.0.0+svn315-3) unstable; urgency=low
* Team upload
[ Luca Niccoli ]
* Separate build of arch-independent packages
[ Didier Raboud ]
* Move the repository from collab-maint to printing; update the VCS-* fields
accordingly
2014-01-15 - Luca Niccoli <lultimouomo@gmail.com>
splix (2.0.0+svn315-2) unstable; urgency=low
* Include missing apport-hook.py in source package
2014-01-03 - Luca Niccoli <lultimouomo@gmail.com>
splix (2.0.0+svn315-1) unstable; urgency=low
* Imported Upstream SVN snapshot (revision 315)
- Add support for Samsung ML-2160 (Closes: #696240).
- Add support for Samsung ML-2165.
* Drop patches that have been merged upstream
* Imported existing quilt patches into gbp-pq and refreshed them for
the new upstream version.
* Set debian build flags during build.
* Fixed splix.ppd-updater (Thanks to Till Kamppeter).
* Add apport hook on Ubuntu and derivatives (reduces the package delta).
* Add get-orig-source target to fetch recreate the tarball from upstream SVN.
* Make build verbose to have more informative buildd logs.
* Move package under the Debian Printing Team maintenance.
* Bump Standards-Version to 3.9.5 (no changes needed)
2012-04-29 - Luca Niccoli <lultimouomo@gmail.com>
splix (2.0.0+svn306-2) unstable; urgency=low
* Properly pre-process drv files during build. (Closes: #670823)
2012-04-23 - Luca Niccoli <lultimouomo@gmail.com>
splix (2.0.0+svn306-1) unstable; urgency=low
* New upstream version: allows installing .drv files instead of PPDs.
* The last patent on JBIG has now expired and we have libjbig in
Debian, let's use it. (Closes: #457650, #507247)
* Bump Standards-Version to 3.9.3 (no changes needed).
* Thanks to Didier Raboud for the prevois NMU.
2012-02-01 - Didier Raboud <odyx@debian.org>
splix (2.0.0+svn300-1.1) unstable; urgency=low
* Non-maintainer upload.
* printer-driver-splix: Add versioned Replaces/Breaks against splix to
ensure smooth upgrades (Closes: #655918).

See Also

Package Description
procmail_3.22-26_amd64.deb Versatile e-mail processor
procps_3.3.12-3ubuntu1_amd64.deb /proc file system utilities
psf-unifont_10.0.07-1_all.deb PSF (console) version of GNU Unifont with APL support
psmisc_23.1-1_amd64.deb utilities that use the proc file system
publicsuffix_20180223.1310-1_all.deb accurate, machine-readable list of domain name suffixes
pulseaudio-module-bluetooth_11.1-1ubuntu7_amd64.deb Bluetooth module for PulseAudio sound server
pulseaudio-utils_11.1-1ubuntu7_amd64.deb Command line tools for the PulseAudio sound server
pulseaudio_11.1-1ubuntu7_amd64.deb PulseAudio sound server
pv_1.6.6-1_amd64.deb Shell pipeline element to meter data passing through
pxelinux_6.03+dfsg1-2_all.deb collection of bootloaders (PXE network bootloader)
pycadf-common_2.7.0-0ubuntu1_all.deb implementation of DMTF Cloud Audit (CADF) data model - common files
python-alembic_0.9.3-2ubuntu1_all.deb lightweight database migration tool for SQLAlchemy - Python 2.x
python-all-dev_2.7.15~rc1-1_amd64.deb package depending on all supported Python development packages
python-all_2.7.15~rc1-1_amd64.deb package depending on all supported Python runtime versions
python-amqp-doc_2.2.2-1_all.deb Low-level AMQP client (Documentation)
Advertisement
Advertisement