ppp_2.4.7-2+2ubuntu1_amd64.deb


Advertisement

Description

ppp - Point-to-Point Protocol (PPP) - daemon

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Main amd64
Package name ppp
Package version 2.4.7
Package release 2+2ubuntu1
Package architecture amd64
Package type deb
Installed size 949 B
Download size 320.41 KB
Official Mirror archive.ubuntu.com
The Point-to-Point Protocol provides a standard way to transmit
datagrams over a serial link, as well as a standard way for the machines
at either end of the link to negotiate various optional characteristics
of the link.
This package is most commonly used to manage a modem for dial-up or
certain kinds of broadband connections.

Alternatives

Package Version Architecture Repository
ppp_2.4.7-2+2ubuntu1_i386.deb 2.4.7 i386 Ubuntu Main
ppp - - -

Requires

Name Value
libc6 >= 2.15
libpam-modules -
libpam-runtime -
libpam0g >= 0.99.7.1
libpcap0.8 >= 0.9.8
libssl1.1 >= 1.1.0
lsb-base -
procps -

Download

Type URL
Binary Package ppp_2.4.7-2+2ubuntu1_amd64.deb
Source Package ppp

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ppp deb package:
    # sudo apt-get install ppp

Files

Path
/etc/chatscripts/gprs
/etc/chatscripts/pap
/etc/init.d/pppd-dns
/etc/logrotate.d/ppp
/etc/pam.d/ppp
/etc/ppp/ip-down
/etc/ppp/ip-up
/etc/ppp/ipv6-down
/etc/ppp/ipv6-up
/etc/ppp/options
/etc/ppp/ip-down.d/0000usepeerdns
/etc/ppp/ip-up.d/0000usepeerdns
/lib/systemd/system/pppd-dns.service
/usr/bin/plog
/usr/bin/poff
/usr/bin/pon
/usr/lib/pppd/2.4.7/minconn.so
/usr/lib/pppd/2.4.7/openl2tp.so
/usr/lib/pppd/2.4.7/passprompt.so
/usr/lib/pppd/2.4.7/passwordfd.so
/usr/lib/pppd/2.4.7/pppoatm.so
/usr/lib/pppd/2.4.7/pppol2tp.so
/usr/lib/pppd/2.4.7/radattr.so
/usr/lib/pppd/2.4.7/radius.so
/usr/lib/pppd/2.4.7/radrealms.so
/usr/lib/pppd/2.4.7/rp-pppoe.so
/usr/lib/pppd/2.4.7/winbind.so
/usr/sbin/chat
/usr/sbin/pppd
/usr/sbin/pppdump
/usr/sbin/pppoe-discovery
/usr/sbin/pppstats
/usr/share/bash-completion/completions/poff
/usr/share/bash-completion/completions/pon
/usr/share/doc/ppp/FAQ.gz
/usr/share/doc/ppp/PLUGINS.gz
/usr/share/doc/ppp/README.Debian.gz
/usr/share/doc/ppp/README.MPPE
/usr/share/doc/ppp/README.MSCHAP80.gz
/usr/share/doc/ppp/README.MSCHAP81
/usr/share/doc/ppp/README.STATIC-IP
/usr/share/doc/ppp/README.cbcp
/usr/share/doc/ppp/README.gz
/usr/share/doc/ppp/README.pppoe
/usr/share/doc/ppp/README.pppol2tp
/usr/share/doc/ppp/README.pwfd
/usr/share/doc/ppp/README.win9x
/usr/share/doc/ppp/SETUP.gz
/usr/share/doc/ppp/changelog.Debian.gz
/usr/share/doc/ppp/copyright
/usr/share/doc/ppp/defaultroute
/usr/share/doc/ppp/examples/filters
/usr/share/doc/ppp/examples/interfaces
/usr/share/doc/ppp/examples/options.ttyXX
/usr/share/doc/ppp/examples/peers-gprs
/usr/share/doc/ppp/examples/peers-pppoa
/usr/share/doc/ppp/examples/peers-pppoe
/usr/share/doc/ppp/examples/per-linkname
/usr/share/doc/ppp/examples/popp
/usr/share/doc/ppp/examples/userscripts-down
/usr/share/doc/ppp/examples/userscripts-up
/usr/share/doc/ppp/examples/scripts/README.gz
/usr/share/doc/ppp/examples/scripts/autopppd.gz
/usr/share/doc/ppp/examples/scripts/callback
/usr/share/doc/ppp/examples/scripts/chat-callback
/usr/share/doc/ppp/examples/scripts/ip-down.local.add
/usr/share/doc/ppp/examples/scripts/ip-up.local.add
/usr/share/doc/ppp/examples/scripts/ipv6-down.sample
/usr/share/doc/ppp/examples/scripts/ipv6-up.sample
/usr/share/doc/ppp/examples/scripts/options-rsh-loc
/usr/share/doc/ppp/examples/scripts/options-rsh-rem
/usr/share/doc/ppp/examples/scripts/options-ssh-loc
/usr/share/doc/ppp/examples/scripts/options-ssh-rem
/usr/share/doc/ppp/examples/scripts/plog
/usr/share/doc/ppp/examples/scripts/poff
/usr/share/doc/ppp/examples/scripts/pon
/usr/share/doc/ppp/examples/scripts/pon.1
/usr/share/doc/ppp/examples/scripts/ppp-off
/usr/share/doc/ppp/examples/scripts/ppp-on
/usr/share/doc/ppp/examples/scripts/ppp-on-dialer
/usr/share/doc/ppp/examples/scripts/ppp-on-rsh
/usr/share/doc/ppp/examples/scripts/ppp-on-ssh
/usr/share/doc/ppp/examples/scripts/redialer
/usr/share/doc/ppp/examples/scripts/secure-card
/usr/share/doc/ppp/examples/scripts/chatchat/README.gz
/usr/share/doc/ppp/examples/scripts/chatchat/chatchat.c.gz
/usr/share/lintian/overrides/ppp
/usr/share/man/man1/plog.1.gz
/usr/share/man/man1/poff.1.gz
/usr/share/man/man1/pon.1.gz
/usr/share/man/man8/chat.8.gz
/usr/share/man/man8/pppd-radattr.8.gz
/usr/share/man/man8/pppd-radius.8.gz
/usr/share/man/man8/pppd.8.gz
/usr/share/man/man8/pppdump.8.gz
/usr/share/man/man8/pppoe-discovery.8.gz
/usr/share/man/man8/pppstats.8.gz
/usr/share/ppp/chap-secrets
/usr/share/ppp/pap-secrets
/usr/share/ppp/provider.chatscript
/usr/share/ppp/provider.peer

Changelog

2018-03-03 - Gianfranco Costamagna <locutusofborg@debian.org>
ppp (2.4.7-2+2ubuntu1) bionic; urgency=low
* Merge from Debian unstable.  Remaining changes:
- debian/patches/load_ppp_generic_if_needed: load ppp_generic kernel
module if needed.
- debian/ppp.preinst: deal with the change in LSB headers start runlevels
of pppd-dns due to dropping our changes (which are no longer necessary
since resolvconf is installed in most systems and has been for a while);
this should probably be kept until the next LTS.
* debian/ppp.symbols: updated for Ubuntu.
2018-02-25 - Chris Boot <bootc@debian.org>
ppp (2.4.7-2+2) unstable; urgency=medium
* Correct a bug in MS-CHAP authentication introduced in 2.4.7-2+1~exp1 which
prevented such authentication from working altogether. (Closes: #891413)
2018-02-23 - Łukasz 'sil2100' Zemczak <lukasz.zemczak@ubuntu.com>
ppp (2.4.7-2+1ubuntu1) bionic; urgency=low
* Merge from Debian unstable.  Remaining changes:
- debian/patches/load_ppp_generic_if_needed: load ppp_generic kernel
module if needed.
- debian/ppp.preinst: deal with the change in LSB headers start runlevels
of pppd-dns due to dropping our changes (which are no longer necessary
since resolvconf is installed in most systems and has been for a while);
this should probably be kept until the next LTS.
* debian/ppp.symbols: updated for Ubuntu.
2018-02-17 - Chris Boot <bootc@debian.org>
ppp (2.4.7-2+1) unstable; urgency=medium
[ Алексей Шилин ]
* debian-installer udeb: use /bin/ip instead of /sbin/ifconfig in the
interfaces configuration for the installed system. (Closes: #889295)
[ Chris Boot ]
* Upload to unstable.
2018-02-11 - Chris Boot <bootc@debian.org>
ppp (2.4.7-2+1~exp1) experimental; urgency=medium
* Switch to debhelper compat level 11.
- Set debian/compat to 11.
- Bump Build-Depends on debhelper to >= 11~.
- Remove Build-Depends on dh-systemd.
- Remove implicit --with systemd from debian/rules.
- Switch to dh_installsystemd helper.
* Update Standards-Version to 4.1.3:
- Remove Priority extra from ppp-dev.
* debian/rules: use dpkg helpers for parsing debian/changelog.
* Incorporate the EAP-TLS patch for pppd: (Closes: #602503)
- debian/patches/eaptls-mppe.patch: add ppp-2.4.7-eaptls-mppe-0.999.patch.
- debian/control: add libssl-dev to Build-Depends.
- debian/changelog: bump the ABI revision number to account for removed
symbols (MD5 now comes from OpenSSL).
- debian/rules: don't include EAP-TLS support in the udeb build.
* debian/changelog: remove trailing whitepace.
* Switch to OpenSSL implementations of MD4, MD5 and SHA1: (Closes: #826625)
- debian/patches/replace-vendored-hash-functions.patch: remove embedded
crypto code copies, unconditionally link with libcrypto, update
includes, amend call sites as required.
- debian/ppp.symbols: remove dropped symbols.
* Import patches added to upstream Git since the 2.4.7 upstream release,
correcting numerous minor bugs. Of note:
- 0002-pppd-add-support-for-defaultroute-metric-option.patch: this patch
is NOT currently applied due to conflicts with the cifdefroute.dif
patch, which adds the replacedefaultroute and noreplacedefaultroute
options.
- 0013-pppd-allow-use-of-arbitrary-interface-names.patch: upstream import
of our ppp-2.4.2-ifname.diff patch.
- 0016-pppoe-include-netinet-in.h-before-linux-in.h.patch: upstream patch
that replaces our fix-rp-pppoe-ftbfs.patch.
- Refreshed 018_ip-up_option.diff and makefiles_cleanup on top of the new
patches.
* Tweak pon and poff bash-completions files for new versions of
bash-completion. (Closes: #882199)
* debian/ppp-udeb.postinst: consider interface names using udev predictable
interface naming. (Closes: #873391)
* d/control: declare that the build requires root.
* Move packaging from Alioth to Salsa.
* Upload to experimental.

See Also

Package Description
pppconfig_2.3.23_all.deb Text menu based utility for configuring ppp
pppoeconf_1.21ubuntu1_all.deb configures PPPoE/ADSL connections
pptp-linux_1.9.0+ds-2_amd64.deb Point-to-Point Tunneling Protocol (PPTP) Client
pptpd_1.4.0-11build1_amd64.deb PoPToP Point to Point Tunneling Server
preview-latex-style_11.91-1ubuntu1_all.deb extraction of elements from LaTeX documents as graphics
printer-driver-brlaser_4-1_amd64.deb printer driver for (some) Brother laser printers
printer-driver-c2esp_27-4_amd64.deb printer driver for Kodak ESP AiO color inkjet Series
printer-driver-foo2zjs-common_20170320dfsg0-4_all.deb printer driver for ZjStream-based printers - common files
printer-driver-foo2zjs_20170320dfsg0-4_amd64.deb printer driver for ZjStream-based printers
printer-driver-gutenprint_5.2.13-2_amd64.deb printer drivers for CUPS
printer-driver-hpcups_3.17.10+repack0-5_amd64.deb HP Linux Printing and Imaging - CUPS Raster driver (hpcups)
printer-driver-hpijs_3.17.10+repack0-5_amd64.deb HP Linux Printing and Imaging - printer driver (hpijs)
printer-driver-m2300w_0.51-13_amd64.deb printer driver for Minolta magicolor 2300W/2400W color laser printers
printer-driver-min12xxw_0.0.9-10_amd64.deb printer driver for KonicaMinolta PagePro 1[234]xxW
printer-driver-pnm2ppa_1.13+nondbs-0ubuntu6_amd64.deb printer driver for HP-GDI printers
Advertisement
Advertisement