policyrcd-script-zg2_0.1-3_all.deb


Advertisement

Description

policyrcd-script-zg2 - policy-compliant interface from invoke-rc.d to local config files

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name policyrcd-script-zg2
Package version 0.1
Package release 3
Package architecture all
Package type deb
Installed size 18 B
Download size 5.48 KB
Official Mirror archive.ubuntu.com
This package contains a script which is linked via the alternatives
subsystem to /usr/sbin/policy-rc.d. This script looks for a local
policy-rc.d script in /usr/local and /etc, providing a policy- and
FHS-compliant way to interface invoke-rc.d with a local script.
Without this package, a local admin wanting to cleanly interface with
invoke-rc.d is forced to drop a local binary to /usr/sbin and/or
manually interface with the alternatives system. Both ways of doing
this are clumsy and error-prone, so this package offers a clean way of
interfacing with sysvrc and file-rc.
Since there are at least two packages containing their own version of
invoke-rc.d, having a search path policy for policy-rc.d can be
messy and is prone to be unstructured and uncoordinated.
Hence, having a dedicated package is the clean way of doing things.
This package has its upstream sources maintained in the Debian
project, so there is no upstream URL.

Alternatives

Package Version Architecture Repository
policyrcd-script-zg2_0.1-3_all.deb 0.1 all Ubuntu Main
policyrcd-script-zg2 - - -

Download

Type URL
Binary Package policyrcd-script-zg2_0.1-3_all.deb
Source Package policyrcd-script-zg2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install policyrcd-script-zg2 deb package:
    # sudo apt-get install policyrcd-script-zg2

Files

Path
/usr/sbin/zg-policy-rc.d
/usr/share/doc/policyrcd-script-zg2/TODO.Debian
/usr/share/doc/policyrcd-script-zg2/changelog.Debian.gz
/usr/share/doc/policyrcd-script-zg2/copyright
/usr/share/man/man8/zg-policy-rc.d.8.gz

Changelog

2016-03-12 - Marc Haber <mh+debian-packages@zugschlus.de>
policyrcd-script-zg2 (0.1-3) unstable; urgency=low
* convert package from cdbs to debhelper 9.
Thanks to Niels Thykier (Closes: #817625)
* re-word description.
Thanks to Peter Eisentraut (Closes: #613783)
* Source-Format: 3.0 (quilt)
* remove lintian overrides
* put upstream changes in quilt patches
* move package to collab-maint
* machine readable debian/copyright
* add Homepage (pointing to tracker.d.o)
* Standards-Version: 3.9.7 (no further changes necessary)
2005-10-22 - Marc Haber <mh+debian-packages@zugschlus.de>
policyrcd-script-zg2 (0.1-2) unstable; urgency=low
* disable DEB_AUTO_UPDATE_DEBIAN_CONTROL, see #311724
* fix typo in package description, thanks to Mika Prokop.
* script is /bin/sh compatible, drop /bin/bash, thanks to Mika Prokop.
* add SEE ALSO section to man page, thanks to Mika Prokop.
* manpage is no longer preliminary.
* new FSF postal address.
* Architecture: all, copy Build-Depends to Build-Depends-Indep
* add lintian source override for build-depends-without-arch-dep: All
cdbs-generated dependencies are needed on clean.
* Standards-Version: 3.6.2, no changes needed
2005-02-10 - Marc Haber <mh+debian-packages@zugschlus.de>
policyrcd-script-zg2 (0.1-1) experimental; urgency=low
* first Debian package. Closes: #292299

See Also

Package Description
pollinate_4.31-0ubuntu1_all.deb seed the pseudo random number generator
poppler-data_0.4.8-2_all.deb encoding data for the poppler PDF rendering library
poppler-utils_0.62.0-2ubuntu2_amd64.deb PDF utilities (based on Poppler)
popularity-contest_1.66ubuntu1_all.deb Vote for your favourite packages automatically
postfix-cdb_3.3.0-1_amd64.deb CDB map support for Postfix
postfix-doc_3.3.0-1_all.deb Documentation for Postfix
postfix-ldap_3.3.0-1_amd64.deb LDAP map support for Postfix
postfix-mysql_3.3.0-1_amd64.deb MySQL map support for Postfix
postfix-pcre_3.3.0-1_amd64.deb PCRE map support for Postfix
postfix-pgsql_3.3.0-1_amd64.deb PostgreSQL map support for Postfix
postfix_3.3.0-1_amd64.deb High-performance mail transport agent
postgresql-10_10.3-1_amd64.deb object-relational SQL database, version 10 server
postgresql-client-10_10.3-1_amd64.deb front-end programs for PostgreSQL 10
postgresql-client-common_190_all.deb manager for multiple PostgreSQL client versions
postgresql-client_10+190_all.deb front-end programs for PostgreSQL (supported version)
Advertisement
Advertisement