pkg-config_0.29.1-0ubuntu2_amd64.deb


Advertisement

Description

pkg-config - manage compile and link flags for libraries

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name pkg-config
Package version 0.29.1
Package release 0ubuntu2
Package architecture amd64
Package type deb
Installed size 181 B
Download size 43.96 KB
Official Mirror archive.ubuntu.com
pkg-config is a system for managing library compile and link flags that
works with automake and autoconf.
Increasingly libraries ship with ".pc" files that allow querying of the
compiler and linker flags needed to use them through the pkg-config(1)
program.

Alternatives

Package Version Architecture Repository
pkg-config_0.29.1-0ubuntu2_i386.deb 0.29.1 i386 Ubuntu Main
pkg-config - - -

Requires

Name Value
dpkg-dev -
libc6 >= 2.14
libdpkg-perl -
libglib2.0-0 >= 2.16.0

Download

Type URL
Binary Package pkg-config_0.29.1-0ubuntu2_amd64.deb
Source Package pkg-config

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pkg-config deb package:
    # sudo apt-get install pkg-config

Files

Path
/etc/dpkg/dpkg.cfg.d/pkg-config-hook-config
/usr/bin/pkg-config
/usr/bin/x86_64-pc-linux-gnu-pkg-config
/usr/lib/pkg-config.multiarch
/usr/share/pkg-config-crosswrapper
/usr/share/pkg-config-dpkghook
/usr/share/aclocal/pkg.m4
/usr/share/doc/pkg-config/AUTHORS
/usr/share/doc/pkg-config/NEWS.gz
/usr/share/doc/pkg-config/README
/usr/share/doc/pkg-config/changelog.Debian.gz
/usr/share/doc/pkg-config/copyright
/usr/share/doc/pkg-config/pkg-config-guide.html
/usr/share/man/man1/pkg-config.1.gz

Changelog

2017-04-21 - Steve Langasek <steve.langasek@ubuntu.com>
pkg-config (0.29.1-0ubuntu2) artful; urgency=medium
* No-change rebuild to pick up -fPIE compiler default in static
libraries
2016-04-06 - Matthias Klose <doko@ubuntu.com>
pkg-config (0.29.1-0ubuntu1) xenial; urgency=medium
* Merge with Debian; remaining changes:
- On Ubuntu, in pkg-config-crosswrapper add /usr/lib/pkgconfig to
PKG_CONFIG_LIBDIR. As a lot of packages that are cross-build on
regular basis rely on cross-building with non-multiarched libraries.
- add dpkg-dev dependency, as dpkg-architecture binary is called from
wrapper.
* New upstream version 0.29.1.
- Fix regression quoting variables. LP: #1523508.
* Fix build failure with recent glib2.0.
2016-01-15 - Tollef Fog Heen <tfheen@debian.org>
pkg-config (0.29-3) unstable; urgency=medium
* Store pkg-config architecture in /usr/lib/pkg-config.multiarch and
pick that up in the crosswrapper.  Closes: #807289, #807946
2015-12-14 - Matthias Klose <doko@ubuntu.com>
pkg-config (0.29-2ubuntu2) xenial; urgency=medium
* Fix pkg-config-crosswrapper to do something for cross builds.
2015-11-19 - Dimitri John Ledkov <xnox@ubuntu.com>
pkg-config (0.29-2ubuntu1) xenial; urgency=low
* Merge from Debian unstable.  Remaining changes:
- On Ubuntu, in pkg-config-crosswrapper add /usr/lib/pkgconfig to
PKG_CONFIG_LIBDIR. As a lot of packages that are cross-build on
regular basis rely on cross-building with non-multiarched libraries.
- add dpkg-dev dependency, as dpkg-architecture binary is called from
wrapper.
2015-11-15 - Tollef Fog Heen <tfheen@debian.org>
pkg-config (0.29-2) unstable; urgency=medium
* Fix typo in crosswrapper.
* Add set -e to postinst and prerm
2015-11-15 - Tollef Fog Heen <tfheen@debian.org>
pkg-config (0.29-1) unstable; urgency=medium
* Drop unused build-dep on libpopt-dev.  Closes: #751897
* Add symlinks to pkg-config-crosswrapper using dpkg hooks. Thanks to
Helmut Grohne for this, both design and implementation. Closes: #759556
* Export LC_ALL=C in debian/rules to make the build more reproducible.
Closes: #792821
* Remove fixing of test running, it now works out of the box.
* Correct spelling of pkg-config in debian/copyright.
* Add missing quoting for arguments in crosswrapper.
* Make crosswrapper handle native builds correctly.
2014-05-23 - Dimitri John Ledkov <xnox@ubuntu.com>
pkg-config (0.28-1ubuntu1) utopic; urgency=medium
* On Ubuntu, in pkg-config-crosswrapper add /usr/lib/pkgconfig to
PKG_CONFIG_LIBDIR. As a lot of packages that are cross-build on
regular basis rely on cross-building with non-multiarched libraries.
2014-04-23 - Tollef Fog Heen <tfheen@debian.org>
pkg-config (0.28-1) unstable; urgency=medium
* New upstream release.  (Closes: #699476, #744031)
- Updated man page with fewer errors. (Closes: #661838)
* Fix test running with newer automake.
* Drop popt stuff from debian/rules, upstream no longer ships popt.
2014-03-24 - Wookey <wookey@debian.org>
pkg-config (0.26-1+autoconf) unreleased; urgency=medium
* Non-maintainer upload.
* Update config.{sub,guess} for new arches (with dh-autoreconf) (Closes: #742665)
* Add Multiarch metadata (M-A: foreign), so this package can
satisfy cross- build-dependencies. The cross-build environment is
responsible for providing the $triplet-pkg-config symlink to
pkg-config-crosswrapper. (Closes: #726598)
* Update crosswrapper script to search multiarch paths, traditional
cross-compilation paths, arch-independent paths, and /usr/local counterparts.
Thanks to Simon McVittie, Steve Langasek, Vincent Danjean, Wookey
(Closes: #642292, #650298, #631275)
* Make pkg-config itself cross-buildable. (Closes: #716918)

See Also

Package Description
pkg-php-tools_1.35ubuntu1_all.deb various packaging tools and scripts for PHP packages
pkgbinarymangler_138_all.deb strips translations and alters maintainers during build
plainbox-secure-policy_0.25-1_all.deb policykit policy required to use plainbox (secure version)
plymouth-label_0.9.3-1ubuntu7_amd64.deb boot animation, logger and I/O multiplexer - label control
plymouth-theme-ubuntu-logo_0.9.3-1ubuntu7_amd64.deb boot animation, logger and I/O multiplexer - ubuntu theme
plymouth-theme-ubuntu-text_0.9.3-1ubuntu7_amd64.deb boot animation, logger and I/O multiplexer - ubuntu text theme
plymouth_0.9.3-1ubuntu7_amd64.deb boot animation, logger and I/O multiplexer
po-debconf_1.0.20_all.deb tool for managing templates file translations with gettext
policykit-1-doc_0.105-20_all.deb documentation for PolicyKit-1
policykit-1-gnome_0.105-6ubuntu2_amd64.deb authentication agent for PolicyKit
policykit-1_0.105-20_amd64.deb framework for managing administrative policies and privileges
policykit-desktop-privileges_0.20_all.deb run common desktop actions without password
policyrcd-script-zg2_0.1-3_all.deb policy-compliant interface from invoke-rc.d to local config files
pollinate_4.31-0ubuntu1_all.deb seed the pseudo random number generator
poppler-data_0.4.8-2_all.deb encoding data for the poppler PDF rendering library
Advertisement
Advertisement