pastebinit_1.5-2_all.deb


Advertisement

Description

pastebinit - command-line pastebin client

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name pastebinit
Package version 1.5
Package release 2
Package architecture all
Package type deb
Installed size 156 B
Download size 14.28 KB
Official Mirror archive.ubuntu.com
pastebinit is a command-line tool to send data to a "pastebin", a web site
which allows its users to upload snippets of text for public viewing.

Alternatives

Package Version Architecture Repository
pastebinit_1.5-2_all.deb 1.5 all Ubuntu Main
pastebinit - - -

Requires

Name Value
python3 -

Replaces

Name Value
bikeshed << 1.21

Download

Type URL
Binary Package pastebinit_1.5-2_all.deb
Source Package pastebinit

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pastebinit deb package:
    # sudo apt-get install pastebinit

Files

Path
/usr/bin/pastebinit
/usr/bin/pbget
/usr/bin/pbput
/usr/bin/pbputs
/usr/share/doc/pastebinit/README
/usr/share/doc/pastebinit/changelog.Debian.gz
/usr/share/doc/pastebinit/copyright
/usr/share/man/man1/pastebinit.1.gz
/usr/share/man/man1/pbget.1.gz
/usr/share/man/man1/pbput.1.gz
/usr/share/man/man1/pbputs.1.gz
/usr/share/pastebin.d/cxg.de.conf
/usr/share/pastebin.d/dpaste.com.conf
/usr/share/pastebin.d/fpaste.org.conf
/usr/share/pastebin.d/lpaste.net.conf
/usr/share/pastebin.d/p.defau.lt.conf
/usr/share/pastebin.d/paste.debian.net.conf
/usr/share/pastebin.d/paste.openstack.org.conf
/usr/share/pastebin.d/paste.pound-python.org.conf
/usr/share/pastebin.d/paste.ubuntu.com.conf
/usr/share/pastebin.d/paste.ubuntu.org.cn.conf
/usr/share/pastebin.d/paste2.org.conf
/usr/share/pastebin.d/pastebin.com.conf
/usr/share/pastebin.d/slexy.org.conf
/usr/share/pastebin.d/sprunge.us.conf

Changelog

2018-04-15 - Rolf Leggewie <foss@rolf.leggewie.biz>
pastebinit (1.5-2) unstable; urgency=medium
* control:
- update VCS URIs to point to github
- update Debian Standard to 4.1.4
* copyright: update to 2018
2016-03-01 - Rolf Leggewie <foss@rolf.leggewie.biz>
pastebinit (1.5-1) unstable; urgency=medium
* new upstream release
- add https support. Closes: #799580, closes: #708206.
- add support for hidden pastes. Closes: #670485.
- correct mistake in README. LP: #1446433
* drop all Debian patches since they were applied upstream
* control: update to Debian standard 3.9.7
* copyright: update copyright to 2016
2016-01-05 - Rolf Leggewie <foss@rolf.leggewie.biz>
pastebinit (1.4-6) unstable; urgency=medium
[ Alberto Fuentes ]
* patches: fix format line in slexy.org configuration. Closes: #743394
2015-10-17 - Rolf Leggewie <foss@rolf.leggewie.biz>
pastebinit (1.4-5) UNRELEASED; urgency=medium
[ Bart Martens ]
* watch: make the syntax more robust
[ Rolf Leggewie ]
* control:
- drop now-obsolete recommendation for lsb-release package
- update to standard 3.9.6. No further changes.
* add script to help with collection of bug triage information
2015-02-17 - Rolf Leggewie <foss@rolf.leggewie.biz>
pastebinit (1.4-4) unstable; urgency=medium
[ Andrew Starr-Bochicchio ]
* detect_distro_with_python3.patch: Use platform instead of
lsb_release to detect the distro as lsb_release is not
available under Python 3 (Closes: #760341). pastebinit
will now default again to using paste.debian.net on Debian
(Closes: #778336).
2014-02-08 - Rolf Leggewie <foss@rolf.leggewie.biz>
pastebinit (1.4-3) unstable; urgency=low
* bump debhelper to version 9
* control: drop some obsolete python options
2014-01-18 - Rolf Leggewie <foss@rolf.leggewie.biz>
pastebinit (1.4-2) unstable; urgency=low
* patches:
~ update upstream to r205. Fix unicode problem. LP: #1270359
This essentially gives us upstream release 1.4.1
~ increase timeout to 15s to account for bad networks
* watch: only check for 2-level (major.minor) upstream releases
* drop preinst script as obsolete
2014-01-17 - Rolf Leggewie <foss@rolf.leggewie.biz>
pastebinit (1.4-1) unstable; urgency=low
[ Bart Martens ]
* update watch file
[ Rolf Leggewie ]
* new upstream release 1.4
- upstream bugfixes
~ crash in create_connection(). LP: #1032221
~ point shebang to python3. LP: #988468
~ allow calling pastebin by basename. Closes: #705979, LP: #977331
~ allow pasting several files at once. Closes: #662242
- control: bump python to python3 in run-time dependencies
remove python-configobj from run-time dependencies
- drop all debian-patches as obsolete
* control:
- drop obsolete DMUA field
- update to standard version 3.9.5. No further changes.
* copyright: update upstream and my copyright to 2014
2012-06-13 - Rolf Leggewie <foss@rolf.leggewie.biz>
pastebinit (1.3-4) unstable; urgency=low
[ St├ęphane Graber ]
* backport new pastebin.com config from 1.3.1. Closes: 673311,LP: #996242
[ Rolf Leggewie ]
* debian/control: add python-support to build-depends
* debian/pastebinit.preinst: use set -e rather than shebang equivalent
* reinstate pastebin.com as default pastebin
2012-05-20 - Rolf Leggewie <foss@rolf.leggewie.biz>
pastebinit (1.3-3) unstable; urgency=low
* debian/control:
- use Breaks instead of Conflicts for the bikeshed package
- bump to standard 3.9.3, no further changes
- recommend the lsb-release package
* move to dh7 rules.tiny for the build process. Closes: #616933
* replace pastebin.com with paste.debian.net as default pastebin
until the breakage from their API change has been fixed upstream

See Also

Package Description
patch_2.7.6-2ubuntu1_amd64.deb Apply a diff file to an original
patchutils_0.3.4-2_amd64.deb Utilities to work with patches
pax_20171021-2_amd64.deb Portable Archive Interchange (cpio, pax, tar)
pbuilder_0.229.1_all.deb personal package builder for Debian packages
pciutils_3.5.2-1ubuntu1_amd64.deb Linux PCI Utilities
pcmciautils_018-8build1_amd64.deb PCMCIA utilities for Linux 2.6
perl-base_5.26.1-6_amd64.deb minimal Perl system
perl-debug_5.26.1-6_amd64.deb debug-enabled Perl interpreter
perl-doc_5.26.1-6_all.deb Perl documentation
perl-modules-5.26_5.26.1-6_all.deb Core Perl modules
perl-openssl-defaults_3build1_amd64.deb version compatibility baseline for Perl OpenSSL packages
perl_5.26.1-6_amd64.deb Larry Wall's Practical Extraction and Report Language
php-all-dev_60ubuntu1_all.deb package depending on all supported PHP development packages
php-cgi_7.2+60ubuntu1_all.deb server-side, HTML-embedded scripting language (CGI binary) (default)
php-cli_7.2+60ubuntu1_all.deb command-line interpreter for the PHP scripting language (default)
Advertisement
Advertisement