odbcinst_2.3.4-1.1ubuntu3_amd64.deb


Advertisement

Description

odbcinst - Helper program for accessing odbc ini files

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name odbcinst
Package version 2.3.4
Package release 1.1ubuntu3
Package architecture amd64
Package type deb
Installed size 52 B
Download size 12.14 KB
Official Mirror archive.ubuntu.com
This package contains the odbcinst helper tool, which allows ODBC driver
packages to install their own driver settings.

Alternatives

Package Version Architecture Repository
odbcinst_2.3.4-1.1ubuntu3_i386.deb 2.3.4 i386 Ubuntu Main
odbcinst - - -

Requires

Name Value
libc6 >= 2.4
odbcinst1debian2 >= 2.3.1

Conflicts

Name Value
odbcinst1 -

Replaces

Name Value
odbcinst1 -
odbcinst1debian1 << 2.2.11-20
unixodbc << 2.1.1-2

Download

Type URL
Binary Package odbcinst_2.3.4-1.1ubuntu3_amd64.deb
Source Package unixodbc

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install odbcinst deb package:
    # sudo apt-get install odbcinst

Files

Path
/etc/odbc.ini
/usr/bin/odbcinst
/usr/share/doc/odbcinst/NEWS.Debian.gz
/usr/share/doc/odbcinst/changelog.Debian.gz
/usr/share/doc/odbcinst/copyright
/usr/share/man/man1/odbcinst.1.gz

Changelog

2018-03-26 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
unixodbc (2.3.4-1.1ubuntu3) bionic; urgency=medium
* Add CVE-2018-7409 fix back and fix length when calling
unicode_to_ansi_copy() in DriverManager/SQLDriverConnectW.c.
2018-03-24 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
unixodbc (2.3.4-1.1ubuntu2) bionic; urgency=medium
* Revert CVE-2018-7409 fix as it seems to have introduced a regression.
2018-03-09 - Marc Deslauriers <marc.deslauriers@ubuntu.com>
unixodbc (2.3.4-1.1ubuntu1) bionic; urgency=medium
* SECURITY UPDATE: overflow in unicode_to_ansi_copy()
- DriverManager/__info.c: properly null-terminate string, use strncat.
- https://sourceforge.net/p/unixodbc/code/136/
- CVE-2018-7409
2017-11-07 - Hugh McMaster <hugh.mcmaster@outlook.com>
unixodbc (2.3.4-1.1) unstable; urgency=medium
* Non-maintainer upload.
* debian/control:
- Mark unixodbc-dev Multi-Arch: same (Closes: #872411).
- Depend on libltdl-dev instead of libltdl3-dev.
* debian/rules:
- Compile with --enable-fastvalidate to avoid performance degradation
when working with large numbers of handles (Closes: #819622).
- Move unixodbc_conf.h to /usr/include/<triplet> to avoid
a file conflict on multi-arch systems.
2016-12-12 - Steve Langasek <vorlon@debian.org>
unixodbc (2.3.4-1) unstable; urgency=medium
* New upstream release.  Closes: #843847.
- Drop patches to autogenerated files in the source tree, since we use
dh-autoreconf already.
- Drop AM_MAINTAINER_MODE, no longer needed due to the above.
- Drop no-longer-used lintian override.
* Standards-Version to 3.9.8.
2016-09-29 - Steve Langasek <vorlon@debian.org>
unixodbc (2.3.1-5) unstable; urgency=low
* Make unixodbc-dev depend directly on libodbc1, not just transitively
via unixodbc, now that unixodbc is Multi-Arch: foreign.
Closes: #839170.
* Fix unixodbc-dev package section.  Closes: #813991.
2016-04-04 - John Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de>
unixodbc (2.3.1-4.1) unstable; urgency=medium
* Non-maintainer upload.
* Use AC_CONFIG_MACRO_DIR([libltdl/m4]) in configure.in
instead of ACLOCAL_AMFLAGS=-I libltdl/m4 in Makefile.am
to add libltdl/m4 macro directory. Closes: #818407.
2015-10-07 - Steve Langasek <vorlon@debian.org>
unixodbc (2.3.1-4) unstable; urgency=medium
* odbcinst/_SQLGetInstalledDrivers.c: don't open /etc/odbcinst.ini for
writing when we never write to it.  Closes: #801258.
2014-04-30 - Steve Langasek <vorlon@debian.org>
unixodbc (2.3.1-3) unstable; urgency=low
* DriverManager/SQLConnect.c: put a mutex around the call to
lt_dlsetsearchpath(), to avoid double-frees in a multithreaded context.
Closes: #746423.
2014-04-06 - Steve Langasek <vorlon@debian.org>
unixodbc (2.3.1-2) unstable; urgency=medium
* Use dh-autoreconf instead of a homegrown autotools target; this fixes
problems caused by config.sub having the wrong permissions in the upstream
tarball.  Closes: #738516.

See Also

Package Description
oem-config-debconf_18.04.14_all.deb debconf frontend for end-user post-OEM-install configuration
oem-config-gtk_18.04.14_all.deb GTK+ frontend for end-user post-OEM-install configuration
oem-config-slideshow-ubuntu_138_all.deb OEM slideshow for Ubuntu
oem-config_18.04.14_all.deb Perform end-user configuration after initial OEM installation
open-iscsi_2.0.874-5ubuntu2_amd64.deb iSCSI initiator tools
open-vm-tools-dev_10.2.0-3ubuntu3_amd64.deb Open VMware Tools for virtual machines hosted on VMware (development)
open-vm-tools_10.2.0-3ubuntu3_amd64.deb Open VMware Tools for virtual machines hosted on VMware (CLI)
opencl-c-headers_2.2~2018.02.21-gb5c3680-1_all.deb OpenCL (Open Computing Language) C header files
openexr-doc_2.2.0-11.1ubuntu1_all.deb documentation and examples for the OpenEXR image format
openhpid_3.6.1-3.1build1_amd64.deb OpenHPI daemon, supports gathering of manageability information
openipmi_2.0.22-1.1ubuntu2_amd64.deb Intelligent Platform Management Interface (for servers)
openjdk-11-doc_10.0.1+10-3ubuntu1_all.deb OpenJDK Development Kit (JDK) documentation
openjdk-11-jdk-headless_10.0.1+10-3ubuntu1_amd64.deb OpenJDK Development Kit (JDK) (headless)
openjdk-11-jdk_10.0.1+10-3ubuntu1_amd64.deb OpenJDK Development Kit (JDK)
openjdk-11-jre-headless_10.0.1+10-3ubuntu1_amd64.deb OpenJDK Java runtime, using Hotspot JIT (headless)
Advertisement
Advertisement