lvm2_2.02.176-4.1ubuntu3_amd64.deb


Advertisement

Description

lvm2 - Linux Logical Volume Manager

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name lvm2
Package version 2.02.176
Package release 4.1ubuntu3
Package architecture amd64
Package type deb
Installed size 3.23 KB
Download size 906.85 KB
Official Mirror archive.ubuntu.com
This is LVM2, the rewrite of The Linux Logical Volume Manager.  LVM
supports enterprise level volume management of disk and disk subsystems
by grouping arbitrary disks into volume groups. The total capacity of
volume groups can be allocated to logical volumes, which are accessed as
regular block devices.

Alternatives

Package Version Architecture Repository
lvm2_2.02.176-4.1ubuntu3_i386.deb 2.02.176 i386 Ubuntu Main
lvm2 - - -

Requires

Name Value
dmeventd -
dmsetup >= 1.02.145-2~
libblkid1 >= 2.24.2
libc6 >= 2.17
libdevmapper-event1.02.1 >= 2:1.02.74
libdevmapper1.02.1 >= 2:1.02.141
liblvm2app2.2 >= 2.02.176
libreadline5 >= 5.2
libsystemd0 >= 222
libudev1 >= 183
lsb-base -

Download

Type URL
Binary Package lvm2_2.02.176-4.1ubuntu3_amd64.deb
Source Package lvm2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lvm2 deb package:
    # sudo apt-get install lvm2

Files

Path
/etc/init.d/lvm2
/etc/init.d/lvm2-lvmetad
/etc/init.d/lvm2-lvmpolld
/etc/lvm/lvm.conf
/etc/lvm/lvmlocal.conf
/etc/lvm/profile/cache-mq.profile
/etc/lvm/profile/cache-smq.profile
/etc/lvm/profile/command_profile_template.profile
/etc/lvm/profile/lvmdbusd.profile
/etc/lvm/profile/metadata_profile_template.profile
/etc/lvm/profile/thin-generic.profile
/etc/lvm/profile/thin-performance.profile
/lib/systemd/system/blk-availability.service
/lib/systemd/system/lvm2-lvmetad.service
/lib/systemd/system/lvm2-lvmetad.socket
/lib/systemd/system/lvm2-lvmpolld.service
/lib/systemd/system/lvm2-lvmpolld.socket
/lib/systemd/system/lvm2-monitor.service
/lib/systemd/system/lvm2-pvscan@.service
/lib/systemd/system/lvm2.service
/lib/systemd/system-generators/lvm2-activation-generator
/lib/udev/rules.d/56-lvm.rules
/lib/udev/rules.d/69-lvm-metad.rules
/sbin/fsadm
/sbin/lvchange
/sbin/lvconvert
/sbin/lvcreate
/sbin/lvdisplay
/sbin/lvextend
/sbin/lvm
/sbin/lvmconf
/sbin/lvmconfig
/sbin/lvmdiskscan
/sbin/lvmdump
/sbin/lvmetad
/sbin/lvmpolld
/sbin/lvmsadc
/sbin/lvmsar
/sbin/lvreduce
/sbin/lvremove
/sbin/lvrename
/sbin/lvresize
/sbin/lvs
/sbin/lvscan
/sbin/pvchange
/sbin/pvck
/sbin/pvcreate
/sbin/pvdisplay
/sbin/pvmove
/sbin/pvremove
/sbin/pvresize
/sbin/pvs
/sbin/pvscan
/sbin/vgcfgbackup
/sbin/vgcfgrestore
/sbin/vgchange
/sbin/vgck
/sbin/vgconvert
/sbin/vgcreate
/sbin/vgdisplay
/sbin/vgexport
/sbin/vgextend
/sbin/vgimport
/sbin/vgimportclone
/sbin/vgmerge
/sbin/vgmknodes
/sbin/vgreduce
/sbin/vgremove
/sbin/vgrename
/sbin/vgs
/sbin/vgscan
/sbin/vgsplit
/usr/lib/tmpfiles.d/lvm2.conf
/usr/share/doc/lvm2/changelog.Debian.gz
/usr/share/doc/lvm2/copyright
/usr/share/doc/lvm2/lvm2-raid.txt.gz
/usr/share/doc/lvm2/lvm_fault_handling.txt.gz
/usr/share/doc/lvm2/lvmetad_design.txt.gz
/usr/share/doc/lvm2/lvmpolld_overview.txt
/usr/share/doc/lvm2/pvmove_outline.txt
/usr/share/doc/lvm2/tagging.txt.gz
/usr/share/doc/lvm2/testing.txt
/usr/share/doc/lvm2/udev_assembly.txt
/usr/share/initramfs-tools/hooks/lvm2
/usr/share/initramfs-tools/scripts/init-bottom/lvm2
/usr/share/initramfs-tools/scripts/init-premount/lvm2
/usr/share/initramfs-tools/scripts/local-block/lvm2
/usr/share/initramfs-tools/scripts/local-top/lvm2
/usr/share/man/man5/lvm.conf.5.gz
/usr/share/man/man7/lvmcache.7.gz
/usr/share/man/man7/lvmraid.7.gz
/usr/share/man/man7/lvmreport.7.gz
/usr/share/man/man7/lvmsystemid.7.gz
/usr/share/man/man7/lvmthin.7.gz
/usr/share/man/man8/fsadm.8.gz
/usr/share/man/man8/lvchange.8.gz
/usr/share/man/man8/lvconvert.8.gz
/usr/share/man/man8/lvcreate.8.gz
/usr/share/man/man8/lvdisplay.8.gz
/usr/share/man/man8/lvextend.8.gz
/usr/share/man/man8/lvm-config.8.gz
/usr/share/man/man8/lvm-dumpconfig.8.gz
/usr/share/man/man8/lvm-fullreport.8.gz
/usr/share/man/man8/lvm-lvpoll.8.gz
/usr/share/man/man8/lvm.8.gz
/usr/share/man/man8/lvm2-activation-generator.8.gz
/usr/share/man/man8/lvmconf.8.gz
/usr/share/man/man8/lvmconfig.8.gz
/usr/share/man/man8/lvmdiskscan.8.gz
/usr/share/man/man8/lvmdump.8.gz
/usr/share/man/man8/lvmetad.8.gz
/usr/share/man/man8/lvmpolld.8.gz
/usr/share/man/man8/lvmsadc.8.gz
/usr/share/man/man8/lvmsar.8.gz
/usr/share/man/man8/lvreduce.8.gz
/usr/share/man/man8/lvremove.8.gz
/usr/share/man/man8/lvrename.8.gz
/usr/share/man/man8/lvresize.8.gz
/usr/share/man/man8/lvs.8.gz
/usr/share/man/man8/lvscan.8.gz
/usr/share/man/man8/pvchange.8.gz
/usr/share/man/man8/pvck.8.gz
/usr/share/man/man8/pvcreate.8.gz
/usr/share/man/man8/pvdisplay.8.gz
/usr/share/man/man8/pvmove.8.gz
/usr/share/man/man8/pvremove.8.gz
/usr/share/man/man8/pvresize.8.gz
/usr/share/man/man8/pvs.8.gz
/usr/share/man/man8/pvscan.8.gz
/usr/share/man/man8/vgcfgbackup.8.gz
/usr/share/man/man8/vgcfgrestore.8.gz
/usr/share/man/man8/vgchange.8.gz
/usr/share/man/man8/vgck.8.gz
/usr/share/man/man8/vgconvert.8.gz
/usr/share/man/man8/vgcreate.8.gz
/usr/share/man/man8/vgdisplay.8.gz
/usr/share/man/man8/vgexport.8.gz
/usr/share/man/man8/vgextend.8.gz
/usr/share/man/man8/vgimport.8.gz
/usr/share/man/man8/vgimportclone.8.gz
/usr/share/man/man8/vgmerge.8.gz
/usr/share/man/man8/vgmknodes.8.gz
/usr/share/man/man8/vgreduce.8.gz
/usr/share/man/man8/vgremove.8.gz
/usr/share/man/man8/vgrename.8.gz
/usr/share/man/man8/vgs.8.gz
/usr/share/man/man8/vgscan.8.gz
/usr/share/man/man8/vgsplit.8.gz

Changelog

2018-04-12 - Julian Andres Klode <juliank@ubuntu.com>
lvm2 (2.02.176-4.1ubuntu3) bionic; urgency=medium
* scripts/blkdeactivate.sh.in: Refer to /usr/bin/sort, not /bin/sort
2018-01-30 - Julian Andres Klode <juliank@ubuntu.com>
lvm2 (2.02.176-4.1ubuntu2) bionic; urgency=medium
* Demote Recommends: thin-provisioning-tools to Suggests, as it's not
in main.
2018-01-26 - Julian Andres Klode <juliank@ubuntu.com>
lvm2 (2.02.176-4.1ubuntu1) bionic; urgency=low
* Merge with Debian unstable. Remaining changes:
- Add and install clvmd resource agent
- Lower libdevmapper1.02.1's Depends: dmsetup to a Recommends:. This
breaks the circular dependency that causes upgrade failures. As dmsetup
is "Priority: required", this has no other practical consequences.
- debian/control: add dmsetup-udeb to libdevmapper1.02.1-udeb recommends.
- debian/dmsetup-udeb.install: install udev rules in udebs
(Debian #504341).
- Add debian/initramfs-tools/lvm2/scripts/init-bottom/lvm2: We cannot
properly synthesize LVM LV change events with udevadm trigger, so
if we use LVM, we need to let it finish; otherwise we get missing LV
symlinks.
- Add debian/initramfs-tools/lvm2/scripts/init-premount/lvm2: failure
hooks to help fix bad boots (Debian #468115)
- Do not start lvmetad when inside a container.
- Add enable-issue-discards.patch: Enable "issue_discards" option by
default to trim SSDs when changing PVs. This option has no effect if the
kernel or the drive does not support trimming, so it's safe to enable by
default. (Debian #717313)
- debian/rules:
+ Copy .po file to .pot file for Rosetta (Ubuntu specific).
- debian/initramfs-tools/lvm2/hooks/lvm2: depend on udev since
we ship udev rules.
- debian/clvm.maintscripts: Drop the /etc/default/clvm conffile on
upgrade.  This delta can be dropped after 18.04 release.
- Do not start lvm2-monitor in containers (LP #1576341)
* Dropped, merged upstream:
- Add a patch to fix crashes on 32bit platforms:
+ 0013-fix-lvmetad-32bit.patch
- d/p/fix-strips-limit.patch: Fix regression limiting number of
stripes to 8 (LP #1675770)
2017-12-03 - Cyril Brulebois <kibi@debian.org>
lvm2 (2.02.176-4.1) unstable; urgency=high
* Non-maintainer upload.
* Revert uncoordinated addition of udev rules/sync support in udebs
which breaks LVM support in debian-installer instead of getting
debian-installer and installed systems to agree on device names.
(closes: #883361, reopens: #504341)
2017-11-10 - Bastian Blank <waldi@debian.org>
lvm2 (2.02.176-4) unstable; urgency=medium
* Don't try to add dropped udev rules to initramfs.
2017-11-10 - Bastian Blank <waldi@debian.org>
lvm2 (2.02.176-3) unstable; urgency=medium
* Actually add newly installed udev rules to initramfs.
(closes: #881314)
* Make initramfs hooks bail out if udev rules can't be found.
* Copy complete lvm config into initramfs.
2017-11-09 - Bastian Blank <waldi@debian.org>
lvm2 (2.02.176-2) unstable; urgency=medium
* Drop changes for upgrades from before Wheezy.
* Drop deprecated python bindings.
* Enable udev rules in udeb. (closes: #504341)
* Drop some udev rules modifications.
- Pull in newer dmsetup for udev rules changes.
2017-11-04 - Bastian Blank <waldi@debian.org>
lvm2 (2.02.176-1) unstable; urgency=medium
* New upstream release.
* Drop obsolte build-depends on dh-systemd.
* Drop extra priorities from packages.
* Update Standards-Version to 4.1.1, no changes.
* Make lvm2-dbusd depend manually on required modules. (closes: #880543)
* Make lvm2 recommend thin-provisioning-tools. (closes: #857142)
* Run pvscan as systemd background job.
* Don't try to restart special systemd services.
* Really use debhelper compat 11.
2017-11-01 - Bastian Blank <waldi@debian.org>
lvm2 (2.02.175-1) unstable; urgency=medium
* New upstream release.
* Enable sanlock support in lvmlockd.
* Use debhelper compat 11 for dh_installsystemd.

See Also

Package Description
lxc-dev_3.0.0-0ubuntu2_all.deb Transitional package - lxc-dev -> liblxc-dev
lxcfs_3.0.0-0ubuntu1_amd64.deb FUSE based filesystem for LXC
lxd-client_3.0.0-0ubuntu4_amd64.deb Container hypervisor based on LXC - client
lxd_3.0.0-0ubuntu4_amd64.deb Container hypervisor based on LXC - daemon
m17n-db_1.7.0-2_all.deb multilingual text processing library - database
m4-doc_1.4.18-1_all.deb Documentation for GNU m4
m4_1.4.18-1_amd64.deb macro processing language
maas-cli_2.4.0~beta2-6865-gec43e47e6-0ubuntu1_all.deb MAAS client and command-line interface
maas-common_2.4.0~beta2-6865-gec43e47e6-0ubuntu1_all.deb MAAS server common files
maas-dhcp_2.4.0~beta2-6865-gec43e47e6-0ubuntu1_all.deb MAAS DHCP server
maas-enlist_0.4+bzr38-0ubuntu3_amd64.deb MAAS enlistment tool
maas-proxy_2.4.0~beta2-6865-gec43e47e6-0ubuntu1_all.deb MAAS Caching Proxy
maas-rack-controller_2.4.0~beta2-6865-gec43e47e6-0ubuntu1_all.deb Rack Controller for MAAS
maas-region-api_2.4.0~beta2-6865-gec43e47e6-0ubuntu1_all.deb Region controller API service for MAAS
maas-region-controller_2.4.0~beta2-6865-gec43e47e6-0ubuntu1_all.deb Region Controller for MAAS
Advertisement
Advertisement