lsb-base_9.20170808ubuntu1_all.deb


Advertisement

Description

lsb-base - Linux Standard Base init script functionality

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name lsb-base
Package version 9.20170808ubuntu1
Package architecture all
Package type deb
Installed size 58 B
Download size 12.17 KB
Official Mirror archive.ubuntu.com
The Linux Standard Base (http://www.linuxbase.org/) is a standard
core system that third-party applications written for Linux can
depend upon.
This package only includes the init-functions shell library, which
may be used by other packages' initialization scripts for console
logging and other purposes.

Alternatives

Package Version Architecture Repository
lsb-base_9.20170808ubuntu1_all.deb 9.20170808ubuntu1 all Ubuntu Main
lsb-base - - -

Download

Type URL
Binary Package lsb-base_9.20170808ubuntu1_all.deb
Source Package lsb

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install lsb-base deb package:
    # sudo apt-get install lsb-base

Files

Path
/lib/lsb/init-functions
/lib/lsb/init-functions.d/20-left-info-blocks
/lib/lsb/init-functions.d/50-ubuntu-logging
/usr/share/doc/lsb-base/NEWS.Debian.gz
/usr/share/doc/lsb-base/README.Debian.gz
/usr/share/doc/lsb-base/changelog.gz
/usr/share/doc/lsb-base/copyright

Changelog

2017-12-05 - Steve Langasek <steve.langasek@ubuntu.com>
lsb (9.20170808ubuntu1) bionic; urgency=low
* Merge from Debian unstable.  Remaining changes:
- Re-added LSB compatibility packages, so that auto-downloadable
LSB-based printer driver packages work.
- Added Conflicts/Replaces against cups-filters-invalid-mta and
cups-filters-lsb for upgrade compatibility from the Xenial development
cycle.
- lsb_release.py: restore support for querying the list of installed
modules, since for the moment some modules are still supported.
- Make the 'lsb' package depend on libjpeg62 as well, known to be needed
by printer driver packages.
* Dropped changes:
- 01-upstart-lsb: obsoleted upstream, no longer used in Ubuntu.
2017-08-07 - Didier Raboud <odyx@debian.org>
lsb (9.20170808) unstable; urgency=medium
* Remove Jeff Licquia from Uploaders, with thanks for his past work
(Closes: #854224)
* Fix number-to-release typo in lsb-release's README.Debian (Closes: #862041)
2017-08-07 - Didier Raboud <odyx@debian.org>
lsb (9.20170807) unstable; urgency=medium
* Remove the lsb-compat package to force migration away from LSB packages
* Update Homepage URL
* Update Vcs-* URLs for https counterparts
* Bump Standards-Version to 4.0.1
2016-11-25 - Didier Raboud <odyx@debian.org>
lsb (9.20161125) unstable; urgency=medium
[ Didier Raboud ]
* Test the distro-info non-Debian fallback, to fix #845489
* Also run the tests for all pyversions (Python 2.7 only)
* Fix regressions on python2 (Closes: #845489)
[ Philipp Hahn ]
* Strip leading spaces in get_lsb_header_val (Closes: #837639)
2016-11-01 - Didier Raboud <odyx@debian.org>
lsb (9.20161101) unstable; urgency=medium
[ Helmut Grohne ]
* Fix FTCBFS: Annotate Build-Depends: python3-all with :any (Closes: #841679)
* Add support for DEB_BUILD_OPTIONS=nocheck
2016-10-16 - Didier Raboud <odyx@debian.org>
lsb (9.20161016) unstable; urgency=medium
* Introduce the new lsb-compat package, providing a limited compatibility
layer for some selected LSB packages
- Provides, and replaces lsb & lsb-core
- Should be sufficient to install and run:
- Epson printer drivers (LP: #1536353)
- Google Earth (Closes: #830481)
2016-06-29 - Didier Raboud <odyx@debian.org>
lsb (9.20160629) unstable; urgency=medium
[ Helge Deller ]
* Update lsb_release.py to cope with the new Debian Ports' release label
(Closes: #827137)
2016-06-01 - Didier Raboud <odyx@debian.org>
lsb (9.20160601) unstable; urgency=medium
* Revert "Add 01-upstart-lsb from the upstart package, and make executing
rc.d scripts no-op if there is an upstart job for that script"
(Closes: #825946)
* Bump Standards-Version to 3.9.8 without changes needed
2016-07-06 - Steve Langasek <steve.langasek@ubuntu.com>
lsb (9.20160110ubuntu5) yakkety; urgency=medium
* Revert changes to python2 vs. python3 installation of lsb_release.py,
inadvertently breaking imports of lsb_release in python2.  LP: #1596638.
2016-06-22 - Steve Langasek <steve.langasek@ubuntu.com>
lsb (9.20160110ubuntu4) yakkety; urgency=medium
* Make the 'lsb' package depend on libjpeg62 as well, known to be needed
by printer driver packages.

See Also

Package Description
lsb-release_9.20170808ubuntu1_all.deb Linux Standard Base version reporting utility
lshw_02.18-0.1ubuntu6_amd64.deb information about hardware configuration
lsof_4.89+dfsg-0.1_amd64.deb Utility to list open files
lsscsi_0.28-0.1_amd64.deb list all SCSI devices (or hosts) currently on system
ltrace_0.7.3-6ubuntu1_amd64.deb Tracks runtime library calls in dynamically linked programs
lua-rrd-dev_1.7.0-1build1_amd64.deb time-series data storage and display system (Lua development)
lua-rrd_1.7.0-1build1_amd64.deb time-series data storage and display system (Lua interfaces)
lua5.2-doc_5.2.4-1.1build1_all.deb Documentation for the Lua language version 5.2
lupin-casper_0.57build1_all.deb Add support for loop-mount installations to casper
lupin-support_0.57build1_amd64.deb Support files for loop-mount installations
lvm2_2.02.176-4.1ubuntu3_amd64.deb Linux Logical Volume Manager
lxc-dev_3.0.0-0ubuntu2_all.deb Transitional package - lxc-dev -> liblxc-dev
lxcfs_3.0.0-0ubuntu1_amd64.deb FUSE based filesystem for LXC
lxd-client_3.0.0-0ubuntu4_amd64.deb Container hypervisor based on LXC - client
lxd_3.0.0-0ubuntu4_amd64.deb Container hypervisor based on LXC - daemon
Advertisement
Advertisement