libxdmcp6_1.1.2-3_amd64.deb


Advertisement

Description

libxdmcp6 - X11 Display Manager Control Protocol library

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package name libxdmcp6
Package version 1.1.2
Package release 3
Package architecture amd64
Package type deb
Installed size 39 B
Download size 10.48 KB
Official Mirror archive.ubuntu.com
This package provides the main interface to the X11 display manager control
protocol library, which allows for remote logins to display managers.
More information about X.Org can be found at:
<URL:http://www.X.org>
This module can be found at
git://anongit.freedesktop.org/git/xorg/lib/libXdmcp

Alternatives

Package Version Architecture Repository
libxdmcp6_1.1.2-3_i386.deb 1.1.2 i386 Ubuntu Main
libxdmcp6 - - -

Requires

Name Value
libbsd0 >= 0.2.0
libc6 >= 2.4

Download

Type URL
Binary Package libxdmcp6_1.1.2-3_amd64.deb
Source Package libxdmcp

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libxdmcp6 deb package:
    # sudo apt-get install libxdmcp6

Files

Path
/usr/lib/x86_64-linux-gnu/libXdmcp.so.6
/usr/lib/x86_64-linux-gnu/libXdmcp.so.6.0.0
/usr/share/doc/libxdmcp6/changelog.Debian.gz
/usr/share/doc/libxdmcp6/copyright

Changelog

2017-03-02 - Julien Cristau <jcristau@debian.org>
libxdmcp (1:1.1.2-3) unstable; urgency=medium
* Merge 1:1.1.2-1.1 NMU, lost by mistake in 1:1.1.2-2.
2017-02-28 - Emilio Pozuelo Monfort <pochu@debian.org>
libxdmcp (1:1.1.2-2) unstable; urgency=medium
* CVE-2017-2625: Build-depend on libbsd-dev for arc4random_buf.
Closes: #856399.
2015-11-11 - Helmut Grohne <helmut@subdivi.de>
libxdmcp (1:1.1.2-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Remove &fullrelver; usage from doc/xdmcp.xml to make libxdmcp-dev M-A:same
safe when built with different versions of xorg-sgml-doctools. (closes:
#761628)
* Make usr/share/doc/libxdmcp-dev/xdmcp.txt.gz reproducible in the presence
of locales by exporting LC_ALL (closes: #783223).
2015-04-26 - Julien Cristau <jcristau@debian.org>
libxdmcp (1:1.1.2-1) unstable; urgency=medium
* Let uscan verify tarball signatures.
* New upstream release.
* Switch to dh with the autoreconf and quilt addons.
* Disable silent build rules.
* Remove Cyril from Uploaders.
2012-04-14 - Julien Cristau <jcristau@debian.org>
libxdmcp (1:1.1.1-1) unstable; urgency=low
* New upstream release.
* Don't require (fake)root for debian/rules clean.
* Exclude .db files from dh_install.
* Drop workaround from debian/rules for an upstream bug fixed in March 2006.
2011-11-08 - Steve Langasek <vorlon@debian.org>
libxdmcp (1:1.1.0-4) unstable; urgency=low
* Drop /usr/share/doc/libxdmcp-dev/xdmcp.html from the package; the
autogenerated contents with random node numbers mean that this is not
multiarch-friendly, and the same information is available in
xdmcp.txt.gz.
* Mark libxdmcp-dev Multi-Arch: same.
2011-06-12 - Julien Cristau <jcristau@debian.org>
libxdmcp (1:1.1.0-3) unstable; urgency=low
* Team upload.
* Don't put the debug symbols for the udeb in libxdmcp6-dbg.
* Add build-{arch,indep} debian/rules targets.
2011-06-07 - Julien Cristau <jcristau@debian.org>
libxdmcp (1:1.1.0-2) unstable; urgency=low
* Team upload.
[ Steve Langasek ]
* Build for multiarch.
[ Julien Cristau ]
* Remove David Nusinow from Uploaders.
* Standards-Version bumped to 3.9.2.
2010-11-06 - Cyril Brulebois <kibi@debian.org>
libxdmcp (1:1.1.0-1) unstable; urgency=low
* New upstream release.
* Bump xutils-dev build-dep for new macros.
* Add xmlto, xorg-sgml-doctools, and w3m build-dep for the doc.
* Pass --with-xmlto and --without-fop, we want html and txt only.
* Ship *.html, *.css, and *.txt from the doc directory.
* Kill *.xml in the doc directory, no point in shipping them.
* Switch from --list-missing to --fail-missing for additional safety.
* Exclude the .la file accordingly.
2010-03-09 - Cyril Brulebois <kibi@debian.org>
libxdmcp (1:1.0.3-2) unstable; urgency=low
[ Julien Cristau ]
* Rename the build directory to not include DEB_BUILD_GNU_TYPE for no
good reason.  Thanks, Colin Watson!
* Remove myself from Uploaders
[ Cyril Brulebois ]
* Add udeb needed for the graphical installer: libxdmcp6-udeb.
* Add myself to Uploaders.
* Bump Standards-Version from 3.8.3 to 3.8.4 (no changes needed).

See Also

Package Description
libxen-4.9_4.9.2-0ubuntu1_amd64.deb Public libs for Xen
libxen-dev_4.9.2-0ubuntu1_amd64.deb Public headers and libs for Xen
libxenstore3.0_4.9.2-0ubuntu1_amd64.deb Xenstore communications library for Xen
libxext-dev_1.3.3-1_amd64.deb X11 miscellaneous extensions library (development headers)
libxext-doc_1.3.3-1_all.deb X11 miscellaneous extensions library (documentation)
libxext6_1.3.3-1_amd64.deb X11 miscellaneous extension library
libxfixes-dev_5.0.3-1_amd64.deb X11 miscellaneous 'fixes' extension library (development headers)
libxfixes3_5.0.3-1_amd64.deb X11 miscellaneous 'fixes' extension library
libxfont-dev_2.0.3-1_amd64.deb X11 font rasterisation library (development headers)
libxfont2_2.0.3-1_amd64.deb X11 font rasterisation library
libxft-dev_2.3.2-1_amd64.deb FreeType-based font drawing library for X (development files)
libxft2_2.3.2-1_amd64.deb FreeType-based font drawing library for X
libxi-dev_1.7.9-1_amd64.deb X11 Input extension library (development headers)
libxi6_1.7.9-1_amd64.deb X11 Input extension library
libxinerama-dev_1.1.3-1_amd64.deb X11 Xinerama extension library (development headers)
Advertisement
Advertisement