liblist-moreutils-perl_0.416-1build3_amd64.deb


Advertisement

Description

liblist-moreutils-perl - Perl module with additional list functions not found in List::Util

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Main amd64
Package name liblist-moreutils-perl
Package version 0.416
Package release 1build3
Package architecture amd64
Package type deb
Installed size 177 B
Download size 54.25 KB
Official Mirror archive.ubuntu.com
List::MoreUtils provides some trivial but commonly needed functionality on
lists which is not going to go into List::Util.
All of the functions are implementable in only a couple of lines of Perl
code. Using the functions from this module however should give slightly better
performance as everything is implemented in C. The pure-Perl implementation of
these functions only serves as a fallback in case the C portions of this module
could not be compiled on this machine.

Alternatives

Package Version Architecture Repository
liblist-moreutils-perl_0.416-1build3_i386.deb 0.416 i386 Ubuntu Main
liblist-moreutils-perl - - -

Requires

Name Value
libc6 >= 2.4
libexporter-tiny-perl -
perl >= 5.26.0-4
perlapi-5.26.0 -

Download

Type URL
Binary Package liblist-moreutils-perl_0.416-1build3_amd64.deb
Source Package liblist-moreutils-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liblist-moreutils-perl deb package:
    # sudo apt-get install liblist-moreutils-perl

Files

Path
/usr/lib/x86_64-linux-gnu/perl5/5.26/List/MoreUtils.pm
/usr/lib/x86_64-linux-gnu/perl5/5.26/List/MoreUtils/Contributing.pod
/usr/lib/x86_64-linux-gnu/perl5/5.26/List/MoreUtils/PP.pm
/usr/lib/x86_64-linux-gnu/perl5/5.26/List/MoreUtils/XS.pm
/usr/lib/x86_64-linux-gnu/perl5/5.26/auto/List/MoreUtils/MoreUtils.so
/usr/share/doc/liblist-moreutils-perl/changelog.Debian.gz
/usr/share/doc/liblist-moreutils-perl/copyright
/usr/share/doc/liblist-moreutils-perl/examples/41097.pl
/usr/share/doc/liblist-moreutils-perl/examples/41494.pl
/usr/share/doc/liblist-moreutils-perl/examples/48669.pl
/usr/share/doc/liblist-moreutils-perl/examples/49796.pl
/usr/share/doc/liblist-moreutils-perl/examples/57499.pl
/usr/share/doc/liblist-moreutils-perl/examples/58325.pl
/usr/share/doc/liblist-moreutils-perl/examples/README
/usr/share/man/man3/List::MoreUtils.3pm.gz
/usr/share/man/man3/List::MoreUtils::Contributing.3pm.gz
/usr/share/man/man3/List::MoreUtils::PP.3pm.gz
/usr/share/man/man3/List::MoreUtils::XS.3pm.gz

Changelog

2017-07-26 - Matthias Klose <doko@ubuntu.com>
liblist-moreutils-perl (0.416-1build3) artful; urgency=medium
* No-change rebuild for perl 5.26.0.
2016-10-24 - Iain Lane <iain@orangesquash.org.uk>
liblist-moreutils-perl (0.416-1build2) zesty; urgency=medium
* No-change rebuild for perl 5.24 transition
2016-10-23 - Iain Lane <iain@orangesquash.org.uk>
liblist-moreutils-perl (0.416-1build1) zesty; urgency=medium
* No-change rebuild for perl 5.24
2016-07-12 - Salvatore Bonaccorso <carnil@debian.org>
liblist-moreutils-perl (0.416-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.416
* Drop fix-spelling-error-in-manpage.patch patch
* Drop Fix-caller-information-passed-down-the-stack.patch patch
* Update requirements on perl version in (Build-)Depends
src:perl 5.22.2-2 contains the fix for CVE-2016-6185.
2016-07-04 - Salvatore Bonaccorso <carnil@debian.org>
liblist-moreutils-perl (0.415-1) unstable; urgency=medium
* Team upload.
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* debian/upstream/metadata: change GitHub/CPAN URL(s) to HTTPS.
[ Salvatore Bonaccorso ]
* Import upstream version 0.415
* Update copyright years for upstream files
* Update copyright years for included Config::AutoConf
* Simplify Build-Depends on just only perl.
The alternative version used as well to enforce the right version for
Test::More is already satisfied in wheezy. Make only a Build-Depends to
perl (unversioned).
* Declare compliance with Debian policy 3.9.8
* Drop unneeded patch makefile-author.patch (resolved in different way
upstream)
* debian/rules: Build enabling all hardening flags
* Add patch to fix spelling errors in Contributing POD
* Fix caller information passed down the stack.
List/MoreUtils/XS.pm calls XSLoader::load from inside a string eval
leading to the path used by XSLoader to determine the library to be
(eval 1)/List/MoreUtils/XS.pm.
Thanks to Jakub Wilk <jwilk@debian.org> (Closes: #829138)
2015-06-26 - gregor herrmann <gregoa@debian.org>
liblist-moreutils-perl (0.413-1) unstable; urgency=medium
* Import upstream version 0.413.
* debian/copyright: drop stanzas about removed bundled modules.
* Add patch to remove "author" check from Makefile.PL.
The condition is a check for a .git directory.
* Make package buildable-twice-in-a-row.
Remove a log which is not cleaned up.
Backup bundled modules which get modified.
2015-05-01 - gregor herrmann <gregoa@debian.org>
liblist-moreutils-perl (0.410-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* New upstream release.
* Add debian/upstream/metadata
* Update upstream and packaging copyright.
* Declare compliance with Debian Policy 3.9.6.
* Update build and runtime dependencies.
2014-03-06 - intrigeri <intrigeri@debian.org>
liblist-moreutils-perl (0.33-2) unstable; urgency=low
* Team upload.
[ Alessandro Ghedini ]
* Email change: Alessandro Ghedini -> ghedo@debian.org
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ gregor herrmann ]
* debian/control: remove Nicholas Bamber from Uploaders on request of
the MIA team.
* Strip trailing slash from metacpan URLs.
[ intrigeri ]
* Bump debhelper compat level to 9.
* Declare compatibility with Standards-Version 3.9.5.
* Adjust versioned Build-Depends on debhelper to (>= 9.20120312~)
to get hardening build flags.

See Also

Package Description
liblld-6.0-dev_6.0-1ubuntu2_amd64.deb LLVM-based linker, header files
liblld-6.0_6.0-1ubuntu2_amd64.deb LLVM-based linker, library
libllvm3.9_3.9.1-19ubuntu1_amd64.deb Modular compiler and toolchain technologies, runtime library
libllvm6.0_6.0-1ubuntu2_amd64.deb Modular compiler and toolchain technologies, runtime library
liblocale-gettext-perl_1.07-3build2_amd64.deb module using libc functions for internationalization in Perl
liblockfile-bin_1.14-1.1_amd64.deb support binaries for and cli utilities based on liblockfile
liblockfile-dev_1.14-1.1_amd64.deb Development library for liblockfile
liblockfile1_1.14-1.1_amd64.deb NFS-safe locking library
liblouis-data_3.5.0-1_all.deb Braille translation library - data
liblouis-dev_3.5.0-1_amd64.deb Braille translation library - static libs and headers
liblouis14_3.5.0-1_amd64.deb Braille translation library - shared libs
liblouisutdml-bin_2.7.0-1_amd64.deb Braille UTDML translation utilities
liblouisutdml-data_2.7.0-1_all.deb Braille UTDML translation library - data
liblouisutdml-dev_2.7.0-1_amd64.deb Braille UTDML translation library - static libs and headers
liblouisutdml-java-doc_2.7.0-1_all.deb Braille UTDML translation library - java bindings documentation
Advertisement
Advertisement