libcgi-pm-perl_4.38-1_all.deb


Advertisement

Description

libcgi-pm-perl - module for Common Gateway Interface applications

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Main amd64
Package filename libcgi-pm-perl_4.38-1_all.deb
Package name libcgi-pm-perl
Package version 4.38
Package release 1
Package architecture all
Package type deb
Category perl
Homepage https://metacpan.org/release/CGI
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 181.11 KB
Installed size 446.00 KB
CGI.pm is a Perl module that provides classes useful for creating Web forms
and for parsing their contents. It defines CGI objects, entities that contain
the values of the current query string and other state variables.

Alternatives

Package Version Architecture Repository
libcgi-pm-perl_4.38-1_all.deb 4.38 all Ubuntu Main
libcgi-pm-perl - - -

Requires

Name Value
libhtml-parser-perl -
perl -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libcgi-pm-perl_4.38-1_all.deb
Source Package libcgi-pm-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcgi-pm-perl deb package:
    # sudo apt-get install libcgi-pm-perl

Files

Path
/usr/share/doc/libcgi-pm-perl/NEWS.Debian.gz
/usr/share/doc/libcgi-pm-perl/README.md.gz
/usr/share/doc/libcgi-pm-perl/changelog.Debian.gz
/usr/share/doc/libcgi-pm-perl/copyright
/usr/share/doc/libcgi-pm-perl/examples/clickable_image.cgi
/usr/share/doc/libcgi-pm-perl/examples/cookie.cgi
/usr/share/doc/libcgi-pm-perl/examples/crash.cgi
/usr/share/doc/libcgi-pm-perl/examples/file_upload.cgi
/usr/share/doc/libcgi-pm-perl/examples/mojo_proxy.pl
/usr/share/doc/libcgi-pm-perl/examples/wikipedia_example.cgi
/usr/share/doc/libcgi-pm-perl/examples/wilogo.gif
/usr/share/man/man3/CGI.3pm.gz
/usr/share/man/man3/CGI::Carp.3pm.gz
/usr/share/man/man3/CGI::Cookie.3pm.gz
/usr/share/man/man3/CGI::HTML::Functions.3pm.gz
/usr/share/man/man3/CGI::Pretty.3pm.gz
/usr/share/man/man3/CGI::Push.3pm.gz
/usr/share/man/man3/CGI::Util.3pm.gz
/usr/share/perl5/CGI.pm
/usr/share/perl5/CGI.pod
/usr/share/perl5/Fh.pm
/usr/share/perl5/CGI/Carp.pm
/usr/share/perl5/CGI/Cookie.pm
/usr/share/perl5/CGI/Pretty.pm
/usr/share/perl5/CGI/Push.pm
/usr/share/perl5/CGI/Util.pm
/usr/share/perl5/CGI/File/Temp.pm
/usr/share/perl5/CGI/HTML/Functions.pm
/usr/share/perl5/CGI/HTML/Functions.pod

Changelog

2017-12-12 - Damyan Ivanov <dmn@debian.org>
libcgi-pm-perl (4.38-1) unstable; urgency=medium
* declare conformance with Policy 4.1.2 (no changes needed)
* New upstream version 4.38
2017-11-02 - Damyan Ivanov <dmn@debian.org>
libcgi-pm-perl (4.37-1) unstable; urgency=medium
* New upstream version 4.37
+ Fix incorrect quoting of ? in ->url (GH #112, GH #222, with thanks to
Reuben Thomas)
* declare conformance with Policy 4.1.1 (no changes needed)
2017-07-11 - gregor herrmann <gregoa@debian.org>
libcgi-pm-perl (4.36-1) unstable; urgency=medium
* Import upstream version 4.36.
* Update years of packaging copyright.
* Declare compliance with Debian Policy 4.0.0.
2016-10-29 - gregor herrmann <gregoa@debian.org>
libcgi-pm-perl (4.35-1) unstable; urgency=medium
* Remove AGOSTINI Yves and Jonathan Yu from Uploaders.
Thanks for your work!
* Import upstream version 4.35.
2016-07-20 - gregor herrmann <gregoa@debian.org>
libcgi-pm-perl (4.32-1) unstable; urgency=medium
* Import upstream version 4.32.
* Update debian/upstream/metadata.
2016-07-18 - gregor herrmann <gregoa@debian.org>
libcgi-pm-perl (4.31-1) unstable; urgency=medium
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* Import upstream version 4.31.
The MultipartBuffer package has been renamed to CGI::MultipartBuffer.
* Update build dependencies.
* Declare compliance with Debian Policy 3.9.8.
2016-03-14 - gregor herrmann <gregoa@debian.org>
libcgi-pm-perl (4.28-1) unstable; urgency=medium
* Import upstream version 4.28
* Drop build dependency on libtest-nowarnings-perl.
* autopkgtest: skip t/compiles_pod.t which wants to run Test::Pod::* on
*.pm files in the source tree which doesn't exist during autopkgtest,
and fails over planning 0 tests.
2016-02-12 - gregor herrmann <gregoa@debian.org>
libcgi-pm-perl (4.26-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* Import upstream version 4.26.
* Declare compliance with Debian Policy 3.9.7.
2016-01-07 - gregor herrmann <gregoa@debian.org>
libcgi-pm-perl (4.25-1) unstable; urgency=medium
* Import upstream version 4.25.
* Update years of packaging copyright.
2015-10-17 - gregor herrmann <gregoa@debian.org>
libcgi-pm-perl (4.22-1) unstable; urgency=medium
* Import upstream version 4.22
* Bump debhelper compatibility level to 9.

See Also

Package Description
libcharon-extra-plugins_5.6.2-1ubuntu2_amd64.deb strongSwan charon library (extra plugins)
libcharon-standard-plugins_5.6.2-1ubuntu2_amd64.deb strongSwan charon library (standard plugins)
libchart-perl_2.4.10ds1-2_all.deb Chart library for Perl
libcheese-dev_3.28.0-1ubuntu1_amd64.deb tool to take pictures and videos from your webcam - base dev
libcheese-doc_3.28.0-1ubuntu1_all.deb tool to take pictures and videos from your webcam - documentation
libcheese-gtk-dev_3.28.0-1ubuntu1_amd64.deb tool to take pictures and videos from your webcam - widgets dev
libcheese-gtk25_3.28.0-1ubuntu1_amd64.deb tool to take pictures and videos from your webcam - widgets
libcheese8_3.28.0-1ubuntu1_amd64.deb tool to take pictures and videos from your webcam - base library
libchewing3-data_0.5.1-1_all.deb intelligent phonetic input method library - data files
libchewing3-dev_0.5.1-1_amd64.deb intelligent phonetic input method library (developer version)
libchewing3_0.5.1-1_amd64.deb intelligent phonetic input method library
libcholmod3_5.1.2-2_amd64.deb sparse Cholesky factorization library for sparse matrices
libcib-dev_1.1.18-0ubuntu1_amd64.deb cluster resource manager CIB library development
libcib4_1.1.18-0ubuntu1_amd64.deb cluster resource manager CIB library
libcilkrts5-armhf-cross_7.3.0-16ubuntu3cross1_all.deb Intel Cilk Plus language extensions (runtime)
Advertisement
Advertisement