libarchive-zip-perl_1.59-1ubuntu0.1_all.deb


Advertisement

Description

libarchive-zip-perl - Perl module for manipulation of ZIP archives

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Updates Main amd64
Package name libarchive-zip-perl
Package version 1.59
Package release 1ubuntu0.1
Package architecture all
Package type deb
Installed size 268 B
Download size 82.59 KB
Official Mirror archive.ubuntu.com
The Archive::Zip module allows a Perl program to create, manipulate,
read, and write Zip archive files.
Zip archives can be created, or you can read from existing zip files.
Once created, they can be written to files, streams, or strings.
Members can be added, removed, extracted, replaced, rearranged, and
enumerated.  They can also be renamed or have their dates, comments,
or other attributes queried or modified.  Their data can be
compressed or uncompressed as needed.  Members can be created from
members in existing Zip files, or from existing directories, files,
or strings.

Alternatives

Package Version Architecture Repository
libarchive-zip-perl_1.59-1ubuntu0.1_all.deb 1.59 all Ubuntu Updates Main
libarchive-zip-perl_1.59-1_all.deb 1.59 all Ubuntu Main
libarchive-zip-perl_1.59-1_all.deb 1.59 all Ubuntu Main
libarchive-zip-perl - - -

Requires

Name Value
perl -

Download

Type URL
Binary Package libarchive-zip-perl_1.59-1ubuntu0.1_all.deb
Source Package libarchive-zip-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libarchive-zip-perl deb package:
    # sudo apt-get install libarchive-zip-perl

Changelog

2018-07-03 - Leonidas S. Barbosa <leo.barbosa@canonical.com>
libarchive-zip-perl (1.59-1ubuntu0.1) artful-security; urgency=medium
* SECURITY UPDATE: Traversal path vulnerability
- debian/patches/CVE-2018-10860.patch: fix in
lib/Archive/Zip/Archive.pm and add test in
t/25_traversal.t and some .zip files for test.
- CVE-2018-10860
2016-08-12 - Salvatore Bonaccorso <carnil@debian.org>
libarchive-zip-perl (1.59-1) unstable; urgency=medium
* Import upstream version 1.59
2016-08-02 - Salvatore Bonaccorso <carnil@debian.org>
libarchive-zip-perl (1.58-1) unstable; urgency=medium
[ gregor herrmann ]
* Change bugtracker URL(s) to HTTPS.
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
[ Salvatore Bonaccorso ]
* Import upstream version 1.58
* Declare compliance with Debian policy 3.9.8
2016-04-02 - Salvatore Bonaccorso <carnil@debian.org>
libarchive-zip-perl (1.57-1) unstable; urgency=medium
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
* Import upstream version 1.57
* Update copyright years for debian/* packaging files
* Declare compliance with Debian policy 3.9.7
2016-01-02 - Salvatore Bonaccorso <carnil@debian.org>
libarchive-zip-perl (1.56-2) unstable; urgency=medium
* Upload to unstable
2015-12-20 - Salvatore Bonaccorso <carnil@debian.org>
libarchive-zip-perl (1.56-1) experimental; urgency=medium
* Import upstream version 1.56
2015-12-05 - gregor herrmann <gregoa@debian.org>
libarchive-zip-perl (1.55-1) unstable; urgency=medium
* Team upload.
* Rename autopkgtest configuration file(s) as per new pkg-perl-
autopkgtest schema.
* Import upstream version 1.55.
* Add new build dependency: libtest-mockmodule-perl.
2015-09-23 - Salvatore Bonaccorso <carnil@debian.org>
libarchive-zip-perl (1.53-1) unstable; urgency=medium
* Import upstream version 1.53
2015-09-22 - Salvatore Bonaccorso <carnil@debian.org>
libarchive-zip-perl (1.51-1) unstable; urgency=medium
* Import upstream version 1.51
2015-09-04 - gregor herrmann <gregoa@debian.org>
libarchive-zip-perl (1.50-1) unstable; urgency=medium
* Team upload.
[ Salvatore Bonaccorso ]
* Import upstream version 1.50
[ gregor herrmann ]
* Remove Matthias Klose from Uploaders on his request.
* Bump debhelper compatibility level to 9.

See Also

Package Description
libasan2_5.5.0-1ubuntu2_amd64.deb AddressSanitizer -- a fast memory error detector
libasan4_7.2.0-8ubuntu3.2_amd64.deb AddressSanitizer -- a fast memory error detector
libatomic1_7.2.0-8ubuntu3.2_amd64.deb support library providing __atomic built-in functions
libavahi-client-dev_0.6.32-1ubuntu1.1_amd64.deb Development files for the Avahi client library
libavahi-client3_0.6.32-1ubuntu1.1_amd64.deb Avahi client library
libavahi-common-data_0.6.32-1ubuntu1.1_amd64.deb Avahi common data files
libavahi-common-dev_0.6.32-1ubuntu1.1_amd64.deb Development files for the Avahi common library
libavahi-common3_0.6.32-1ubuntu1.1_amd64.deb Avahi common library
libavahi-compat-libdnssd-dev_0.6.32-1ubuntu1.1_amd64.deb Development headers for the Avahi Apple Bonjour compatibility library
libavahi-compat-libdnssd1_0.6.32-1ubuntu1.1_amd64.deb Avahi Apple Bonjour compatibility library
libavahi-core-dev_0.6.32-1ubuntu1.1_amd64.deb Development files for Avahi's embeddable mDNS/DNS-SD library
libavahi-core7_0.6.32-1ubuntu1.1_amd64.deb Avahi's embeddable mDNS/DNS-SD library
libavahi-glib-dev_0.6.32-1ubuntu1.1_amd64.deb Development headers for the Avahi GLib integration library
libavahi-glib1_0.6.32-1ubuntu1.1_amd64.deb Avahi GLib integration library
libavahi-gobject-dev_0.6.32-1ubuntu1.1_amd64.deb Development headers for the Avahi GObject library
Advertisement
Advertisement