python-pudb_2017.1.2-2_all.deb


Advertisement

Description

python-pudb - full-screen, console-based Python debugger

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name python-pudb
Package version 2017.1.2
Package release 2
Package architecture all
Package type deb
Installed size 250 B
Download size 44.44 KB
Official Mirror archive.ubuntu.com
PuDB is a full-screen, console-based visual debugger for Python.
Its goal is to provide all the niceties of modern GUI-based debuggers
in a more lightweight and keyboard-friendly package. PuDB allows you
to debug code right where you write and test it -- in a terminal. If
you've worked with the excellent (but nowadays ancient) DOS-based
Turbo Pascal or C tools, PuDB's UI might look familiar.

Alternatives

Package Version Architecture Repository
python-pudb_2017.1.2-2_all.deb 2017.1.2 all Ubuntu Universe
python-pudb - - -

Requires

Name Value
dpkg >= 1.15.6~
python-pygments >= 1.0
python-urwid >= 1.1.1
python:any >= 2.7.5-5~
python:any << 2.8

Provides

Name Value
python2.7-pudb -

Download

Type URL
Binary Package python-pudb_2017.1.2-2_all.deb
Source Package pudb

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-pudb deb package:
    # sudo apt-get install python-pudb

Files

Path
/usr/bin/pudb
/usr/lib/python2.7/dist-packages/pudb/__init__.py
/usr/lib/python2.7/dist-packages/pudb/__main__.py
/usr/lib/python2.7/dist-packages/pudb/b.py
/usr/lib/python2.7/dist-packages/pudb/debugger.py
/usr/lib/python2.7/dist-packages/pudb/ipython.py
/usr/lib/python2.7/dist-packages/pudb/lowlevel.py
/usr/lib/python2.7/dist-packages/pudb/py3compat.py
/usr/lib/python2.7/dist-packages/pudb/remote.py
/usr/lib/python2.7/dist-packages/pudb/run.py
/usr/lib/python2.7/dist-packages/pudb/settings.py
/usr/lib/python2.7/dist-packages/pudb/shell.py
/usr/lib/python2.7/dist-packages/pudb/source_view.py
/usr/lib/python2.7/dist-packages/pudb/theme.py
/usr/lib/python2.7/dist-packages/pudb/ui_tools.py
/usr/lib/python2.7/dist-packages/pudb/var_view.py
/usr/lib/python2.7/dist-packages/pudb-2017.1.2.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/pudb-2017.1.2.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/pudb-2017.1.2.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/pudb-2017.1.2.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/pudb-2017.1.2.egg-info/top_level.txt
/usr/share/doc/python-pudb/README.rst
/usr/share/doc/python-pudb/changelog.Debian.gz
/usr/share/doc/python-pudb/copyright
/usr/share/doc/python-pudb/examples/debug_me.py
/usr/share/doc/python-pudb/examples/try-the-debugger.sh
/usr/share/man/man1/pudb.1.gz

Changelog

2017-06-19 - Josue Ortega <josue@debian.org>
pudb (2017.1.2-2) unstable; urgency=medium
* Upload to unstable.
2017-04-15 - Josue Ortega <josue@debian.org>
pudb (2017.1.2-1) experimental; urgency=medium
* New upstream release (2107.1.2).
2017-02-25 - Josue Ortega <josue@debian.org>
pudb (2017.1.1-1) experimental; urgency=medium
* New upstream release (2017.1.1)
2017-02-18 - Josue Ortega <josue@debian.org>
pudb (2017.1-1) experimental; urgency=medium
* New upstream release (2017.1)
2016-06-24 - Josue Ortega <josue@debian.org>
pudb (2016.2-1) unstable; urgency=medium
* New upstream release 2016.2.
* debian/changelog:
- Bumps Standards version to 3.9.8, no changes required.
- Updates Josue Ortega uploaders mail.
- Changes VCS-* fields to secure URI.
2015-12-13 - Federico Ceratto <federico@debian.org>
pudb (2015.4.1-1) unstable; urgency=low
* New upstream release 2015.4.1
2015-06-14 - Josue Ortega <josueortega@debian.org.gt>
pudb (2015.3-1) unstable; urgency=medium
* New upstream release 2015.3
2015-02-08 - Federico Ceratto <federico.ceratto@gmail.com>
pudb (2015.1-1) unstable; urgency=low
[ Josue Ortega ]
* New upstream release 2015.1
* debian/control: Updated uploader email
* Standards-Version bumped to 3.9.6, no changes required
* debian/copyright: changed paragraph in order to avoid lintian false positive
warning: unused-file-paragraph-in-dep5-copyright.
* Removed installation of debian/wrappers/pudb since it's no longer needed and
was the cause of malfunctions on the pudb executable:
- Closes: #773257
- Closes: #773258
* Updated watch file
2014-03-28 - Federico Ceratto <federico.ceratto@gmail.com>
pudb (2014.1-1) unstable; urgency=low
* New upstream release 2014.1
2014-01-06 - David Paleino <dapal@debian.org>
pudb (2013.5.1-1) unstable; urgency=low
[ Federico Ceratto ]
* New upstream release 2013.5.1
* Switched to Pybuild
* Build Python3 binary package (Closes: #689655)
* Standards-Version bumped to 3.9.5, no changes required

See Also

Package Description
python-pulp_1.6.0+dfsg1-1build2_all.deb LP modeler - Python 2.7
python-purl_1.3.1-1_all.deb URL interrogation and manipulation
python-pushy_0.5.3-1ubuntu1_i386.deb Simple interface for connecting two python interpreters
python-pwquality_1.4.0-1_i386.deb Python bindings for libpwquality
python-py_1.4.34-2ubuntu1_all.deb Advanced Python development support library (Python 2)
python-pyalsa_1.0.29-1_i386.deb Official ALSA Python binding library
python-pyao_0.82-5build1_i386.deb Python interface to the Audio Output library
python-pyassimp_3.3.1~dfsg-5_all.deb 3D model import library (Python bindings)
python-pyatspi2_2.24.0+dfsg-1_all.deb Transitional package for assistive technology Python bindings
python-pyatspi_2.24.0+dfsg-1_all.deb Assistive Technology Service Provider Interface - Python bindings
python-pyaudio-doc_0.2.11-1build2_all.deb Documentation for Python bindings for PortAudio v19
python-pyaudio_0.2.11-1build2_i386.deb Python bindings for PortAudio v19
python-pyavm_0.9.4-1_all.deb Python module to handle Astronomy Visualization Metadata Standard
python-pybiggles_1.6.6-3_i386.deb Scientific plotting package for Python
python-pybigwig_0.3.2-1ubuntu5_i386.deb Python 2 module for quick access to bigBed and bigWig files
Advertisement
Advertisement