python-pexpect_4.2.1-1_all.deb


Advertisement

Description

python-pexpect - Python module for automating interactive applications

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name python-pexpect
Package version 4.2.1
Package release 1
Package architecture all
Package type deb
Installed size 182 B
Download size 40.77 KB
Official Mirror archive.ubuntu.com
Pexpect is a pure Python module for spawning child applications;
controlling them; and responding to expected patterns in their
output. Pexpect works like Don Libes' Expect. Pexpect allows your
script to spawn a child application and control it as if a human were
typing commands.

Alternatives

Package Version Architecture Repository
python-pexpect_4.2.1-1_all.deb 4.2.1 all Ubuntu Universe
python-pexpect - - -

Requires

Name Value
python-ptyprocess -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-pexpect_4.2.1-1_all.deb
Source Package pexpect

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-pexpect deb package:
    # sudo apt-get install python-pexpect

Files

Path
/usr/lib/python2.7/dist-packages/pexpect-4.2.1.egg-info
/usr/lib/python2.7/dist-packages/pexpect/ANSI.py
/usr/lib/python2.7/dist-packages/pexpect/FSM.py
/usr/lib/python2.7/dist-packages/pexpect/__init__.py
/usr/lib/python2.7/dist-packages/pexpect/bashrc.sh
/usr/lib/python2.7/dist-packages/pexpect/exceptions.py
/usr/lib/python2.7/dist-packages/pexpect/expect.py
/usr/lib/python2.7/dist-packages/pexpect/fdpexpect.py
/usr/lib/python2.7/dist-packages/pexpect/popen_spawn.py
/usr/lib/python2.7/dist-packages/pexpect/pty_spawn.py
/usr/lib/python2.7/dist-packages/pexpect/pxssh.py
/usr/lib/python2.7/dist-packages/pexpect/replwrap.py
/usr/lib/python2.7/dist-packages/pexpect/run.py
/usr/lib/python2.7/dist-packages/pexpect/screen.py
/usr/lib/python2.7/dist-packages/pexpect/spawnbase.py
/usr/lib/python2.7/dist-packages/pexpect/utils.py
/usr/share/doc/python-pexpect/changelog.Debian.gz
/usr/share/doc/python-pexpect/copyright

Changelog

2016-12-12 - Ondřej Nový <onovy@debian.org>
pexpect (4.2.1-1) unstable; urgency=medium
* Team upload.
* New upstream release
* Removed Ganesan Rajagopal from Uploaders (Closes: #839665)
* Bumped debhelper compat version to 10
* Removed privacy breach in docs
* d/copyright
- Added copyright holders for Debian part
- Added new upstream copyright holder
* wrap-and-sort -t -a
* Removed version from pre-wheezy dependency
* Enabled autopkgtest-pkg-python testsuite
* Bumped required version of Python to 2.7/3.3
2016-08-12 - Tobias Hansen <thansen@debian.org>
pexpect (4.2.0-1) unstable; urgency=medium
[ Ondřej Nový ]
* Fixed VCS URL (https)
[ Tobias Hansen ]
* New upstream release (Closes: #832772)
* Put Debian Python Modules Team into Maintainer field, the
package is maintained by different team members since 8 years.
* Add myself to Uploaders.
* Bump Standards-Version to 3.9.8.
* Bump dh compat to 9.
* Install without *.install files.
* Set http_proxy='127.0.0.1:9' for sphinx-build to prevent
internet access (Closes: #833860)
2015-11-06 - Javi Merino <vicho@debian.org>
pexpect (4.0.1-1) unstable; urgency=medium
* Team upload
* New upstream release (Closes: #744844)
* Bump standards-version to 3.9.6 (no change needed)
* Fix PyPI URL in debian/watch.  Thanks Lintian
* Build-depend on python-ptyprocess to generate the documentation
properly
* Depend on ptyprocess
2014-05-08 - Barry Warsaw <barry@debian.org>
pexpect (3.2-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* d/control: Add explicit dh-python Build-Depends.  (Closes: 744300)
2014-01-26 - Jackson Doak <noskcaj@ubuntu.com>
pexpect (3.1-1) unstable; urgency=medium
* Team upload.
* New upstream release
* debian/control: 
- In -doc, add breaks/replaces on python-pexcept <<3. Closes: #732915
- Drop python-pexcept-doc to Suggests in both other packages. 
Closes: #732889
- Bump standards-version to 3.9.5 (no changes)
2013-12-12 - Andrew Starr-Bochicchio <asb@debian.org>
pexpect (3.0-2) unstable; urgency=low
* Team upload.
* debian/copyright: Update to reflect upstreams change
from Expat to ISC (Closes: #731945). 
2013-12-06 - Andrew Starr-Bochicchio <asb@debian.org>
pexpect (3.0-1) unstable; urgency=low
* Team upload.
[ Thomas Kluyver ]
* New upstream release. Closes: #729518
* Add packaging for Python 3.
* Use pybuild for packaging.
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
[ Jackson Doak ]
* Create debian/python3-pexpect.docs
[ Andrew Starr-Bochicchio ]
* Remove empty debian/patches dir.
* Move documentation and examples into a new python-pexpect-doc
package. They are shared between the Python 2 and Python 3 packages,
so there is no need to install them with both.
2012-03-09 - Arthur de Jong <adejong@debian.org>
pexpect (2.4-1) unstable; urgency=low
* Team upload.
[ Arthur de Jong ]
* New upstream release (Closes: #609195).
* Switch to 3.0 (quilt) source format.
* Switch to dh-style debian/rules.
* Moved packaging from python-central to dh_python2 (Closes: #616935,
LP: #788514).
* Drop Conflicts/Replaces on ancient versions which shipped in sarge.
* Bump standards-version to 3.9.3.
* Register documentation with doc-base.
* Update debian/copyright (license is actually MIT instead of Python 2.3).
* Fix syntax errors in one of the examples (closes: #580271)
[ Piotr Ożarowski ]
* Added Vcs-Svn and Vcs-Browser fields
[ Sandro Tosi ]
* debian/control
- uniforming Vcs-Browser field
* debian/control
- switch Vcs-Browser field to viewsvn
[ Carlos Galisteo ]
* debian/control
- Added Homepage field.
2008-07-27 - Ganesan Rajagopal <rganesan@debian.org>
pexpect (2.3-1) unstable; urgency=low
* New upstream release.
* Fix lintian warnings:
- Move debhelper to Build-Depends from Build-Depends-Indep.
- Remove DH_COMPAT in debian/rules.
- Added debian/pycompat.
- Added #! line for examples/ssh_session.py.
* Updated standards version.

See Also

Package Description
python-pg8000-doc_1.10.6-1_all.deb Pure-Python PostgreSQL Driver (documentation)
python-pg8000_1.10.6-1_all.deb Pure-Python PostgreSQL Driver (Python 2)
python-pgmagick_0.6.5-1build1_i386.deb Yet Another Python wrapper for GraphicsMagick
python-pgpdump_1.5-1_all.deb PGP packet parser library (Python 2)
python-pgq3_3.2.6-5_i386.deb python framework for Skype tools for PostgreSQL replication
python-pgspecial_1.8.0-1_all.deb Meta-commands handler for Postgres Database (Python 2)
python-phabricator_0.7.0-1_all.deb Phabricator Python API Bindings (Python 2)
python-phoneutils_0.1+git20100219-2_i386.deb Python bindings for libphone-utils
python-photutils_0.3.2-2_i386.deb Astropy affiliated package for image photometry
python-phply_1.0.0-1_all.deb PHP parser written in Python using PLY
python-phpserialize_1.3-1_all.deb Python port of PHP serialize and unserialize functions (Python 2)
python-picklable-itertools_0.1.1-1_all.deb picklable reimplementation of Python's itertools
python-pickleshare_0.7.4-2_all.deb File system based database that uses Python pickles for Python 2
python-piggyphoto_0.1dev-git20141014_all.deb Python bindings for libgphoto2
python-pilkit_2.0-1_all.deb Utilities and processors built for, and on top of PIL (Python2 version)
Advertisement
Advertisement