python-pex_1.1.14-2ubuntu2_all.deb


Advertisement

Description

python-pex - library for generating Python executable zip files

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name python-pex
Package version 1.1.14
Package release 2ubuntu2
Package architecture all
Package type deb
Installed size 312 B
Download size 66.56 KB
Official Mirror archive.ubuntu.com
pex is a library for generating .pex (Python EXecutable) files which
are executable Python environments in the spirit of virtualenvs.  pex
is an expansion upon the ideas outlined in PEP 441 and makes the
deployment of Python applications as simple as cp.  pex files may even
include multiple platform-specific Python distributions, meaning that
a single pex file can be portable across Linux and OS X.
pex files can be built using the pex tool.  Build systems such as
Pants and Buck also support building .pex files directly.
This is the Python 2 library version.

Alternatives

Package Version Architecture Repository
python-pex_1.1.14-2ubuntu2_all.deb 1.1.14 all Ubuntu Universe
python-pex - - -

Requires

Name Value
python-pkg-resources -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-pex_1.1.14-2ubuntu2_all.deb
Source Package python-pex

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-pex deb package:
    # sudo apt-get install python-pex

Files

Path
/usr/lib/python2.7/dist-packages/pex/__init__.py
/usr/lib/python2.7/dist-packages/pex/archiver.py
/usr/lib/python2.7/dist-packages/pex/base.py
/usr/lib/python2.7/dist-packages/pex/common.py
/usr/lib/python2.7/dist-packages/pex/compatibility.py
/usr/lib/python2.7/dist-packages/pex/compiler.py
/usr/lib/python2.7/dist-packages/pex/crawler.py
/usr/lib/python2.7/dist-packages/pex/environment.py
/usr/lib/python2.7/dist-packages/pex/executor.py
/usr/lib/python2.7/dist-packages/pex/fetcher.py
/usr/lib/python2.7/dist-packages/pex/finders.py
/usr/lib/python2.7/dist-packages/pex/http.py
/usr/lib/python2.7/dist-packages/pex/installer.py
/usr/lib/python2.7/dist-packages/pex/interpreter.py
/usr/lib/python2.7/dist-packages/pex/iterator.py
/usr/lib/python2.7/dist-packages/pex/link.py
/usr/lib/python2.7/dist-packages/pex/orderedset.py
/usr/lib/python2.7/dist-packages/pex/package.py
/usr/lib/python2.7/dist-packages/pex/pep425.py
/usr/lib/python2.7/dist-packages/pex/pex.py
/usr/lib/python2.7/dist-packages/pex/pex_bootstrapper.py
/usr/lib/python2.7/dist-packages/pex/pex_builder.py
/usr/lib/python2.7/dist-packages/pex/pex_info.py
/usr/lib/python2.7/dist-packages/pex/platforms.py
/usr/lib/python2.7/dist-packages/pex/requirements.py
/usr/lib/python2.7/dist-packages/pex/resolvable.py
/usr/lib/python2.7/dist-packages/pex/resolver.py
/usr/lib/python2.7/dist-packages/pex/resolver_options.py
/usr/lib/python2.7/dist-packages/pex/sorter.py
/usr/lib/python2.7/dist-packages/pex/testing.py
/usr/lib/python2.7/dist-packages/pex/tracer.py
/usr/lib/python2.7/dist-packages/pex/translator.py
/usr/lib/python2.7/dist-packages/pex/util.py
/usr/lib/python2.7/dist-packages/pex/variables.py
/usr/lib/python2.7/dist-packages/pex/version.py
/usr/lib/python2.7/dist-packages/pex-1.1.14.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/pex-1.1.14.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/pex-1.1.14.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/pex-1.1.14.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/pex-1.1.14.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/pex-1.1.14.egg-info/zip-safe
/usr/lib/python2.7/dist-packages/pex/bin/__init__.py
/usr/lib/python2.7/dist-packages/pex/bin/pex.py
/usr/lib/python2.7/dist-packages/pex/commands/__init__.py
/usr/lib/python2.7/dist-packages/pex/commands/bdist_pex.py
/usr/share/doc/python-pex/changelog.Debian.gz
/usr/share/doc/python-pex/copyright

Changelog

2017-07-24 - Gianfranco Costamagna <locutusofborg@debian.org>
python-pex (1.1.14-2ubuntu2) artful; urgency=medium
* debian/patches/343.patch:
- Fix another python3.6 failure, related to upstream issue 29130
https://bugs.python.org/issue29130
2017-07-24 - Gianfranco Costamagna <locutusofborg@debian.org>
python-pex (1.1.14-2ubuntu1) artful; urgency=medium
* debian/patches/c5ab73fd4d8e816e21a89d48c8d0c8095ef5a49c.patch:
- fix build and testsuite with python3.6 with upstream cherry-pick
2016-09-22 - Barry Warsaw <barry@debian.org>
python-pex (1.1.14-2) unstable; urgency=medium
* d/patches/update-dependencies.patch: Remove ceiling dependency
versions since we have (or may eventually have) newer versions
which are still compatible.  This prevents trying to hit PyPI for
setuptools and wheel dependencies we still satisfy.  
(Closes: #838559)
* d/control: pex works better with requests, so add python3-requests
to Depends.
2016-08-03 - Barry Warsaw <barry@debian.org>
python-pex (1.1.14-1) unstable; urgency=medium
* New upstream release.
2016-05-09 - Barry Warsaw <barry@debian.org>
python-pex (1.1.6-1) unstable; urgency=medium
* New upstream release.
* d/patches/bump-setuptools-max-version.patch: Deleted; applied upstream.
* d/control:
- Bump Standards-Version to 3.9.8 with no other changes needed.
- Remove XS-Testsuite as it's now redundant.
2016-03-22 - Barry Warsaw <barry@debian.org>
python-pex (1.1.4-1) unstable; urgency=medium
* New upstream release.
* d/patches/bump-setuptools-max-version.patch: Update setuptools versions.
2016-02-22 - Barry Warsaw <barry@debian.org>
python-pex (1.1.2-1) unstable; urgency=medium
* New upstream release.
* d/control:
- Bump Standards-Version to 3.9.7 with no other changes needed.
- Update Vcs-Git header to https URL as per style guide.
* d/tests/{control,execute.sh}: Revert Ubuntu accommodations.
* d/patches: Updated by git-dpm.
* d/rules: in override_dh_auto_clean, there's no need to remove the
build/ directory explicitly, but we do need to remove the pex.1 file.
2015-10-15 - Barry Warsaw <barry@debian.org>
python-pex (1.1.0-2) unstable; urgency=medium
* d/control: Canonicalize the Vcs-* headers as per team standard.
* d/patches/bump-wheel-requirement-version.patch: Added.
* d/README.pex: Removed; upstream now includes the docs directory.
* d/python-pex-docs -> python-pex-doc.docs; fix the path.
* d/rules:
- Added override_dh_installdocs to build the Sphinx documentation.
- Added override_dh_auto_clean to remove the doc build directory.
* d/tests:
- Rewrite the execution test so that it's compatible between both
Ubuntu and Debian, negating the need for an Ubuntu delta.  The extra
required package is now conditionally installed depending on the
dpkg-vendor.  Also, by setting http_proxy and https_proxy to the
discard port, we ensure that pex cannot install from PyPI (it must
use system packages to resolve dependencies in the test).
- d/t/execute.sh: Added.
- d/t/control: Call execute.sh instead of using a Test-Command, and
add the needs-root Restriction (for the conditional `apt-get
install` in the script).
2015-10-12 - Barry Warsaw <barry@debian.org>
python-pex (1.1.0-1) unstable; urgency=medium
* New upstream release.
* d/control: Added python3-pkg-resources to pex Depends.

See Also

Package Description
python-pexif_0.15-1_all.deb Python EXIF parsing
python-pexpect_4.2.1-1_all.deb Python module for automating interactive applications
python-pg8000-doc_1.10.6-1_all.deb Pure-Python PostgreSQL Driver (documentation)
python-pg8000_1.10.6-1_all.deb Pure-Python PostgreSQL Driver (Python 2)
python-pgmagick_0.6.5-1build1_i386.deb Yet Another Python wrapper for GraphicsMagick
python-pgpdump_1.5-1_all.deb PGP packet parser library (Python 2)
python-pgq3_3.2.6-5_i386.deb python framework for Skype tools for PostgreSQL replication
python-pgspecial_1.8.0-1_all.deb Meta-commands handler for Postgres Database (Python 2)
python-phabricator_0.7.0-1_all.deb Phabricator Python API Bindings (Python 2)
python-phoneutils_0.1+git20100219-2_i386.deb Python bindings for libphone-utils
python-photutils_0.3.2-2_i386.deb Astropy affiliated package for image photometry
python-phply_1.0.0-1_all.deb PHP parser written in Python using PLY
python-phpserialize_1.3-1_all.deb Python port of PHP serialize and unserialize functions (Python 2)
python-picklable-itertools_0.1.1-1_all.deb picklable reimplementation of Python's itertools
python-pickleshare_0.7.4-2_all.deb File system based database that uses Python pickles for Python 2
Advertisement
Advertisement