python-nids_0.6.1-1.1_i386.deb


Advertisement

Description

python-nids - Python binding for libnids (aka pynids)

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name python-nids
Package version 0.6.1
Package release 1.1
Package architecture i386
Package type deb
Installed size 48 B
Download size 14.50 KB
Official Mirror archive.ubuntu.com
This package is commonly known as pynids. It is a Python wrapper for the
libnids packet capture analysis library, a Network Intrusion Detection
System library offering sniffing, IP defragmentation, TCP stream
reassembly and TCP port scan detection.

Alternatives

Package Version Architecture Repository
python-nids_0.6.1-1.1_amd64.deb 0.6.1 amd64 Ubuntu Universe
python-nids - - -

Requires

Name Value
libc6 >= 2.4
libpcap0.8 >= 0.9.8
python << 2.8
python >= 2.7~

Download

Type URL
Binary Package python-nids_0.6.1-1.1_i386.deb
Source Package python-nids

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-nids deb package:
    # sudo apt-get install python-nids

Files

Path
/usr/lib/python2.7/dist-packages/nids.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/pynids-0.6.1.egg-info
/usr/share/doc/python-nids/README.Debian
/usr/share/doc/python-nids/README.gz
/usr/share/doc/python-nids/changelog.Debian.gz
/usr/share/doc/python-nids/copyright
/usr/share/doc/python-nids/examples/Example

Changelog

2015-08-21 - Matthias Klose <doko@debian.org>
python-nids (0.6.1-1.1) unstable; urgency=low
* Non-maintainer upload.
[ Matthias Klose ]
* Build using dh-python. Closes: #786272.
[ Jari Aalto ]
* Remove deprecated dpatch and upgrade to packaging format "3.0 quilt".
Closes: #669938.
* Update to Standards-Version to 3.9.3 and debhelper to 9.
* Add build-arch and build-indep targets; use dh_prep in rules file.
* Fix helper-templates-in-copyright (Lintian).
* Fix debian-watch-file-is-missing (Lintian).
2010-05-31 - Luciano Bello <luciano@debian.org>
python-nids (0.6.1-1) unstable; urgency=low
* New upstream version:
- bump bundled libnids to 1.24
- support for packet timestamps
- support for pcap stats (JF)
* Linking with the shared library insted of the static one (closes:
#580723).
2010-04-22 - Luciano Bello <luciano@debian.org>
python-nids (0.6-1) unstable; urgency=low
* Initial release (Closes: #507718)

See Also

Package Description
python-nifti_0.20100607.1-4.1_i386.deb Python interface to the NIfTI I/O libraries
python-nine_1.0.0-1_all.deb Python 2 / 3 compatibility, like six, but favouring Python 3
python-nitime-doc_0.7-1_all.deb timeseries analysis for neuroscience data (nitime) -- documentation
python-nitime_0.7-1_all.deb timeseries analysis for neuroscience data (nitime)
python-nlopt_2.4.2+dfsg-3_i386.deb nonlinear optimization library -- Python bindings
python-nltk_3.2.4-1_all.deb Python libraries for natural language processing
python-nmap_0.6.1-1_all.deb Python interface to the Nmap port scanner
python-nmea2_1.8.0-1_all.deb Python library for the NMEA 0183 protocol
python-nodelet-topic-tools_1.9.8-1_all.deb Robot OS nodelet_topic_tools library - service files
python-nodelet_1.9.8-1_all.deb Robot OS nodelet library - service files - Python
python-nose-cov_1.6-0ubuntu1_all.deb nose plugin for coverage reporting - python 2 flavor
python-nose-doc_1.3.7-2_all.deb documentation for discovery and running for Python's unittest
python-nose-exclude_0.4.1-1_all.deb exclude specific directories from nosetests runs - Python 2.7
python-nose-json_0.2.4-0ubuntu1_all.deb nose pugin for json reporting - python 2 flavor
python-nose-parameterized_0.3.4-4_all.deb decorator for parameterized testing with Nose - Python 2.x
Advertisement
Advertisement