python-neovim_0.1.13-3_all.deb


Advertisement

Description

python-neovim - Python2 library for scripting Neovim processes through its msgpack-rpc API

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name python-neovim
Package version 0.1.13
Package release 3
Package architecture all
Package type deb
Installed size 126 B
Download size 27.47 KB
Official Mirror archive.ubuntu.com
Neovim is a Vim fork that focuses on refactoring, extensibility and
simplification of the original code base.
This is the Python2 version of the package (If you only use one of python2 or
python3, it is enough to install that version.)

Alternatives

Package Version Architecture Repository
python-neovim_0.1.13-3_all.deb 0.1.13 all Ubuntu Universe
python-neovim - - -

Requires

Name Value
python-greenlet -
python-msgpack -
python-trollius -
python:any << 2.8
python:any >= 2.7.5-5~

Provides

Name Value
python2.7-neovim -

Download

Type URL
Binary Package python-neovim_0.1.13-3_all.deb
Source Package python-neovim

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-neovim deb package:
    # sudo apt-get install python-neovim

Files

Path
/usr/lib/python2.7/dist-packages/neovim/__init__.py
/usr/lib/python2.7/dist-packages/neovim/compat.py
/usr/lib/python2.7/dist-packages/neovim/util.py
/usr/lib/python2.7/dist-packages/neovim-0.1.13.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/neovim-0.1.13.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/neovim-0.1.13.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/neovim-0.1.13.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/neovim-0.1.13.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/neovim/api/__init__.py
/usr/lib/python2.7/dist-packages/neovim/api/buffer.py
/usr/lib/python2.7/dist-packages/neovim/api/common.py
/usr/lib/python2.7/dist-packages/neovim/api/nvim.py
/usr/lib/python2.7/dist-packages/neovim/api/tabpage.py
/usr/lib/python2.7/dist-packages/neovim/api/window.py
/usr/lib/python2.7/dist-packages/neovim/msgpack_rpc/__init__.py
/usr/lib/python2.7/dist-packages/neovim/msgpack_rpc/async_session.py
/usr/lib/python2.7/dist-packages/neovim/msgpack_rpc/msgpack_stream.py
/usr/lib/python2.7/dist-packages/neovim/msgpack_rpc/session.py
/usr/lib/python2.7/dist-packages/neovim/msgpack_rpc/event_loop/__init__.py
/usr/lib/python2.7/dist-packages/neovim/msgpack_rpc/event_loop/asyncio.py
/usr/lib/python2.7/dist-packages/neovim/msgpack_rpc/event_loop/base.py
/usr/lib/python2.7/dist-packages/neovim/msgpack_rpc/event_loop/uv.py
/usr/lib/python2.7/dist-packages/neovim/plugin/__init__.py
/usr/lib/python2.7/dist-packages/neovim/plugin/decorators.py
/usr/lib/python2.7/dist-packages/neovim/plugin/host.py
/usr/lib/python2.7/dist-packages/neovim/plugin/script_host.py
/usr/share/doc/python-neovim/README.md.gz
/usr/share/doc/python-neovim/changelog.Debian.gz
/usr/share/doc/python-neovim/copyright

Changelog

2017-08-15 - Víctor Cuadrado Juan <me@viccuad.me>
python-neovim (0.1.13-3) unstable; urgency=medium
* Rename d/tests/control.autodep8 to d/tests/control
* Pass -vv to nosetests, to investigate flaky tests (see #867886)
* Update Std-Ver to 4.0.1
2017-02-27 - Víctor Cuadrado Juan <me@viccuad.me>
python-neovim (0.1.13-2) unstable; urgency=medium
* Enable nosetests in autopkgtest
2017-01-28 - Víctor Cuadrado Juan <me@viccuad.me>
python-neovim (0.1.13-1) unstable; urgency=medium
* New Upstream release: 0.1.13
- Python 3.6 is officially supported
- Fix spawning a child on python 3.6 (Closes: #848230)
- Conform to pyuv 1.0 API
- Use tox for testing and add python 3.6 to test matrix
- Thanks to James McCoy (jamessan) for doing the
leg-work on fixing this version's bugs
* New Upstream release: 0.1.12
- Fixed version number in pypi tar.gz
* New upstream release: 0.1.11
- Supports python2.7, python3.3+
- Declare api level 1, for neovim >= 0.1.6
* Update Breaks: neovim (<< 0.1.6)
* First upload to Unstable
2016-10-28 - Víctor Cuadrado Juan <me@viccuad.me>
python-neovim (0.1.10-1) experimental; urgency=medium
* New upstream release
- Last version supporting python2.6
- This version supports neovim >=0.15
* Update Build-Depends to neovim (>= 0.1.5)
* Update Breaks to neovim (<< 0.1.5)
2016-06-18 - Víctor Cuadrado Juan <me@viccuad.me>
python-neovim (0.1.9-1) experimental; urgency=medium
* new upstream version
2016-05-20 - Víctor Cuadrado Juan <me@viccuad.me>
python-neovim (0.1.8-1) experimental; urgency=medium
* Import python-neovim_0.1.8.orig.tar.gz
2016-04-20 - Víctor Cuadrado Juan <me@viccuad.me>
python-neovim (0.1.7-1) experimental; urgency=medium
* New upstream release
* Reword descriptions; you don't need both python2 and 3 packages
* Update Std-Ver to 3.9.8
* Drop Build-Depends on dtach as tests lift their own nvim instance
* Add Breaks and Build-Depends on neovim 0.1.3
2016-04-05 - Víctor Cuadrado Juan <me@viccuad.me>
python-neovim (0.1.5-1) experimental; urgency=medium
[ Víctor Cuadrado Juan ]
* New upstream release
* Update d/copyright to 2016
* Add README.md to docs now that upstream ships it
[ Ondřej Nový ]
* Fixed homepage (https)
2016-03-10 - Víctor Cuadrado Juan <me@viccuad.me>
python-neovim (0.1.4-1) experimental; urgency=medium
* New upstream release.
* Add .git-dpm.
2016-03-03 - Víctor Cuadrado Juan <me@viccuad.me>
python-neovim (0.1.3-1) experimental; urgency=medium
* Initial release. (Closes: #808176)

See Also

Package Description
python-netcdf4_1.2.9-1build2_i386.deb Python interface to the netCDF4 (network Common Data Form) library
python-netfilter_0.6.4-1_all.deb Python module for manipulating netfilter rules (Python 2)
python-netmiko_1.1.0-1_all.deb multi-vendor library for SSH connections to network devices - Python 2.X
python-netsnmp_5.7.3+dfsg-1.7ubuntu1_i386.deb SNMP (Simple Network Management Protocol) Python support
python-netsyslog_0.1.0+dp2-1_all.deb Python Modules for emitting and receiving syslog events
python-networking-arista_2016.2.0-1_all.deb OpenStack virtual network service - Arista plugin
python-networking-bagpipe-doc_7.0.0-0ubuntu1_all.deb Driver and agent code to use BagPipe implementation (common documentaiton)
python-networking-bagpipe_7.0.0-0ubuntu1_all.deb Driver and agent code to use BagPipe implementation (Python 2)
python-networking-bgpvpn-doc_7.0.0-0ubuntu1_all.deb BGP-MPLS VPN Extension for OpenStack Networking (common documentation)
python-networking-bgpvpn_7.0.0-0ubuntu1_all.deb BGP-MPLS VPN Extension for OpenStack Networking (Python 2)
python-networking-hyperv_5.0.0-0ubuntu1_all.deb OpenStack Networking Hyper-V ML2 mechanism driver
python-networking-l2gw_10.1.0~a2~git20170831.a8ae0e3-0ubuntu1_all.deb OpenStack virtual network service - L2 gateway extension
python-networking-mlnx_9.0.0~b1-1_all.deb OpenStack virtual network service - Mellanox plugin Python 2.7 files
python-networking-odl-doc_11.0.0-0ubuntu1_all.deb OpenStack Networking OpenDayLight ML2 mechanism driver - doc
python-networking-odl_11.0.0-0ubuntu1_all.deb OpenStack Networking OpenDayLight ML2 mechanism driver
Advertisement
Advertisement