python-nautilus_1.1-4ubuntu1_i386.deb


Advertisement

Description

python-nautilus - Python binding for Nautilus components

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name python-nautilus
Package version 1.1
Package release 4ubuntu1
Package architecture i386
Package type deb
Installed size 68 B
Download size 17.41 KB
Official Mirror archive.ubuntu.com
Python binding for Nautilus, to allow Nautilus property page and menu item
extensions to be written in Python.

Alternatives

Package Version Architecture Repository
python-nautilus_1.1-4ubuntu1_amd64.deb 1.1 amd64 Ubuntu Universe
python-nautilus - - -

Requires

Name Value
gir1.2-nautilus-3.0 -
libc6 >= 2.4
libglib2.0-0 >= 2.16.0
libgtk-3-0 >= 3.0.0
libnautilus-extension1a >= 3.14.1
libpython2.7 >= 2.7
python-gi >= 3.0

Download

Type URL
Binary Package python-nautilus_1.1-4ubuntu1_i386.deb
Source Package nautilus-python

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-nautilus deb package:
    # sudo apt-get install python-nautilus

Files

Path
/usr/lib/i386-linux-gnu/nautilus/extensions-3.0/libnautilus-python.so
/usr/lib/pkgconfig/nautilus-python.pc
/usr/share/doc/python-nautilus/AUTHORS
/usr/share/doc/python-nautilus/NEWS.Debian.gz
/usr/share/doc/python-nautilus/NEWS.gz
/usr/share/doc/python-nautilus/README
/usr/share/doc/python-nautilus/README.Debian
/usr/share/doc/python-nautilus/changelog.Debian.gz
/usr/share/doc/python-nautilus/copyright
/usr/share/doc/python-nautilus/examples/README
/usr/share/doc/python-nautilus/examples/background-image.py
/usr/share/doc/python-nautilus/examples/block-size-column.py
/usr/share/doc/python-nautilus/examples/location-widget-provider.py
/usr/share/doc/python-nautilus/examples/md5sum-property-page.py
/usr/share/doc/python-nautilus/examples/open-terminal.py
/usr/share/doc/python-nautilus/examples/submenu.py
/usr/share/doc/python-nautilus/examples/update-file-info-async.py
/usr/share/lintian/overrides/python-nautilus

Changelog

2016-09-29 - Jeremy Bicha <jbicha@ubuntu.com>
nautilus-python (1.1-4ubuntu1) yakkety; urgency=medium
* debian/rules:
- Adapt to nautilus multi-archification
2013-10-09 - Andreas Henriksson <andreas@fatal.se>
nautilus-python (1.1-4) unstable; urgency=low
* Team upload.
* Sync with ubuntu (Closes: #697565, #558613, #725665)
- debian/control(.in) changes excluded except added dh-autoreconf b-d
2013-05-29 - Barry Warsaw <barry@ubuntu.com>
nautilus-python (1.1-3ubuntu3) saucy; urgency=low
[ Doug McMahon ]
* d/p/02_python_multiarch_path.patch: Follow up fix for i386 multiarch.
(LP: #1170017)
2013-05-28 - Barry Warsaw <barry@ubuntu.com>
nautilus-python (1.1-3ubuntu2) saucy; urgency=low
[ Dr.Amr Osman ]
* debian/patches/02_python_multiarch_path.patch: Add 64bit multiarch
search paths for libpython2.7.so.  (LP: #1170017)
2013-01-06 - Micah Gersten <micahg@ubuntu.com>
nautilus-python (1.1-3ubuntu1) raring; urgency=low
* Fix FTBFS with python multiarch headers; Add dh-autoreconf to control;
Add autoreconf to rules
- update debian/control
- update debian/rules
- add debian/patches/02_python_multiarch_path.patch
- update debian/patches/series
2011-12-15 - Michael Biebl <biebl@debian.org>
nautilus-python (1.1-3) unstable; urgency=low
* Bump debhelper compatibility to 8.
* Set pkg-gnome-maintainers@lists.alioth.debian.org as Maintainer.
* Tighten dependency on python-gi to ensure it has dynamic bindings support.
Closes: #652109
2011-12-02 - Martin Pitt <mpitt@debian.org>
nautilus-python (1.1-2) unstable; urgency=low
[ Josselin Mouette ]
* Replace python-gobject by python-gi.
[ Martin Pitt ]
* Add 00git_open_terminal_example_GI.patch: Use GI GConf bindings in open
terminal example. Patch taken from upstream git.
* Add 01_port_examples_to_GI.patch: Port remaining examples to GI
bindings/GSettings. (Closes: #649910, LP: #898959)
2011-10-19 - Laurent Bigonville <bigon@debian.org>
nautilus-python (1.1-1) unstable; urgency=low
* New upstream release.
- Transition to nautilus 3 (Closes: #637315)
* debian/control.in:
- Adjusts {build-}dependencies
- Bump Standards-Version to 3.9.2 (no further changes)
- Add Vcs-* fields
* Switch to dpkg-source 3.0 (quilt) format
* debian/dirs: Create system-wide extensions directory to new location
* debian/watch: Switch to .xz tarballs
* debian/README.Debian: Update to new locations
* debian/lintian-overrides: Add an override for the empty system-wide
extensions directory
* debian/copyright: Add missing copyright statements
2010-01-30 - Emilio Pozuelo Monfort <pochu@debian.org>
nautilus-python (0.6.1-1) unstable; urgency=low
[ Josselin Mouette ]
* Require python-gconf instead of python-gnome2. Closes: #541582.
* Add missing dependency on python-gtk2.
* Drop useless .la files.
[ Emilio Pozuelo Monfort ]
* New upstream release.
* debian/patches/02_libeel.patch,
debian/patches/10_dlopen-nasty.patch,
debian/patches/50_CVE-2009-0317.patch,
debian/patches/70_missing_m4.patch,
debian/patches/90_relibtoolize.patch:
- Removed, no longer needed / applied upstream.
* debian/control.in:
- Remove libgnomevfs-dev from build depends, add python-gobject-dev.
- Standards-Version is 3.8.4, no changes needed.
* debian/watch:
- Don't uupdate.
* debian/control.in,
debian/rules:
- Remove quilt support, no longer needed.
2009-04-25 - Josselin Mouette <joss@debian.org>
nautilus-python (0.5.1-2) unstable; urgency=low
* Remove useless libeel build-dependency.

See Also

Package Description
python-nav-msgs_1.12.5-3_all.deb Messages relating to Robot OS nav, Python interface
python-nbconvert_4.2.0-4_all.deb Jupyter notebook conversion (Python 2)
python-nbformat-doc_4.4.0-1_all.deb Jupyter notebook format (documentation)
python-nbformat_4.4.0-1_all.deb Jupyter notebook format (Python 2)
python-nbsphinx-doc_0.2.9+ds-2_all.deb Jupyter Notebook Tools for Sphinx -- doc
python-nbsphinx_0.2.9+ds-2_all.deb Jupyter Notebook Tools for Sphinx -- Python
python-nbxmpp-doc_0.5.4-1_all.deb Non blocking Jabber/XMPP Python library, documentation
python-nbxmpp_0.5.4-1_all.deb Non blocking Jabber/XMPP Python library
python-ncap_1.9.2-2.2_i386.deb Python bindings for libncap
python-ncclient-doc_0.5.3-4_all.deb Documentation for python-ncclient (Python library for NETCONF clients)
python-ncclient_0.5.3-4_all.deb Python library for NETCONF clients (Python 2)
python-ndg-httpsclient_0.4.3-1_all.deb enhanced HTTPS support for httplib and urllib2 using PyOpenSSL for Python2
python-nemu_0.3.1-1_all.deb lightweight network emulator embedded in a small python library
python-neo_0.3.3-2_all.deb Python IO library for electrophysiological data formats
python-neovim_0.1.13-3_all.deb Python2 library for scripting Neovim processes through its msgpack-rpc API
Advertisement
Advertisement