python-lucene_4.10.1+dfsg-2_i386.deb


Advertisement

Description

python-lucene - Python extension for accessing Java Lucene

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name python-lucene
Package version 4.10.1+dfsg
Package release 2
Package architecture i386
Package type deb
Installed size 22.03 KB
Download size 3.68 MB
Official Mirror archive.ubuntu.com
PyLucene is a Python extension for accessing Java Lucene. Its goal
is to allow you to use Lucene's text indexing and searching
capabilities from Python.

Alternatives

Package Version Architecture Repository
python-lucene_4.10.1+dfsg-2_amd64.deb 4.10.1+dfsg amd64 Ubuntu Universe
python-lucene - - -

Requires

Name Value
default-jre-headless -
libasm-java -
libc6 >= 2.4
libgcc1 >= 1:3.0
liblucene4.10-java -
libstdc++6 >= 5
python << 2.8
python >= 2.7~
python:any << 2.8
python:any >= 2.7.5-5~

Replaces

Name Value
pylucene << 2.3.1-1.1+b1

Download

Type URL
Binary Package python-lucene_4.10.1+dfsg-2_i386.deb
Source Package pylucene

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-lucene deb package:
    # sudo apt-get install python-lucene

Files

Path
/usr/lib/python2.7/dist-packages/lucene-4.10.x.egg-info
/usr/lib/python2.7/dist-packages/lucene/ICUFoldingFilter.py
/usr/lib/python2.7/dist-packages/lucene/ICUNormalizer2Filter.py
/usr/lib/python2.7/dist-packages/lucene/ICUTransformFilter.py
/usr/lib/python2.7/dist-packages/lucene/__init__.py
/usr/lib/python2.7/dist-packages/lucene/_lucene.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/lucene/antlr-runtime-3.x.jar
/usr/lib/python2.7/dist-packages/lucene/asm-5.2.jar
/usr/lib/python2.7/dist-packages/lucene/asm-commons-5.2.jar
/usr/lib/python2.7/dist-packages/lucene/collections.py
/usr/lib/python2.7/dist-packages/lucene/extensions.jar
/usr/lib/python2.7/dist-packages/lucene/lucene-analyzers-common-4.10.x.jar
/usr/lib/python2.7/dist-packages/lucene/lucene-analyzers-stempel-4.10.x.jar
/usr/lib/python2.7/dist-packages/lucene/lucene-core-4.10.x.jar
/usr/lib/python2.7/dist-packages/lucene/lucene-expressions-4.10.x.jar
/usr/lib/python2.7/dist-packages/lucene/lucene-facet-4.10.x.jar
/usr/lib/python2.7/dist-packages/lucene/lucene-grouping-4.10.x.jar
/usr/lib/python2.7/dist-packages/lucene/lucene-highlighter-4.10.x.jar
/usr/lib/python2.7/dist-packages/lucene/lucene-join-4.10.x.jar
/usr/lib/python2.7/dist-packages/lucene/lucene-memory-4.10.x.jar
/usr/lib/python2.7/dist-packages/lucene/lucene-misc-4.10.x.jar
/usr/lib/python2.7/dist-packages/lucene/lucene-queries-4.10.x.jar
/usr/lib/python2.7/dist-packages/lucene/lucene-queryparser-4.10.x.jar
/usr/lib/python2.7/dist-packages/lucene/lucene-sandbox-4.10.x.jar
/usr/lib/python2.7/dist-packages/lucene/lucene-suggest-4.10.x.jar
/usr/share/doc/python-lucene/CREDITS
/usr/share/doc/python-lucene/README.Debian
/usr/share/doc/python-lucene/changelog.Debian.gz
/usr/share/doc/python-lucene/copyright
/usr/share/lintian/overrides/python-lucene
/usr/share/python-lucene/extensions.jar

Changelog

2017-02-03 - Dmitry Nezhevenko <dion@dion.org.ua>
pylucene (4.10.1+dfsg-2) unstable; urgency=medium
* Add wrapper around jcc to avoid build failure on armel, armhf, mips,
mipsel (Closes: #845083, #845084)
* Change Build-Depends to libasm-java (Closes: #839722)
* Update debian/watch
2016-07-22 - Dmitry Nezhevenko <dion@dion.org.ua>
pylucene (4.10.1+dfsg-1) unstable; urgency=medium
* New upstream release (Closes: #740992) 
* Repack upstream tarball to get rid of embedded copy of liblucene4.10-java.
and JCC compiler
* Bump debian/compat to 9, no changes required
* Bump Standards-Version to 3.9.8, no changes required
* Remove old pylucene transition package
* Drop obsolete X-Python-Version 
* Drop embedded copy of lucene-java-4.10 in binary package (add Depends: 
liblucene4.10-java)
* Add Build-Depends: antlr3, libasm4-java (new upstream depencencies,
embedded copies were included by upstream) 
* Drop unique_classes.patch patch (not needed anymore)
* Enable tests
* Apply security hardening in build flags (Closes: #740994)
* Switch to -dbgsym package for debug symbols
* Configure 'uscan(1)' to verify upstream signature on source releases
(thanks to Ben Finney) (Closes: #741062, #741063)
2013-06-21 - Niels Thykier <niels@thykier.net>
pylucene (3.5.0-1.2) unstable; urgency=low
* Non-maintainer upload.
* Compile Java with backwards compatible bytecode. (Closes: #678131)
2012-08-06 - Luca Falavigna <dktrkranz@debian.org>
pylucene (3.5.0-1.1) unstable; urgency=medium
* Non-maintainer upload.
* debian/patches/unique_classes.patch:
- Cherry-pick patch from upstream branch_3x SVN (r1240640) to rename
classes whose python name would not be unique (Closes: #679368).
2012-04-23 - Dmitry Nezhevenko <dion@dion.org.ua>
pylucene (3.5.0-1) unstable; urgency=low
* New maintainer (closes: 670179)
* New upstream release
* Switch to dpkg-source 3.0 (quilt) format
* Switch to machine-readable debian/copyright
* Bump debian/compat to 8, drop debian/pycompat
* Switch from cdbs to dh
* Add watch file
* Build for all supported versions of python2 (closes: 581198, 632240)
* Rename binary package to python-lucene (closes: 581197)
* Add -dbg package
2008-08-30 - Rene Mayorga <rmayorga@debian.org.sv>
pylucene (2.3.1-1.1) unstable; urgency=low
* Non-maintainer upload.
* Adding python-all-dev and python-all to B-D (closes: 496332)
* Add a dependency on python 2.5 (closes: 497479)
2008-04-16 - Jeff Breidenbach <jab@debian.org>
pylucene (2.3.1-1) unstable; urgency=low
* Initial release (closes: 490254)

See Also

Package Description
python-lunar_2.0.1-3_i386.deb Python bindings for the Chinese Lunar library
python-lunch_0.4.0-2_all.deb distributed process launcher
python-lvm2_2.02.168-2ubuntu3_i386.deb LVM2 application library - Python 2 binding
python-lxc_0.1-3_i386.deb Linux Containers userspace tools (Python 2.x bindings)
python-ly-doc_0.9.5-1_all.deb Tool and library for manipulating LilyPond files (documentation)
python-ly_0.9.5-1_all.deb Tool and library for manipulating LilyPond files (Python 2)
python-lz4_0.8.2+dfsg-2build2_i386.deb Python interface to the lz4 compression library
python-lzma_0.5.3-3_i386.deb Python bindings for liblzma
python-lzo_1.08-1_i386.deb Python bindings for the LZO data compression library
python-m2crypto_0.24.0-2_i386.deb Python wrapper for the OpenSSL library
python-m2ext_0.1-1.1_i386.deb Extensions to the M2Crypto Python package
python-m3u8_0.3.2-2_all.deb Python m3u8 parser - Python 2.x
python-macaron_0.3.1-1_all.deb simple ORM for Python, SQLite3 and Bottle web framework
python-macholib-doc_1.8~dfsg-1_all.deb module for Mach-O header analysis and editing (API documentation)
python-macholib_1.8~dfsg-1_all.deb module for Mach-O header analysis and editing (Python 2 interface)
Advertisement
Advertisement