python-libwfut-0.2_0.2.3-5_i386.deb


Advertisement

Description

python-libwfut-0.2 - WorldForge Update Tool (Python bindings)

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name python-libwfut-0.2
Package version 0.2.3
Package release 5
Package architecture i386
Package type deb
Installed size 472 B
Download size 110.28 KB
Official Mirror archive.ubuntu.com
WFUT is a content distribution system initially intended to provide media
updates for WorldForge. It can download and update game data and artwork for
WorldForge gaming clients.
This package contains the libwfut Python bindings.

Alternatives

Package Version Architecture Repository
python-libwfut-0.2_0.2.3-5_amd64.deb 0.2.3 amd64 Ubuntu Universe
python-libwfut-0.2 - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libsigc++-2.0-0v5 >= 2.8.0
libstdc++6 >= 5.2
libwfut-0.2-1 = 0.2.3-5
python >= 2.7~
python << 2.8
python:any >= 2.7.5-5~
python:any << 2.8

Provides

Name Value
python2.7-libwfut-0.2 -

Download

Type URL
Binary Package python-libwfut-0.2_0.2.3-5_i386.deb
Source Package libwfut

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-libwfut-0.2 deb package:
    # sudo apt-get install python-libwfut-0.2

Files

Path
/usr/lib/python2.7/dist-packages/libwfut/WFUTAvahiClient.py
/usr/lib/python2.7/dist-packages/libwfut/WFUTCore.py
/usr/lib/python2.7/dist-packages/libwfut/__init__.py
/usr/lib/python2.7/dist-packages/libwfut/pyWFUT.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/libwfut/wfut-python.py
/usr/lib/python2.7/dist-packages/libwfut/wfut-server.py
/usr/share/doc/python-libwfut-0.2/changelog.Debian.gz
/usr/share/doc/python-libwfut-0.2/copyright

Changelog

2017-09-05 - Olek Wojnar <olek-dev@wojnar.org>
libwfut (0.2.3-5) unstable; urgency=high
* Update symbols for GCC 7 (Closes: #853516)
* Update dh compat to 10
* Update standards to 4.1.0
- d/control: document new standards version
- d/copyright: use https in Format field
2016-07-03 - Olek Wojnar <olek-dev@wojnar.org>
libwfut (0.2.3-4) unstable; urgency=medium
* Fix symbols for GCC6 (Closes: #811985)
* Update d/control
- Standards-Version to 3.9.8 (no changes)
- Update Vcs lines for secure URIs
* Enable all hardening options
* Update d/copyright
* Add ldconfig trigger
* Convert to automatic debug package
2015-11-21 - Olek Wojnar <olek-dev@wojnar.org>
libwfut (0.2.3-3) unstable; urgency=medium
* Add patch to remove references to sigc++ file object_slot.h
-- File has been removed in newest sigc++
-- Fixes resulting build failures (Closes: #804736)
* Remove auto-generated python/WFUT.cxx file from source tree
* Update symbols
2015-09-26 - Olek Wojnar <olek-dev@wojnar.org>
libwfut (0.2.3-2) unstable; urgency=medium
* Fix symbols file to allow GCC 5 building (Closes: #799746)
- Thanks for the patch, Matthias Klose
* Refresh packaging
* Don't install into games directories
2014-10-22 - Olek Wojnar <olek-dev@wojnar.org>
libwfut (0.2.3-1) unstable; urgency=low
* New upstream release
* New maintainer (Closes: #653974)
* Team maintained under the Debian Games Team
* Incorporate Stephen Webb's packaging changes from pkg-games VCS
- Remove obsolete use of chrpath
- Convert from cdbs to dh(8)
- Update to 3.0 (quilt) source format
- Restore -dbg package contents
- Package python bindings
- Add d/libwfut-0.2-1.symbols
- Add build dependency on libtinyxml-dev
* Update to dh(9)
* Update d/control: Standards-Version to 3.9.6
- Update d/copyright for DEP-5
- Add VCS to d/control
* Update d/control: Update dependencies
* Update d/control: Add Stephen Webb and myself to uploaders
* Update d/control: Use dh-autoreconf (Closes: #734231)
* Move wfut binary install to /usr/games to comply with FHS
* Update d/libwfut-0.2-1.symbols
* Updated Multiarch compliance
2014-08-16 - Tobias Frost <tobi@debian.org>
libwfut (0.2.1-3) unstable; urgency=medium
* QA upload.
* Setting maintainer to QA-Group
* add "Build-Depends: zlib1g-dev" to fix FTBFS (Closes: #747786)
(Patch from the BTS by Hideki Yamane)
2009-08-27 - Michael Koch <konqueror@gmx.de>
libwfut (0.2.1-2) unstable; urgency=low
* debian/rules: Add --disable-static to configure call.
* debian/libwfut-0.2-dev.install: Don't install *.la and *.a files.
* debian/control: Updated Standards-Version to 3.8.3.
2009-07-22 - Michael Koch <konqueror@gmx.de>
libwfut (0.2.1-1) unstable; urgency=low
* New upstream release.
* debian/control: Updated Standards-Version to 3.8.2.
* debian/control: Add Depends: ${misc:Depends} to all packages.
* debian/control: Move libwfut-0.2-1-dbg to debug section.
* debian/watch: Update to make upstream updates easier.
2008-04-13 - Michael Koch <konqueror@gmx.de>
libwfut (0.2.0-3) unstable; urgency=low
* Really upload to unstable.
* Added debian/patches/libwfut-gcc4.3.patch to make libwfut compile with
GCC 4.3. Closes: #475765
2008-04-11 - Michael Koch <konqueror@gmx.de>
libwfut (0.2.0-2) experimental; urgency=low
* Upload to unstable.
* Updated long descriptions of all packages. Closes: 458887

See Also

Package Description
python-libxmp-doc_2.0.1+git20140309.5437b0a-5_all.deb Python library for XMP metadata - documentation
python-libxmp_2.0.1+git20140309.5437b0a-5_all.deb Python library for XMP metadata
python-lightblue_0.3.2-5build1_i386.deb cross-platform Bluetooth API for Python
python-limits-doc_1.2.1-1_all.deb Rate limiting utilities for Python - Documentation
python-limits_1.2.1-1_all.deb Rate limiting utilities for Python - Python 2.X
python-linaro-image-tools_2016.05-1_all.deb Python library for the manipulation of Linaro bootable media
python-link-grammar-examples_5.3.16-2_all.deb CMU's link grammar parser (Python examples)
python-link-grammar_5.3.16-2_i386.deb Carnegie Mellon University's link grammar parser (Python 2)
python-linop-doc_0.8.2-3_all.deb Linear mathematical operators in Python (documentation)
python-linop_0.8.2-3_i386.deb Linear mathematical operators in Python (Python 2)
python-livereload-doc_2.4.0-1_all.deb automatic browser refresher (documentation)
python-livereload_2.4.0-1_all.deb automatic browser refresher
python-livestreamer-doc_1.12.2-1_all.deb library to extract video streams from various services - documentation
python-livestreamer_1.12.2-1_all.deb library to extract video streams from various services - Python 2
python-lldb-3.8_3.8.1-24ubuntu7_i386.deb Next generation, high-performance debugger, python lib
Advertisement
Advertisement