python-latexcodec_1.0.5-1_all.deb


Advertisement

Description

python-latexcodec - LaTeX lexer and codec library for Python

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name python-latexcodec
Package version 1.0.5
Package release 1
Package architecture all
Package type deb
Installed size 82 B
Download size 14.19 KB
Official Mirror archive.ubuntu.com
latexcodec is a Python library for converting from and into
LaTeX encoding. It includes a codec module which contains classes
and functions for LaTeX code translation, and a module for lexing
LaTeX code, which includes general purpose base classes for
incremental LaTeX decoders and encoders.
This package contains the modules for Python2.

Alternatives

Package Version Architecture Repository
python-latexcodec_1.0.5-1_all.deb 1.0.5 all Ubuntu Universe
python-latexcodec - - -

Requires

Name Value
python-six >= 1.4.1
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Binary Package python-latexcodec_1.0.5-1_all.deb
Source Package python-latexcodec

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-latexcodec deb package:
    # sudo apt-get install python-latexcodec

Files

Path
/usr/lib/python2.7/dist-packages/latexcodec/__init__.py
/usr/lib/python2.7/dist-packages/latexcodec/codec.py
/usr/lib/python2.7/dist-packages/latexcodec/lexer.py
/usr/lib/python2.7/dist-packages/latexcodec-1.0.5.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/latexcodec-1.0.5.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/latexcodec-1.0.5.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/latexcodec-1.0.5.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/latexcodec-1.0.5.egg-info/zip-safe
/usr/share/doc/python-latexcodec/changelog.Debian.gz
/usr/share/doc/python-latexcodec/copyright

Changelog

2017-07-13 - Ghislain Antony Vaillant <ghisvail@gmail.com>
python-latexcodec (1.0.5-1) unstable; urgency=medium
* Source tarballs from PyPI
* Switch from git-dpm to gbp
* New upstream version 1.0.5
* Drop the patch queue, no longer required
* Use secure URI in copyright Format
* Update Source field to the PyPI URI
* Downgrade install of -doc package to Suggests
* Drop Recommends of -doc package
* Add missing Built-Using metadata
* Build the docs using the upstream Makefile
* Build the documentation with Python 3
- Use the Python 3 version of Sphinx
- New patch Fix-build-of-docs-with-Python-3.patch
* Add support for the nodoc build profile
* Add support for the nocheck build profile
* Drop superfluous installchangelogs override
* Bump debhelper version to 10, no changes required
* Bump standards version to 4.0.0, no changes required
* Improve the autopkgtest suite
- Replace individual test scripts by Test-Commands
- Run tests outside the source tree
- Run tests for all supported Python versions
* Adopt the package
- Add myself to Uploaders
- Add myself to copyright
- Remove Daniel Stender from Uploaders (Closes: #840034)
2016-08-06 - Daniel Stender <stender@debian.org>
python-latexcodec (1.0.3-4) unstable; urgency=medium
* deb/rules: set discarded http_proxy for sphinx-build (Closes: #830604).
2016-05-29 - Daniel Stender <stender@debian.org>
python-latexcodec (1.0.3-3) unstable; urgency=medium
* deb/rules: added -f- to date for reproducible builds (Closes: #824454).
2016-05-10 - Daniel Stender <stender@debian.org>
python-latexcodec (1.0.3-2) unstable; urgency=medium
* deb/control: corrected X-Python3-version.
* build docs package:
+ added package description in deb/control.
+ added Recommends to module package description in deb/control,
removed sphinxdoc:Depends.
+ build HTML documentation into docs package in deb/rules.
+ contribute CHANGELOG into both packages in deb/rules.
+ renamed deb/python3-latexcodec.doc-base accordingly, updated
paths and Document field.
* build Python2 package:
+ added package description in deb/control.
+ added Python2 package counterparts to build-deps in deb/control.
+ added X-Python-Version in deb/control.
+ added dh_python2 to Debhelper addons to use in deb/rules.
+ extended DEP-8 tests.
2016-05-09 - Daniel Stender <stender@debian.org>
python-latexcodec (1.0.3-1) unstable; urgency=medium
* Initial release (Closes: #801309).

See Also

Package Description
python-launchpadlib-toolkit_2.3_all.deb convenience library for launchpadlib
python-lazr.batchnavigator_1.2.10-0ubuntu2_all.deb A helper to navigate batched results in a web page
python-lazr.config-doc_2.2-1_all.deb ini-file format handling supporting schemas and inheritance
python-lazr.config_2.2-1_all.deb ini-file format handling supporting schemas and inheritance
python-lazr.delegates-doc_2.0.3-1build1_all.deb easily write objects that delegate behavior
python-lazr.delegates_2.0.3-1build1_all.deb easily write objects that delegate behavior
python-lazr.enum_1.1.4-0ubuntu2_all.deb Enums with zope.schema vocabulary support and database-friendly conveniences
python-lazr.lifecycle_1.0-0ubuntu3_all.deb Richer lifecycle events API
python-lazr.restful_0.19.3-0ubuntu2_all.deb Publish Python objects as RESTful resources over HTTP
python-lazr.smtptest-doc_2.0.3-1build1_all.deb framework for testing SMTP-based applications and libraries
python-lazr.smtptest_2.0.3-1build1_all.deb framework for testing SMTP-based applications and libraries
python-lazy-object-proxy_1.2.2-1build2_i386.deb Python fast and thorough lazy object proxy
python-lazyarray_0.1.0-1_all.deb Python module providing a NumPy-compatible lazily-evaluated array
python-ldap3_2.2.4-1_all.deb Pure Python LDAP client library
python-ldappool_2.0.0-1_all.deb connection pool for python-ldap - Python 2.7
Advertisement
Advertisement