python-kolab_1.0.2-10ubuntu8_i386.deb


Advertisement

Description

python-kolab - Python bindings for Kolab Library

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name python-kolab
Package version 1.0.2
Package release 10ubuntu8
Package architecture i386
Package type deb
Installed size 354 B
Download size 57.35 KB
Official Mirror archive.ubuntu.com
This package provides the Kolab Python modules icalendar and calendaring.
- The calendaring module provides some general calendaring functions
- The icalendar module exposes iCalendar functionality:
iCal reading/writing, iTip, iMip.

Alternatives

Package Version Architecture Repository
python-kolab_1.0.2-10ubuntu8_amd64.deb 1.0.2 amd64 Ubuntu Universe
python-kolab - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libkolab1 = 1.0.2-10ubuntu8
libkolabxml1v5 >= 1.1.0
libpython2.7 >= 2.7
libqt5core5a >= 5.9.0~beta
libstdc++6 >= 5.2
python << 2.8
python >= 2.7
python:any >= 2.6.6-7~

Download

Type URL
Binary Package python-kolab_1.0.2-10ubuntu8_i386.deb
Source Package libkolab

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-kolab deb package:
    # sudo apt-get install python-kolab

Files

Path
/usr/lib/python2.7/dist-packages/kolab/__init__.py
/usr/lib/python2.7/dist-packages/kolab/_calendaring.so
/usr/lib/python2.7/dist-packages/kolab/_icalendar.so
/usr/lib/python2.7/dist-packages/kolab/_kolabobject.so
/usr/lib/python2.7/dist-packages/kolab/_shared.so
/usr/lib/python2.7/dist-packages/kolab/calendaring.py
/usr/lib/python2.7/dist-packages/kolab/icalendar.py
/usr/lib/python2.7/dist-packages/kolab/kolabobject.py
/usr/lib/python2.7/dist-packages/kolab/shared.py
/usr/share/doc/python-kolab/changelog.Debian.gz
/usr/share/doc/python-kolab/copyright

Changelog

2017-08-23 - Rik Mills <rikmills@kubuntu.org>
libkolab (1.0.2-10ubuntu8) artful; urgency=medium
* No change rebuild against KDE PIM 17.04
2017-05-11 - Rik Mills <rikmills@kubuntu.org>
libkolab (1.0.2-10ubuntu7) artful; urgency=medium
* No change rebuild against new KDE PIM.
2016-04-05 - Nishanth Aravamudan <nish.aravamudan@canonical.com>
libkolab (1.0.2-10ubuntu6) xenial; urgency=medium
* PHP bindings only support PHP5 (LP: #1566433).
2016-03-10 - Scarlett Clark <sgclark@kubuntu.org>
libkolab (1.0.2-10ubuntu5) xenial; urgency=medium
* Revert back to happier times. 
2016-03-10 - Scarlett Clark <sgclark@kubuntu.org>
libkolab (1.0.2-10ubuntu4) xenial; urgency=medium
* Reset all changes back to working state. 
2016-03-04 - Scarlett Clark <sgclark@kubuntu.org>
libkolab (1.0.2-10ubuntu1) UNRELEASED; urgency=medium
* Debian merge with kde-kolab repo.
* Remaining changes: Kept versions on build dependencies
due to the struggle with kdepim stack builds. 
* Took out pgp option for uscan as our version fails. 
* Fix control merge. 
* Fix job merger. 
* Fix job merger to unstable. 
* Add epochs to build deps. 
2016-01-27 - Sandro Knauß <bugs@sandroknauss.de>
libkolab (1.0.2-1) UNRELEASED; urgency=medium
[ Sandro Knauß ]
* New upstream release.
* Bump build deps to 15.12, because newer kmime is needed
* remove patch to compile with 15.08
* update symbols
[ Diane Trout ]
* Bump libkf5akonadi-dev and notes-dev build deps to 4:15.12
2015-11-25 - Sandro Knauß <bugs@sandroknauss.de>
libkolab (1.0.0-1) experimental; urgency=medium
[Sandro Knauß]
* New upstream release.
* Updated patch hunks.
* Delete unused lintian overrides.
* Use symbolfiles instead of shlibs.
* Add breaks/replaces for libkolab0v5
[Harald Sitter]
* Updated dependencies using Qt5 and KF5.
2016-03-04 - Scarlett Clark <sgclark@kubuntu.org>
libkolab (1.0.0-0ubuntu2) UNRELEASED; urgency=medium
* Debian merge: No remaining changes. 
* Add version requirements to all pim* releated
build dependencies. 
* Fix typo in build depends. 
* Try a patch found upstream for kmime FTBFS 
* Fix fuzz in patch. 
* Another patch attempt.
* Try to adjust lines for last patch hunk. 
* Fix typo. 
* Last stab at patch line numbers. 
* Refresh symbols. 
* 
2015-08-27 - Harald Sitter <sitter@kde.org>
libkolab (1.0.0-0ubuntu1) wily; urgency=medium
* New upstream release using Qt5 and KF5 (LP: #1489392)
* Sobump from 0 to 1 (rename package accordingly)
* Import upstream commits to fix compatibility with KDE Applications 15.08
- upstream_Fix-build-with-Qt-5.5-and-also-adjust-to-the-latest-.patch

See Also

Package Description
python-kolabformat_1.1.4-1build3_i386.deb Python 2 bindings for Kolab Format 3.0 XML parsing
python-kopano_8.1.0-3ubuntu5_all.deb Complete and feature rich groupware solution - Python bindings
python-krbv_1.0.90-1_i386.deb Python extension module for Kerberos 5
python-ktoblzcheck_1.49-4_all.deb library for verification of account numbers and bank codes (Python bindings)
python-l20n_4.0.0~a1-2_all.deb Mozilla Web localization framework (Python 2)
python-laditools_1.1.0-2_all.deb Python module to control and monitor the LADI system
python-lamson_1.0pre11-1.3_all.deb A pure Python SMTP server
python-landslide_1.0.1-1_all.deb Lightweight markup language-based html5 slideshow generator
python-larch_1.20151025-1_all.deb B-tree library for Python
python-lasagne_0.1+git20160728.8b66737-3_all.deb deep learning library build on the top of Theano (Python2 modules)
python-laser-geometry_1.6.4-2build5_all.deb Robot OS laser geometry package - Python bindings
python-lasso_2.5.0-5build4_i386.deb Library for Liberty Alliance and SAML protocols - Python bindings
python-latexcodec-doc_1.0.5-1_all.deb LaTeX lexer and codec library for Python (docs)
python-latexcodec_1.0.5-1_all.deb LaTeX lexer and codec library for Python
python-launchpadlib-toolkit_2.3_all.deb convenience library for launchpadlib
Advertisement
Advertisement