python-hypothesis_3.12.0-2_all.deb


Advertisement

Description

python-hypothesis - advanced Quickcheck style testing library for Python 2

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name python-hypothesis
Package version 3.12.0
Package release 2
Package architecture all
Package type deb
Installed size 434 B
Download size 79.83 KB
Official Mirror archive.ubuntu.com
Hypothesis is a library for testing your Python code against a much
larger range of examples than you would ever want to write by
hand. It's based on the Haskell library, Quickcheck, and is designed
to integrate seamlessly into your existing Python unit testing work
flow.
Hypothesis is both extremely practical and also advances the state of
the art of unit testing by some way. It's easy to use, stable, and
extremely powerful. If you're not using Hypothesis to test your
project then you're missing out.
This package contains the Python 2 module.

Alternatives

Package Version Architecture Repository
python-hypothesis_3.12.0-2_all.deb 3.12.0 all Ubuntu Universe
python-hypothesis_3.6.0-1~nd90+1+nd17.04+1+nd17.10+1_all.deb 3.6.0 all NeuroDebian Main
python-hypothesis_3.6.0-1~nd90+1+nd17.04+1+nd17.10+1_all.deb 3.6.0 all NeuroDebian Main
python-hypothesis - - -

Requires

Name Value
python-enum34 -
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Binary Package python-hypothesis_3.12.0-2_all.deb
Source Package python-hypothesis

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-hypothesis deb package:
    # sudo apt-get install python-hypothesis

Files

Path
/usr/lib/python2.7/dist-packages/hypothesis/__init__.py
/usr/lib/python2.7/dist-packages/hypothesis/_settings.py
/usr/lib/python2.7/dist-packages/hypothesis/configuration.py
/usr/lib/python2.7/dist-packages/hypothesis/control.py
/usr/lib/python2.7/dist-packages/hypothesis/core.py
/usr/lib/python2.7/dist-packages/hypothesis/database.py
/usr/lib/python2.7/dist-packages/hypothesis/errors.py
/usr/lib/python2.7/dist-packages/hypothesis/executors.py
/usr/lib/python2.7/dist-packages/hypothesis/reporting.py
/usr/lib/python2.7/dist-packages/hypothesis/stateful.py
/usr/lib/python2.7/dist-packages/hypothesis/statistics.py
/usr/lib/python2.7/dist-packages/hypothesis/strategies.py
/usr/lib/python2.7/dist-packages/hypothesis/strategytests.py
/usr/lib/python2.7/dist-packages/hypothesis/types.py
/usr/lib/python2.7/dist-packages/hypothesis/version.py
/usr/lib/python2.7/dist-packages/hypothesis-3.12.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/hypothesis-3.12.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/hypothesis-3.12.0.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/hypothesis-3.12.0.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/hypothesis-3.12.0.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/hypothesis-3.12.0.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/hypothesis/extra/__init__.py
/usr/lib/python2.7/dist-packages/hypothesis/extra/datetime.py
/usr/lib/python2.7/dist-packages/hypothesis/extra/fakefactory.py
/usr/lib/python2.7/dist-packages/hypothesis/extra/numpy.py
/usr/lib/python2.7/dist-packages/hypothesis/extra/pytestplugin.py
/usr/lib/python2.7/dist-packages/hypothesis/extra/pytz.py
/usr/lib/python2.7/dist-packages/hypothesis/extra/django/__init__.py
/usr/lib/python2.7/dist-packages/hypothesis/extra/django/models.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/__init__.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/charmap.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/classmap.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/compat.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/deferredformat.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/detection.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/escalation.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/floats.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/intervalsets.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/reflection.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/conjecture/__init__.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/conjecture/data.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/conjecture/engine.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/conjecture/minimizer.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/conjecture/utils.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/__init__.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/collections.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/datetime.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/deferred.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/flatmapped.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/misc.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/numbers.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/recursive.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/reprwrapper.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/shared.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/strategies.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/streams.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/strings.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/wrappers.py
/usr/lib/python2.7/dist-packages/hypothesis/tools/__init__.py
/usr/lib/python2.7/dist-packages/hypothesis/tools/mergedbs.py
/usr/lib/python2.7/dist-packages/hypothesis/utils/__init__.py
/usr/lib/python2.7/dist-packages/hypothesis/utils/conventions.py
/usr/lib/python2.7/dist-packages/hypothesis/utils/dynamicvariables.py
/usr/lib/python2.7/dist-packages/hypothesis/vendor/__init__.py
/usr/lib/python2.7/dist-packages/hypothesis/vendor/pretty.py
/usr/share/doc/python-hypothesis/changelog.Debian.gz
/usr/share/doc/python-hypothesis/copyright

Changelog

2017-07-08 - Tristan Seligmann <mithrandi@debian.org>
python-hypothesis (3.12.0-2) unstable; urgency=medium
* Avoid loading py.test configuration from tox.ini (fixes autopkgtest
failures).
2017-07-07 - Tristan Seligmann <mithrandi@debian.org>
python-hypothesis (3.12.0-1) unstable; urgency=medium
* New upstream release.
- Tweak docs/conf.py to fix building docs when Hypothesis is not
installed.
* Fix permuted python3-hypothesis and python-hypothesis-doc Depends
stanzas (closes: #867435).
* Bump Standards-Version to 4.0.0 (no changes).
2016-12-26 - Tristan Seligmann <mithrandi@debian.org>
python-hypothesis (3.6.1-1) unstable; urgency=medium
* New upstream release.
2016-11-07 - Tristan Seligmann <mithrandi@debian.org>
python-hypothesis (3.6.0-1) unstable; urgency=medium
* The copyright of tests/cover/test_pretty.py is now documented
correctly.
* New upstream release.
2016-08-27 - Tristan Seligmann <mithrandi@debian.org>
python-hypothesis (3.4.2-2) unstable; urgency=medium
[ Julian Taylor ]
* add pypy-hypothesis package
2016-07-16 - Tristan Seligmann <mithrandi@debian.org>
python-hypothesis (3.4.2-1) unstable; urgency=medium
* New upstream release.
2016-06-25 - Tristan Seligmann <mithrandi@debian.org>
python-hypothesis (3.4.0-1) unstable; urgency=medium
* New upstream release.
2016-06-23 - Tristan Seligmann <mithrandi@debian.org>
python-hypothesis (3.1.3-3) unstable; urgency=medium
* Install python3-sphinx-rtd-theme instead of python-sphinx-rtd-theme
(closes: #827588, hopefully).
2016-05-15 - Tristan Seligmann <mithrandi@debian.org>
python-hypothesis (3.1.3-2) unstable; urgency=medium
* Add python-hypothesis-doc to Suggests.
2016-05-15 - Tristan Seligmann <mithrandi@debian.org>
python-hypothesis (3.1.3-1) unstable; urgency=medium
* New upstream release.
* Bump Standards-Version to 3.9.8 (no changes).
* Disable build-time test suite; running the tests takes a long time,
and is a little flaky, but hardly anything tested by them is
Debian-specific, so upstream would have already caught a bad release.
The DEP 8 tests are left, however.
* Swap team over to Maintainer.

See Also

Package Description
python-iapws_1.2-3_all.deb Python implementation of the international APWS-IF97 steam tables
python-ibm-db-sa_2.0.5-0ubuntu2_all.deb SQLAlchemy support for IBM Data Servers - Python 2.x
python-icalendar-doc_3.8-2_all.deb parser/generator of iCalendar files for use with Python -- docs
python-icalendar_3.8-2_all.deb parser/generator of iCalendar files for use with Python2
python-id3_1.2-6.3_all.deb Python module for id3-tags manipulation
python-ieee1284_0.2.11-13_i386.deb Python bindings to libieee1284
python-igraph_0.7.1.post6-3build2_i386.deb High performance graph data structures and algorithms (Python 2)
python-ijson_2.3-1_all.deb event-driven JSON parser (Python 2 version)
python-image-geometry_1.12.3+ds-1build1_all.deb image_geometry Robot OS package - Python bindings
python-imageio-doc_2.2.0-1_all.deb documentation for imageio
python-imageio_2.2.0-1_all.deb library for reading and writing image data (Python 2)
python-imagesize_0.7.1-1_all.deb Python 2 module for getting image size from png/jpeg/jpeg2000/gif file
python-imaging-doc-html_1.1.2-1.2_all.deb Documentation for the Python Imaging Library
python-imaging-doc-pdf_1.1.2-1.2_all.deb Documentation for the Python Imaging Library
python-imaging_4.1.1-3build2_all.deb Python Imaging Library compatibility layer
Advertisement
Advertisement