python-httpretty_0.8.14-1_all.deb


Advertisement

Description

python-httpretty - HTTP client mock - Python 2.x

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name python-httpretty
Package version 0.8.14
Package release 1
Package architecture all
Package type deb
Installed size 98 B
Download size 19.00 KB
Official Mirror archive.ubuntu.com
Once upon a time a Python developer wanted to use a RESTful API, everything
was fine but until the day he needed to test the code that hits the RESTful
API: what if the API server is down? What if its content has changed ?
Don't worry, HTTPretty is here for you.
This package provides the Python 2.x module.

Alternatives

Package Version Architecture Repository
python-httpretty_0.8.14-1~nd17.10+1_all.deb 0.8.14 all NeuroDebian Main
python-httpretty_0.8.14-1~nd17.10+1_all.deb 0.8.14 all NeuroDebian Main
python-httpretty_0.8.14-1_all.deb 0.8.14 all Ubuntu Universe
python-httpretty - - -

Requires

Name Value
python-urllib3 -
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Binary Package python-httpretty_0.8.14-1_all.deb
Source Package python-httpretty

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-httpretty deb package:
    # sudo apt-get install python-httpretty

Files

Path
/usr/lib/python2.7/dist-packages/httpretty/__init__.py
/usr/lib/python2.7/dist-packages/httpretty/compat.py
/usr/lib/python2.7/dist-packages/httpretty/core.py
/usr/lib/python2.7/dist-packages/httpretty/errors.py
/usr/lib/python2.7/dist-packages/httpretty/http.py
/usr/lib/python2.7/dist-packages/httpretty/utils.py
/usr/lib/python2.7/dist-packages/httpretty-0.8.14.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/httpretty-0.8.14.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/httpretty-0.8.14.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/httpretty-0.8.14.egg-info/top_level.txt
/usr/share/doc/python-httpretty/changelog.Debian.gz
/usr/share/doc/python-httpretty/copyright

Changelog

2016-05-24 - Ondřej Nový <novy@ondrej.org>
python-httpretty (0.8.14-1) unstable; urgency=medium
* Team upload.
* New upstream release (Closes: #815851)
* Fixed homepage (https).
* Fixed VCS URLs (https).
* d/rules: Changed UPSTREAM_GIT protocol to https
* d/copyright
- Changed source URL to https protocol
- Reordered
- Added myself to Debian part
* Removed removes-non-ascii-char-from-source.patch (not needed)
* Don't ignore unittests results during build and enable Py3 tests
* Enabled autopkgtest-pkg-python testsuite
* Standards-Version is 3.9.8 now (no changes needed)
* Install upstream changelog
2015-04-27 - Thomas Goirand <zigo@debian.org>
python-httpretty (0.8.6-2) unstable; urgency=medium
* Uploading to unstable.
2015-04-19 - Thomas Goirand <zigo@debian.org>
python-httpretty (0.8.6-1) experimental; urgency=medium
* New upstream release.
* Added export http{s,}_proxy.
2015-04-19 - Thomas Goirand <zigo@debian.org>
python-httpretty (0.8.3-2) experimental; urgency=medium
* Adds a patch to remove non-ascii chars from source.
2015-03-04 - Thomas Goirand <zigo@debian.org>
python-httpretty (0.8.3-1) experimental; urgency=medium
* New upstream release.
* Added a lintian-overrides for theme/assets/js/prefixfree.min.js: the file
isn't minifed, so it's ok.
2014-04-03 - Thomas Goirand <zigo@debian.org>
python-httpretty (0.8.0-2) unstable; urgency=medium
* Added python3 support.
* Allow the unit tests to fail, because they do with the last version of
python-sure (Closes: #746118).
2014-03-06 - Thomas Goirand <zigo@debian.org>
python-httpretty (0.8.0-1) unstable; urgency=medium
* New upstream release.
* Removed tests removal, because upstream did remove the tests files from the
setup.py.
* reviewed (build-)dependencies.
2014-02-09 - Thomas Goirand <zigo@debian.org>
python-httpretty (0.7.1-3) unstable; urgency=medium
* Do not package the test folder. (Closes: #738210)
2014-02-08 - Thomas Goirand <zigo@debian.org>
python-httpretty (0.7.1-2) unstable; urgency=medium
* Added missing build-depends: python-mock, python-nose.
2013-12-30 - Thomas Goirand <zigo@debian.org>
python-httpretty (0.7.1-1) unstable; urgency=medium
* New upstream release.
* Adds unit tests run.
* Standards-Version: is now 3.9.5.

See Also

Package Description
python-humanfriendly_3.2-1_all.deb Python library to make user friendly text interfaces
python-humanize_0.5.1-2_all.deb Python Humanize library (Python 2)
python-hunspell_0.4.1-1build3_i386.deb Python 2 binding for Hunspell
python-hupper_1.0-2_all.deb Integrated process monitor for developing servers (Python 2)
python-hurry.filesize_0.9-1_all.deb human readable file sizes or anything sized in bytes - Python 2.x
python-hurry.query_1.1.1-0ubuntu2_all.deb Higher level query system for the zope.catalog
python-hy_0.12.1-2_all.deb Lisp (s-expression) based frontend to Python
python-hydroffice.bag_0.2.15-1_all.deb manage Bathymetric Attributed Grid (BAG) data files (Python 2)
python-hyperframe_5.1.0-1_all.deb Pure-Python HTTP/2 framing code
python-hyperlink_17.3.1-2_all.deb Immutable, Pythonic, correct URLs
python-hypothesis-doc_3.12.0-2_all.deb advanced Quickcheck style testing library (documentation)
python-hypothesis_3.12.0-2_all.deb advanced Quickcheck style testing library for Python 2
python-iapws_1.2-3_all.deb Python implementation of the international APWS-IF97 steam tables
python-ibm-db-sa_2.0.5-0ubuntu2_all.deb SQLAlchemy support for IBM Data Servers - Python 2.x
python-icalendar-doc_3.8-2_all.deb parser/generator of iCalendar files for use with Python -- docs
Advertisement
Advertisement