python-genshi_0.7-6_i386.deb


Advertisement

Description

python-genshi - Python XML-based template engine - Python 2.x

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name python-genshi
Package version 0.7
Package release 6
Package architecture i386
Package type deb
Installed size 901 B
Download size 123.12 KB
Official Mirror archive.ubuntu.com
Genshi  is  a Python  library  that  provides  an integrated  set  of
components  for  parsing,  generating,  and processing  HTML  or  XML
content  in  a uniform  manner.   The  major  feature is  a  template
language, which is heavily inspired by Kid.
This is the Python 2 version.

Alternatives

Package Version Architecture Repository
python-genshi_0.7-6_amd64.deb 0.7 amd64 Ubuntu Universe
python-genshi - - -

Requires

Name Value
libc6 >= 2.4
python << 2.8
python >= 2.7~
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Binary Package python-genshi_0.7-6_i386.deb
Source Package genshi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-genshi deb package:
    # sudo apt-get install python-genshi

Files

Path
/usr/lib/python2.7/dist-packages/Genshi-0.7.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/Genshi-0.7.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/Genshi-0.7.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/Genshi-0.7.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/Genshi-0.7.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/genshi/__init__.py
/usr/lib/python2.7/dist-packages/genshi/_speedups.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/genshi/builder.py
/usr/lib/python2.7/dist-packages/genshi/compat.py
/usr/lib/python2.7/dist-packages/genshi/core.py
/usr/lib/python2.7/dist-packages/genshi/input.py
/usr/lib/python2.7/dist-packages/genshi/output.py
/usr/lib/python2.7/dist-packages/genshi/path.py
/usr/lib/python2.7/dist-packages/genshi/util.py
/usr/lib/python2.7/dist-packages/genshi/filters/__init__.py
/usr/lib/python2.7/dist-packages/genshi/filters/html.py
/usr/lib/python2.7/dist-packages/genshi/filters/i18n.py
/usr/lib/python2.7/dist-packages/genshi/filters/transform.py
/usr/lib/python2.7/dist-packages/genshi/filters/tests/__init__.py
/usr/lib/python2.7/dist-packages/genshi/filters/tests/i18n.py
/usr/lib/python2.7/dist-packages/genshi/filters/tests/test_html.py
/usr/lib/python2.7/dist-packages/genshi/filters/tests/transform.py
/usr/lib/python2.7/dist-packages/genshi/template/__init__.py
/usr/lib/python2.7/dist-packages/genshi/template/_ast24.py
/usr/lib/python2.7/dist-packages/genshi/template/ast24.py
/usr/lib/python2.7/dist-packages/genshi/template/astutil.py
/usr/lib/python2.7/dist-packages/genshi/template/base.py
/usr/lib/python2.7/dist-packages/genshi/template/directives.py
/usr/lib/python2.7/dist-packages/genshi/template/eval.py
/usr/lib/python2.7/dist-packages/genshi/template/interpolation.py
/usr/lib/python2.7/dist-packages/genshi/template/loader.py
/usr/lib/python2.7/dist-packages/genshi/template/markup.py
/usr/lib/python2.7/dist-packages/genshi/template/plugin.py
/usr/lib/python2.7/dist-packages/genshi/template/text.py
/usr/lib/python2.7/dist-packages/genshi/template/tests/__init__.py
/usr/lib/python2.7/dist-packages/genshi/template/tests/base.py
/usr/lib/python2.7/dist-packages/genshi/template/tests/directives.py
/usr/lib/python2.7/dist-packages/genshi/template/tests/eval.py
/usr/lib/python2.7/dist-packages/genshi/template/tests/interpolation.py
/usr/lib/python2.7/dist-packages/genshi/template/tests/loader.py
/usr/lib/python2.7/dist-packages/genshi/template/tests/markup.py
/usr/lib/python2.7/dist-packages/genshi/template/tests/plugin.py
/usr/lib/python2.7/dist-packages/genshi/template/tests/text.py
/usr/lib/python2.7/dist-packages/genshi/template/tests/templates/__init__.py
/usr/lib/python2.7/dist-packages/genshi/tests/__init__.py
/usr/lib/python2.7/dist-packages/genshi/tests/builder.py
/usr/lib/python2.7/dist-packages/genshi/tests/core.py
/usr/lib/python2.7/dist-packages/genshi/tests/input.py
/usr/lib/python2.7/dist-packages/genshi/tests/output.py
/usr/lib/python2.7/dist-packages/genshi/tests/path.py
/usr/lib/python2.7/dist-packages/genshi/tests/util.py
/usr/share/doc/python-genshi/README.Debian
/usr/share/doc/python-genshi/changelog.Debian.gz
/usr/share/doc/python-genshi/copyright

Changelog

2017-06-29 - Scott Kitterman <scott@kitterman.com>
genshi (0.7-6) unstable; urgency=medium
* Team upload.
[ Ondřej Nový ]
* Fixed VCS URL (https)
[ Scott Kitterman ]
* Genshi only supports binary extension for python3 3.3 and before (Closes:
#810108)
- Make python3-genshi arc:all
- Drop python3-all-dev build-depends
2015-09-16 - Barry Warsaw <barry@debian.org>
genshi (0.7-5) unstable; urgency=medium
* debian/python3-genshi.pyremove: Re-added, but this time only to remove
the bogus genshi/_speedups.c file.
2015-09-08 - Barry Warsaw <barry@debian.org>
genshi (0.7-4) unstable; urgency=medium
* debian/patches:
- issue602.patch: Upstream patch for Python 3.5 compatibility.
(Closes: #798030)
- issue566.patch: Fix IndexError when uploading attachments in Trac
for users with non-English language settings (Closes: #775746)
* debian/control: Bump Standards-Version with no other changes needed.
* debian/tests: Add simple DEP-8 tests for both Python 2 and 3.
* debian/python3-genshi.pyremove: Removed.
2014-03-11 - Barry Warsaw <barry@debian.org>
genshi (0.7-3) unstable; urgency=medium
[ Barry Warsaw ]
* Team upload.
* d/patches/issue582.patch: Cherry picked patch from upstream to support
Python 3.4.
* d/copyright: Adjust copyright claim for Barry to just the debian/* files.
* d/control: As per request, remove Arnaud from Uploaders.
* d/python3-genshi.pyremove: Remove Python 3.4 specific paths.
[ Thomas Goirand ]
* d/control:
- Use X-Python-Version: >= 2.7 and X-Python3-Version: >= 3.2, << 3.4, to
allow easy backports and reflect reality.
- Added "- Python {2,3}.x" in short descriptions.
* d/copyright: Rewrote using parseable format 1.0.
* d/rules: Cleans genshi/_speedups.so to allow package to be rebuilt twice.
2014-02-17 - Barry Warsaw <barry@debian.org>
genshi (0.7-2) unstable; urgency=medium
* Team upload.
* d/control: Disable building/testing against Python 3.4 until
upstream fixes their ticket #582.
* d/patches/diable-python34.patch: Raise an ImportError when trying
to import genshi in a Python > 3.3.
2013-12-04 - Barry Warsaw <barry@debian.org>
genshi (0.7-1) unstable; urgency=low
[ Barry Warsaw ]
* Team upload.
- Closes: #673935
* New upstream release.  Closes: #731280
- Closes: #713747 (FTBFS)
- Closes: #673935 (py:match templates patch applied upstream).
* d/control:
- With maintainer permission, put DPMT in Maintainers, moved Arnaud to 
Uploaders, and added Barry to the latter.
- Add python3-genshi binary package.
- Update Build-Depends for pybuild and remove cdbs.
- Standards-Version: 3.9.5 with no further changes needed.
- Add X-Python3-Version header.
- wrap-and-sort
* d/rules:
- Switch to pybuild and add Python 3 support as a byproduct.
- Removed cdbs and simplified.
* d/watch: Updated
* d/compat: Update to v8.
* d/patches/fix_tests_failure_with_python27.patch: Updated.
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
2012-11-24 - Arnaud Fontaine <arnau@debian.org>
genshi (0.6-3) unstable; urgency=low
* debian/rules: build should fail if tests fail.
* debian/patches/fix_tests_failure_with_python27.patch:
+ Fix tests which used to fail with python < 2.7.3. Thanks to Barry Warsaw.
Closes: #661441.
2011-08-23 - Arnaud Fontaine <arnau@debian.org>
genshi (0.6-2) unstable; urgency=low
* Switch to dh_python2. Thanks to Julian Taylor. Closes: #637383.
* debian/control:
+ Bump Standards-Version to 3.9.2. No changes needed.
* debian/copyright:
+ Update copyright years.
* debian/rules:
+ Run tests suite at build time. Closes: #581774.

See Also

Package Description
python-genty_1.3.0-1_all.deb Allows you to run a test with multiple data sets (Python 2)
python-geographiclib_1.48-1_i386.deb Python implementation of GeographicLib
python-geohash_0.8.3-1.1_i386.deb fast, accurate Python geohashing library
python-geoip2_2.5.0+dfsg1-2_all.deb Python geoip2 API for web services and databases - Python 2.x
python-geoip_1.3.2-1build4_i386.deb Python bindings for the GeoIP IP-to-country resolver library
python-geojson_1.3.4-1_all.deb Python 2 bindings and utilities for GeoJSON
python-geolinks_0.2.0-2_all.deb Python 2 Library for using geospatial links (catalogue interoperablity)
python-geometry-msgs_1.12.5-3_all.deb Messages relating to Robot OS geometry, Python interface
python-geopandas-doc_0.2.1-4_all.deb Documentation for the geopandas library
python-geopandas_0.2.1-4_all.deb Python tools for geographic data
python-geopy_1.11.0+ds1-1_all.deb geocoding toolbox for Python
python-germinate_2.26_all.deb expand dependencies in seed packages (Python 2 interface)
python-gerritlib_0.4.0+git20150319-2_all.deb client library for accessing Gerrit with Python
python-getdns-doc_1.0.0~b1-1build3_all.deb modern asynchronous DNS API (documentation)
python-getdns_1.0.0~b1-1build3_i386.deb modern asynchronous DNS API (python bindings)
Advertisement
Advertisement