python-flask-principal_0.4.0-1build1_all.deb


Advertisement

Description

python-flask-principal - identity management for Flask

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name python-flask-principal
Package version 0.4.0
Package release 1build1
Package architecture all
Package type deb
Installed size 58 B
Download size 7.36 KB
Official Mirror archive.ubuntu.com
Flask-Principal provides a very loose framework to tie in providers of two
types of service, often located in different parts of a web application:
- Authentication providers
- User information providers
For example, an authentication provider may be oauth, using Flask-OAuth and
the user information may be stored in a relational database. Looseness of
the framework is provided by using signals as the interface.
This is the Python 2 version of the package.

Alternatives

Package Version Architecture Repository
python-flask-principal_0.4.0-1build1_all.deb 0.4.0 all Ubuntu Universe
python-flask-principal - - -

Requires

Name Value
python-blinker -
python-flask -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-flask-principal_0.4.0-1build1_all.deb
Source Package flask-principal

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-flask-principal deb package:
    # sudo apt-get install python-flask-principal

Files

Path
/usr/lib/python2.7/dist-packages/flask_principal.py
/usr/lib/python2.7/dist-packages/Flask_Principal-0.4.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/Flask_Principal-0.4.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/Flask_Principal-0.4.0.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/Flask_Principal-0.4.0.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/Flask_Principal-0.4.0.egg-info/top_level.txt
/usr/share/doc/python-flask-principal/changelog.Debian.gz
/usr/share/doc/python-flask-principal/copyright

Changelog

2015-07-22 - Steve Langasek <steve.langasek@ubuntu.com>
flask-principal (0.4.0-1build1) wily; urgency=medium
* No-change rebuild for python3.5 transition
2013-08-01 - Tonnerre LOMBARD <tonnerre@ancient-solutions.com>
flask-principal (0.4.0-1) unstable; urgency=low
* Initial release. Closes: 718555

See Also

Package Description
python-flask-rdf_0.2.0-1.1_all.deb Flask decorator to output RDF using content negotiation (Python 2)
python-flask-restful-doc_0.3.6-1_all.deb REST API framework for Flask applications (Documentation)
python-flask-restful_0.3.6-1_all.deb REST API framework for Flask applications (Python Module)
python-flask-script_2.0.5-2_all.deb set of utilities for use with the Flask framework
python-flask-silk-doc_0.2-6_all.deb FamFamFam Silk icon set for Flask applications (documentation)
python-flask-silk_0.2-6_all.deb FamFamFam Silk icon set for Flask applications (Python 2)
python-flask-sockets_0.2.1-1_all.deb elegant WebSockets for your Flask apps
python-flask-sqlalchemy_2.1-3build1_all.deb adds SQLAlchemy support to your Flask application
python-flask-testing-doc_0.4.2-1_all.deb documentation for the Flask-Testing Python library - documentation
python-flask-testing_0.4.2-1_all.deb unit testing utilities for the Flask micro web framework - Python 2.X
python-flaskext.multistatic_1.0-1_all.deb Simple Flask plugin for overriding static files (Python 2)
python-flaskext.wtf-doc_0.14.2-1_all.deb Simple integration of Flask and WTForms (doc)
python-flaskext.wtf_0.14.2-1_all.deb Simple integration of Flask and WTForms (Python 2)
python-flexmock_0.10.2-1_all.deb Mock/Stub/Spy library for Python
python-flickrapi_2.1.2-5_all.deb Flickr API wrapper for Python 2
Advertisement
Advertisement