python-fife_0.4.1-2_i386.deb


Advertisement

Description

python-fife - FIFE is a multi-platform isometric game engine

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name python-fife
Package version 0.4.1
Package release 2
Package architecture i386
Package type deb
Installed size 16.28 KB
Download size 2.71 MB
Official Mirror archive.ubuntu.com
FIFE stands for Flexible Isometric Free Engine and is a cross
platform game creation framework written in C++. It provides you with
the ability to create a game using Python interfaces. FIFE also comes
as a DLL or static library so you can use C++ as well.

Alternatives

Package Version Architecture Repository
python-fife_0.4.1-2_amd64.deb 0.4.1 amd64 Ubuntu Universe
python-fife - - -

Requires

Name Value
libboost-filesystem1.62.0 -
libboost-regex1.62.0 -
libboost-system1.62.0 -
libc6 >= 2.11
libfifechan0.1.4 -
libgcc1 >= 1:4.2
libgl1 -
libgl1-mesa-glx -
libopenal1 >= 1.14
libpng16-16 >= 1.6.2-1
libpython2.7 >= 2.7
libsdl2-2.0-0 >= 2.0.4
libsdl2-image-2.0-0 >= 2.0.1
libsdl2-ttf-2.0-0 >= 2.0.14
libstdc++6 >= 5.2
libtinyxml2.6.2v5 -
libvorbisfile3 >= 1.1.2
python << 2.8
python >= 2.7~
python:any << 2.8
python:any >= 2.7.5-5~
zlib1g >= 1:1.1.4

Download

Type URL
Binary Package python-fife_0.4.1-2_i386.deb
Source Package fife

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-fife deb package:
    # sudo apt-get install python-fife

Files

Path
/usr/lib/python2.7/dist-packages/fife/__init__.py
/usr/lib/python2.7/dist-packages/fife/_fife.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/fife/_fifechan.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/fife/fife.py
/usr/lib/python2.7/dist-packages/fife/fifechan.py
/usr/lib/python2.7/dist-packages/fife/extensions/__init__.py
/usr/lib/python2.7/dist-packages/fife/extensions/basicapplication.py
/usr/lib/python2.7/dist-packages/fife/extensions/fife_compat.py
/usr/lib/python2.7/dist-packages/fife/extensions/fife_settings.py
/usr/lib/python2.7/dist-packages/fife/extensions/fife_timer.py
/usr/lib/python2.7/dist-packages/fife/extensions/fife_utils.py
/usr/lib/python2.7/dist-packages/fife/extensions/fifelog.py
/usr/lib/python2.7/dist-packages/fife/extensions/loaders.py
/usr/lib/python2.7/dist-packages/fife/extensions/pythonize.py
/usr/lib/python2.7/dist-packages/fife/extensions/savers.py
/usr/lib/python2.7/dist-packages/fife/extensions/soundmanager.py
/usr/lib/python2.7/dist-packages/fife/extensions/cegui/__init__.py
/usr/lib/python2.7/dist-packages/fife/extensions/cegui/ceguibasicapplication.py
/usr/lib/python2.7/dist-packages/fife/extensions/librocket/__init__.py
/usr/lib/python2.7/dist-packages/fife/extensions/librocket/rocketbasicapplication.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/__init__.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/attrs.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/autoposition.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/compat.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/dialogs.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/events.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/exceptions.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/fife_pychansettings.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/fonts.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/internal.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/properties.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/pychanbasicapplication.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/tools.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/dialog/__init__.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/dialog/filebrowser.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/widgets/__init__.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/widgets/basictextwidget.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/widgets/buttons.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/widgets/checkbox.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/widgets/common.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/widgets/containers.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/widgets/dropdown.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/widgets/icon.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/widgets/iconprogressbar.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/widgets/label.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/widgets/layout.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/widgets/listbox.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/widgets/passwordfield.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/widgets/percentagebar.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/widgets/radiobutton.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/widgets/scrollarea.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/widgets/slider.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/widgets/textbox.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/widgets/textfield.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/widgets/widget.py
/usr/lib/python2.7/dist-packages/fife/extensions/pychan/widgets/ext/__init__.py
/usr/lib/python2.7/dist-packages/fife/extensions/serializers/__init__.py
/usr/lib/python2.7/dist-packages/fife/extensions/serializers/simplexml.py
/usr/lib/python2.7/dist-packages/fife/extensions/serializers/xml_loader_tools.py
/usr/lib/python2.7/dist-packages/fife/extensions/serializers/xmlanimation.py
/usr/lib/python2.7/dist-packages/fife/extensions/serializers/xmlmap.py
/usr/lib/python2.7/dist-packages/fife/extensions/serializers/xmlmapsaver.py
/usr/lib/python2.7/dist-packages/fife/extensions/serializers/xmlobject.py
/usr/share/doc/python-fife/changelog.Debian.gz
/usr/share/doc/python-fife/copyright

Changelog

2017-07-19 - Markus Koschany <apo@debian.org>
fife (0.4.1-2) unstable; urgency=medium
* Team upload.
* Stop building fife on mips and mipsel due to architecture limitations which
cause FTBFS and prevent newer versions from migrating to testing.
Add alpha to WEAK_HOSTS and hope it builds again.
2017-07-07 - Markus Koschany <apo@debian.org>
fife (0.4.1-1) unstable; urgency=medium
* Team upload.
* New upstream version 0.4.1.
* Add get-orig-source target.
* Declare compliance with Debian Policy 4.0.0.
* Tighten build-dependency on libfifechan-dev to >= 0.1.4.
* Use https for Format field.
* Change homepage link to http://www.fifengine.net/. (Closes: #854620)
2017-01-22 - Markus Koschany <apo@debian.org>
fife (0.4.0-3) unstable; urgency=medium
* Team upload.
* debian/rules: Try to prevent build failures on mips and mipsel by using
a single thread only and building with CMAKE_BUILD_TYPE=MinSizeRel.
2017-01-20 - Markus Koschany <apo@debian.org>
fife (0.4.0-2) unstable; urgency=medium
* Team upload.
* Use dh_install --fail-missing to detect when files are not installed
into the resulting binary package.
* debian/rules: Pass --buildsystem=cmake to dh. (Closes: #851998)
* Add clean file and ensure that fife can be built twice in a row.
2017-01-19 - Markus Koschany <apo@debian.org>
fife (0.4.0-1) unstable; urgency=medium
* Team upload.
* New upstream version 0.4.0.
* Tighten build-dependency on libfifechan-dev.
* Drop all patches.
* Switch from Scons to CMake.
* Fix Lintian warning "extra license file".
2016-11-07 - Markus Koschany <apo@debian.org>
fife (0.3.5+git160920-1) unstable; urgency=medium
* Team upload.
* New upstream version 0.3.5+git160920.
* Use compat level 10.
* Add libfifechan-dev to Build-Depends.
* Drop all patches. Fixed upstream.
* Add debian/watch file. Thanks to Bart Martens.
* Simplify debian/rules.
* Switch from SDL1 to SDL2.
* Delete static libraries to ensure that fife can be built twice in a row.
* Remove debian/clean file.
* Drop libguichan-dev from Build-Depends. It is obsolete now.
* Add endif.patch and fix a FTBFS.
2016-09-02 - Markus Koschany <apo@debian.org>
fife (0.3.5-3) unstable; urgency=medium
* Team upload.
* Use compat level 9.
* Vcs fields: Use https.
* Declare compliance with Debian Policy 3.9.8.
* wrap-and-sort -sa.
* Add gcc6.diff and fix FTBFS with GCC-6.
Thanks to Martin Michlmayr for the report and Graham Inggs for the patch.
(Closes: #811858)
* Add dh-python to Build-Depends.
2016-04-23 - Tobias Frost <tobi@debian.org>
fife (0.3.5-2) unstable; urgency=medium
* Team upload.
* Link gnukfreebsd10-config.py to gnukfreebsd9-config.py, this
to fix builderror on kfreebsd. (Closes: #821765)
* Add ext/guichan-0.8.2/config.(guess|sub) to d/clean
2013-09-01 - Christoph Egger <christoph@debian.org>
fife (0.3.5-1) unstable; urgency=low
* New upstream release
2013-03-17 - Christoph Egger <christoph@debian.org>
fife (0.3.4-2) experimental; urgency=low
* Break older unknown-horizons as it only works with matching fife
versions (Closes: #703214)

See Also

Package Description
python-file-encryptor_0.2.9-2_all.deb Python module to convergently encrypt and decrypt files
python-filelock_2.0.11-1_all.deb platform independent file locking module (Python 2)
python-fiona_1.7.9-1build1_i386.deb Python API for reading/writing vector geospatial data
python-first_2.0.0-2_all.deb simple function that returns the first true value from an iterable
python-fisx-common_1.1.2-1ubuntu2_all.deb Quantitative X-Ray Fluorescence Analysis Support Library - (Common)
python-fisx_1.1.2-1ubuntu2_i386.deb Quantitative X-Ray Fluorescence Analysis Support Library - (Python 2)
python-fitbit_0.2.4-1_all.deb FitBit REST API Client Implementation
python-fitsio_0.9.10+dfsg-1ubuntu3_i386.deb Python 2 library to read from and write to FITS files
python-fiu_0.95-4build1_i386.deb userspace fault injection framework (Python bindings)
python-flake8_3.2.1-1_all.deb code checker using pycodestyle and pyflakes - Python 2.x
python-flaky_3.3.0-1_all.deb Plugin for nose or py.test that automatically reruns flaky tests (Python 2)
python-flask-api-common_0.6.4+dfsg-1_all.deb Browsable web APIs for the Flask micro web framework - static resources
python-flask-api_0.6.4+dfsg-1_all.deb Browsable web APIs for the Flask micro web framework - Python 2.X
python-flask-autoindex-doc_0.6-1_all.deb automatically generated index pages for Flask applications (documentation)
python-flask-autoindex_0.6-1_all.deb automatically generated index pages for Flask applications (Python 2)
Advertisement
Advertisement