python-fast5_0.6.3-1ubuntu1_i386.deb


Advertisement

Description

python-fast5 - library for reading Oxford Nanopore Fast5 files -- Python 2

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name python-fast5
Package version 0.6.3
Package release 1ubuntu1
Package architecture i386
Package type deb
Installed size 739 B
Download size 215.76 KB
Official Mirror archive.ubuntu.com
A lightweight C++11 library to read raw signal data from Oxford
Nanopore's FAST5 files.
This package provides the Python 2 library

Alternatives

Package Version Architecture Repository
python-fast5_0.6.3-1ubuntu1_amd64.deb 0.6.3 amd64 Ubuntu Universe
python-fast5 - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libhdf5-100 -
libstdc++6 >= 5.2
python << 2.8
python >= 2.7~
python:any << 2.8
python:any >= 2.7~

Download

Type URL
Binary Package python-fast5_0.6.3-1ubuntu1_i386.deb
Source Package fast5

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-fast5 deb package:
    # sudo apt-get install python-fast5

Files

Path
/usr/lib/python2.7/dist-packages/fast5.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/fast5-0.6.2.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/fast5-0.6.2.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/fast5-0.6.2.egg-info/top_level.txt
/usr/share/doc/python-fast5/changelog.Debian.gz
/usr/share/doc/python-fast5/copyright

Changelog

2017-10-18 - Graham Inggs <ginggs@ubuntu.com>
fast5 (0.6.3-1ubuntu1) artful; urgency=medium
* Allow stderr output in autpkgtests to ignore
notes emitted by GCC7 on armhf.
2017-10-17 - Afif Elghraoui <afif@debian.org>
fast5 (0.6.3-1) unstable; urgency=medium
* New upstream version
* Vastly simplified packaging after upstream patches accepted
* Don't hard-code hdf5-serial
* Fix source build in autopkgtest (Closes: #876283)
2017-10-01 - Afif Elghraoui <afif@debian.org>
fast5 (0.6.2-7) unstable; urgency=medium
* Reorganize executables package
- replace python{,3}-fast5-bin with fast5
- require executables package version to match
library version
2017-09-17 - Steffen Moeller <moeller@debian.org>
fast5 (0.6.2-6) unstable; urgency=medium
* Team upload
* Create yet another dir before moving files.
Now truly Closes: #875991
2017-09-17 - Andreas Tille <tille@debian.org>
fast5 (0.6.2-5) unstable; urgency=medium
* Team upload
* Fix clean target
* Create dir before moving files
Closes: #875991
* DEP3
* hardening=+all
2017-09-16 - Steffen Moeller <moeller@debian.org>
fast5 (0.6.2-4) unstable; urgency=medium
* Added build dependency on cython.
2017-09-15 - Steffen Moeller <moeller@debian.org>
fast5 (0.6.2-3) unstable; urgency=medium
* Completed include files to be redistributed
for a functional package.
2017-09-15 - Steffen Moeller <moeller@debian.org>
fast5 (0.6.2-2) unstable; urgency=medium
* Corrected for erroneously declared conflict
between python3-fast5 and python-fast5.
2017-09-15 - Steffen Moeller <moeller@debian.org>
fast5 (0.6.2-1) unstable; urgency=medium
* Team upload.
* New upstream version.
* Updated policy to 4.1.0 (no changes reguired)
* Patches
- Uncommented two older patches that do not seem to fit current
build structure
- Added patch for gcc-7 compatibility
- Added patch to adjusted include path for hdf5.h
* ./debian/rules binary works, still trouble with generated files
* Added separate packages for the binaries to avoid conflicts between
the Python2 and Python3 versions of the same binaries.
2016-12-29 - Afif Elghraoui <afif@debian.org>
fast5 (0.5.9-1) UNRELEASED; urgency=medium
* Imported Upstream version 0.5.9
* Update patches
* d/debian/upstream/metadata: References to registries
(Steffen Moeller)

See Also

Package Description
python-fastcluster_1.1.22-1build1_i386.deb Fast hierarchical clustering routines for Python
python-fastimport_0.9.6-3_all.deb Fastimport file format parser and generator library
python-fastkml_0.11-1_all.deb fast KML processing
python-faulthandler_2.4-1_i386.deb Display the Python backtrace on a crash
python-fcgi_19980130-1_all.deb Simple FastCGI module for Python
python-fdb-doc_1.6.1+dfsg1-1_all.deb Python DB-API driver for Firebird documentation
python-fdb_1.6.1+dfsg1-1_all.deb Python2 DB-API driver for Firebird
python-fdsend_0.2.1-2_i386.deb Provides an abstraction for file descriptor passing via sockets
python-feather-format_0.3.1+dfsg1-1ubuntu2_i386.deb Python interface to the Apache Arrow-based Feather File Format (Python 2)
python-fedora-doc_0.9.0-1_all.deb Python modules for interacting with Fedora Services (common documentation)
python-fedora_0.9.0-1_all.deb Python modules for interacting with Fedora Services (Python 2)
python-feed_0.7.4-1_all.deb set of Python modules for working with syndication feeds
python-feedgenerator_1.9-1_all.deb Syndication feed generation library (Python 2 version)
python-feedparser_5.1.3-3build1_all.deb Universal Feed Parser for Python
python-feedvalidator_0~svn1022-3_all.deb library and tool for validating syndication feeds
Advertisement
Advertisement