python-ephem_3.7.6.0-7build1_i386.deb


Advertisement

Description

python-ephem - Compute positions of the planets and stars with Python 2

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name python-ephem
Package version 3.7.6.0
Package release 7build1
Package architecture i386
Package type deb
Installed size 1.50 KB
Download size 572.50 KB
Official Mirror archive.ubuntu.com
PyEphem provides an ephem Python package for performing high-precision
astronomy computations. The underlying numeric routines are coded in C and
are the same ones that drive the popular XEphem astronomy application, whose
author, Elwood Charles Downey, generously gave permission for their use in
PyEphem.
The name ephem is short for the word ephemeris, which is the
traditional term for a table giving the position of a planet, asteroid, or
comet for a series of dates.
This package contains the Python 2 version of the package.

Alternatives

Package Version Architecture Repository
python-ephem_3.7.6.0-7build1_amd64.deb 3.7.6.0 amd64 Ubuntu Universe
python-ephem - - -

Requires

Name Value
libc6 >= 2.7
python << 2.8
python >= 2.7~
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Binary Package python-ephem_3.7.6.0-7build1_i386.deb
Source Package pyephem

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-ephem deb package:
    # sudo apt-get install python-ephem

Files

Path
/usr/lib/python2.7/dist-packages/ephem-3.7.6.0.egg-info
/usr/lib/python2.7/dist-packages/ephem/__init__.py
/usr/lib/python2.7/dist-packages/ephem/_libastro.i386-linux-gnu.so
/usr/lib/python2.7/dist-packages/ephem/cities.py
/usr/lib/python2.7/dist-packages/ephem/stars.py
/usr/lib/python2.7/dist-packages/ephem/doc/CHANGELOG.rst
/usr/lib/python2.7/dist-packages/ephem/doc/angle.rst
/usr/lib/python2.7/dist-packages/ephem/doc/catalogs.rst
/usr/lib/python2.7/dist-packages/ephem/doc/coordinates.rst
/usr/lib/python2.7/dist-packages/ephem/doc/date.rst
/usr/lib/python2.7/dist-packages/ephem/doc/examples.rst
/usr/lib/python2.7/dist-packages/ephem/doc/faq.rst
/usr/lib/python2.7/dist-packages/ephem/doc/index.rst
/usr/lib/python2.7/dist-packages/ephem/doc/newton.rst
/usr/lib/python2.7/dist-packages/ephem/doc/quick.rst
/usr/lib/python2.7/dist-packages/ephem/doc/radec.rst
/usr/lib/python2.7/dist-packages/ephem/doc/reference.rst
/usr/lib/python2.7/dist-packages/ephem/doc/rise-set.rst
/usr/lib/python2.7/dist-packages/ephem/doc/tutorial.rst
/usr/lib/python2.7/dist-packages/ephem/tests/__init__.py
/usr/lib/python2.7/dist-packages/ephem/tests/test_angles.py
/usr/lib/python2.7/dist-packages/ephem/tests/test_bodies.py
/usr/lib/python2.7/dist-packages/ephem/tests/test_cities.py
/usr/lib/python2.7/dist-packages/ephem/tests/test_constants.py
/usr/lib/python2.7/dist-packages/ephem/tests/test_dates.py
/usr/lib/python2.7/dist-packages/ephem/tests/test_github_issues.py
/usr/lib/python2.7/dist-packages/ephem/tests/test_jpl.py
/usr/lib/python2.7/dist-packages/ephem/tests/test_launchpad_236872.py
/usr/lib/python2.7/dist-packages/ephem/tests/test_launchpad_244811.py
/usr/lib/python2.7/dist-packages/ephem/tests/test_locales.py
/usr/lib/python2.7/dist-packages/ephem/tests/test_observers.py
/usr/lib/python2.7/dist-packages/ephem/tests/test_rst.py
/usr/lib/python2.7/dist-packages/ephem/tests/test_satellite.py
/usr/lib/python2.7/dist-packages/ephem/tests/test_stars.py
/usr/lib/python2.7/dist-packages/ephem/tests/test_usno.py
/usr/lib/python2.7/dist-packages/ephem/tests/test_usno_equinoxes.py
/usr/lib/python2.7/dist-packages/ephem/tests/jpl/europa.txt
/usr/lib/python2.7/dist-packages/ephem/tests/jpl/hyperion.txt
/usr/lib/python2.7/dist-packages/ephem/tests/jpl/jupiter.txt
/usr/lib/python2.7/dist-packages/ephem/tests/jpl/mars.txt
/usr/lib/python2.7/dist-packages/ephem/tests/jpl/neptune.txt
/usr/lib/python2.7/dist-packages/ephem/tests/jpl/oberon.txt
/usr/lib/python2.7/dist-packages/ephem/tests/jpl/phobos.txt
/usr/lib/python2.7/dist-packages/ephem/tests/jpl/saturn.txt
/usr/lib/python2.7/dist-packages/ephem/tests/jpl/uranus.txt
/usr/lib/python2.7/dist-packages/ephem/tests/usno/appgeo_deneb.txt
/usr/lib/python2.7/dist-packages/ephem/tests/usno/appgeo_jupiter.txt
/usr/lib/python2.7/dist-packages/ephem/tests/usno/appgeo_moon.txt
/usr/lib/python2.7/dist-packages/ephem/tests/usno/appgeo_sun.txt
/usr/lib/python2.7/dist-packages/ephem/tests/usno/apptopo_deneb.txt
/usr/lib/python2.7/dist-packages/ephem/tests/usno/apptopo_moon.txt
/usr/lib/python2.7/dist-packages/ephem/tests/usno/apptopo_sun.txt
/usr/lib/python2.7/dist-packages/ephem/tests/usno/astrom_antares.txt
/usr/lib/python2.7/dist-packages/ephem/tests/usno/astrom_mercury.txt
/usr/lib/python2.7/dist-packages/ephem/tests/usno/astrom_neptune.txt
/usr/lib/python2.7/dist-packages/ephem/tests/usno/moon_phases.txt
/usr/lib/python2.7/dist-packages/ephem/tests/usno/riset_moon.txt
/usr/lib/python2.7/dist-packages/ephem/tests/usno/riset_sun.txt
/usr/lib/python2.7/dist-packages/ephem/tests/usno/risettran_moon.txt
/usr/lib/python2.7/dist-packages/ephem/tests/usno/risettran_rigel.txt
/usr/share/doc/python-ephem/changelog.Debian.gz
/usr/share/doc/python-ephem/copyright

Changelog

2017-08-04 - Michael Hudson-Doyle <michael.hudson@ubuntu.com>
pyephem (3.7.6.0-7build1) artful; urgency=medium
* No change rebuild to drop Python 3.5 support.
2017-07-10 - Ole Streicher <olebole@debian.org>
pyephem (3.7.6.0-7) unstable; urgency=low
* Update standards-version (no changes), VCS fields; add ASCL Id
* Make build reproducible
* Convert patches to gbp
* Push Standards-Version to 4.0.0. No changes needed.
2016-02-08 - Ole Streicher <olebole@debian.org>
pyephem (3.7.6.0-6) unstable; urgency=low
* Fix again on s390x (grmpf), and on ppc64
2016-02-08 - Ole Streicher <olebole@debian.org>
pyephem (3.7.6.0-5) unstable; urgency=low
* Fix another FTBS on s390x
2016-02-08 - Ole Streicher <olebole@debian.org>
pyephem (3.7.6.0-4) unstable; urgency=low
* Fix FTBS on powerpc and mips
2016-02-07 - Ole Streicher <olebole@debian.org>
pyephem (3.7.6.0-3) unstable; urgency=low
* Allow stderr in CI tests
2016-02-06 - Ole Streicher <olebole@debian.org>
pyephem (3.7.6.0-2) unstable; urgency=low
* Rewrite test_github_25 to fix some FTBFS
* Add CI tests
2015-12-16 - Ole Streicher <olebole@debian.org>
pyephem (3.7.6.0-1) unstable; urgency=low
* Initial release. (Closes: #807778)

See Also

Package Description
python-epr-doc_0.9.3-2_all.deb Python ENVISAT Product Reader API (common documentation)
python-epr_0.9.3-2_i386.deb Python ENVISAT Product Reader API (Python 2)
python-epsilon_0.7.1-1_all.deb Python utility modules commonly used by Divmod.org project
python-epydoc_3.0.1+dfsg-15_all.deb tool for documenting Python modules
python-escript-doc_5.0-4ubuntu1_all.deb Documentation for Escript/Finley
python-escript-mpi_5.0-4ubuntu1_i386.deb Escript/Finley finite elements Python2 system (OpenMP + MPI)
python-escript_5.0-4ubuntu1_i386.deb Escript/Finley finite elements Python2 system (with OpenMP)
python-esmre_0.3.1-3build3_i386.deb Regular expression acceleration in Python2
python-espeak_0.5-1build5_i386.deb Python bindings for eSpeak
python-et-xmlfile_1.0.1-2_all.deb low memory library for creating large XML files (Python 2)
python-etcd_0.4.3-2_all.deb Python Etcd client library
python-ethtool_0.12-1.1_i386.deb Python bindings for the ethtool kernel interface
python-evdev_0.4.7-0ubuntu6_i386.deb Python bindings for the generic input event interface
python-evemu_2.6.0-0.1_i386.deb Linux Input Event Device Emulation Library - Python bindings
python-evtx_0.6.1-1_all.deb parser for recent Windows Event Log files -- Python 2 version
Advertisement
Advertisement