python-dkim_0.6.2-1_all.deb


Advertisement

Description

python-dkim - Python module for DKIM and ARC signing and verification

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name python-dkim
Package version 0.6.2
Package release 1
Package architecture all
Package type deb
Installed size 168 B
Download size 40.36 KB
Official Mirror archive.ubuntu.com
Python module that implements DKIM (DomainKeys Identified Mail) email signing
and verification as well as ARC (Authenticated Received Chain) signing and
verification. It also provides helper scripts for key generation and command
line signing and verification.
This is the Python (2) version of the package.

Alternatives

Package Version Architecture Repository
python-dkim_0.6.2-1_all.deb 0.6.2 all Ubuntu Universe
python-dkim - - -

Requires

Name Value
python-dns -
python-dnspython -
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Binary Package python-dkim_0.6.2-1_all.deb
Source Package dkimpy

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-dkim deb package:
    # sudo apt-get install python-dkim

Files

Path
/usr/bin/arcsign
/usr/bin/arcverify
/usr/bin/dkimsign
/usr/bin/dkimverify
/usr/bin/dknewkey
/usr/lib/python2.7/dist-packages/dkimpy-0.6.2.egg-info
/usr/lib/python2.7/dist-packages/dkim/__init__.py
/usr/lib/python2.7/dist-packages/dkim/__main__.py
/usr/lib/python2.7/dist-packages/dkim/asn1.py
/usr/lib/python2.7/dist-packages/dkim/canonicalization.py
/usr/lib/python2.7/dist-packages/dkim/crypto.py
/usr/lib/python2.7/dist-packages/dkim/dnsplug.py
/usr/lib/python2.7/dist-packages/dkim/util.py
/usr/lib/python2.7/dist-packages/dkim/tests/__init__.py
/usr/lib/python2.7/dist-packages/dkim/tests/test_arc.py
/usr/lib/python2.7/dist-packages/dkim/tests/test_canonicalization.py
/usr/lib/python2.7/dist-packages/dkim/tests/test_crypto.py
/usr/lib/python2.7/dist-packages/dkim/tests/test_dkim.py
/usr/lib/python2.7/dist-packages/dkim/tests/test_dnsplug.py
/usr/lib/python2.7/dist-packages/dkim/tests/test_util.py
/usr/lib/python2.7/dist-packages/dkim/tests/data/message.mbox
/usr/lib/python2.7/dist-packages/dkim/tests/data/test.message
/usr/lib/python2.7/dist-packages/dkim/tests/data/test.private
/usr/lib/python2.7/dist-packages/dkim/tests/data/test.txt
/usr/lib/python2.7/dist-packages/dkim/tests/data/test2.message
/usr/lib/python2.7/dist-packages/dkim/tests/data/test_bad.txt
/usr/lib/python2.7/dist-packages/dkim/tests/data/test_extra.message
/usr/lib/python2.7/dist-packages/dkim/tests/data/test_nofrom.message
/usr/share/doc/python-dkim/README
/usr/share/doc/python-dkim/changelog.Debian.gz
/usr/share/doc/python-dkim/copyright
/usr/share/man/man1/arcsign.1.gz
/usr/share/man/man1/arcverify.1.gz
/usr/share/man/man1/dkimsign.1.gz
/usr/share/man/man1/dkimverify.1.gz
/usr/share/man/man1/dknewkey.1.gz

Changelog

2017-06-10 - Scott Kitterman <scott@kitterman.com>
dkimpy (0.6.2-1) unstable; urgency=medium
* New upstream release
- Bug fixes, including Closes: #863690 
2017-03-02 - Scott Kitterman <scott@kitterman.com>
dkimpy (0.6.1-1) unstable; urgency=medium
* New upstream release: (Closes: #856609, #856611, #856613)
2017-01-23 - Scott Kitterman <scott@kitterman.com>
dkimpy (0.6.0-1) unstable; urgency=medium
* New upstream release
* Updated debian/copyright
* Updated debian/rules to install new scripts
* Adjusted required python versions
* Updated package descriptions
* Bumped debhelper version requirement and compat to 9
2016-06-29 - Scott Kitterman <scott@kitterman.com>
dkimpy (0.5.6-2) unstable; urgency=medium
[ Scott Kitterman ]
* Clean up clean rule to fix FTBFS on second build
* Don't install test data in pyshared for python-dkim
* Bump standards version to 3.9.8 without further change
[ Ondřej Nový ]
* Fixed homepage (https)
* Fixed VCS URL (https)
2015-12-07 - Scott Kitterman <scott@kitterman.com>
dkimpy (0.5.6-1) unstable; urgency=medium
[ Scott Kitterman ]
* New upstream release (LP: #1350141)
* Remove uupdate from debian/watch, no longer relevant when using git-dpm
* Bump standards version to 3.9.6 without further change
* Add dh-python to build-depends
[ SVN-Git Migration ]
* Migrate packaging to git with git-dpm
2013-06-09 - Scott Kitterman <scott@kitterman.com>
dkimpy (0.5.4-1) unstable; urgency=medium
* Urgency medium for important bug fix
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
[ Scott Kitterman ]
* New upstream release
- Fixes Gmail signature verification failures due to improper FWS regular
expression - Thanks to Peter Palfrader (weasel) for the patch
(Closes: #711751)
* Drop --no-compile from debian/rules so byte compilation gets tested during
build
* Bump minimum dephelper version to 8.1 and debian/compat to 8 for
build-{arch,indep} support
* Bump standards version to 3.9.4 without further change
2012-10-28 - Scott Kitterman <scott@kitterman.com>
dkimpy (0.5.3-1) unstable; urgency=medium
* Urgency medium for multiple RC bug fixes
* New upstream release:
* Fix header unfolding and body hash calculation errors that cause
correct DKIM signatures to fail to verify in many cases
(Closes: #691663)
* Add minimum key length requirement to prevent validation of signatures
generated with insecure keys (Closes: #691662)
2012-06-13 - Scott Kitterman <scott@kitterman.com>
dkimpy (0.5.2-1) unstable; urgency=low
* New upstream release
- Change canonicalization defaults to work around issues with different
verification implementations <https://launchpad.net/bugs/939128>
- Fully fold DKIM-Signature on sign, and ignore FWS in b= value on verify
- Fix hashing problem while signing using sha1
* Add alternate depends on python3-dnspython for python3-dkim since it will
enter the archive shortly
* Install tests directory, including test data
* Drop obsolete breaks on Lenny dkimproxy
* Fix debian watch to work with package rename and  Launchpad changes
* Bump standards version to 3.9.3 without further change
2012-02-03 - Scott Kitterman <scott@kitterman.com>
dkimpy (0.5.1-1) unstable; urgency=low
* New upstream release
- Rename source to match new upstream name
- Updated debian/copyright
* Remove no longer used quilt patch system artifacts
2011-10-26 - Scott Kitterman <scott@kitterman.com>
pydkim (0.5-1) unstable; urgency=low
* New upstream release
- Drop debian/patches/adjust-setup.py.patch, essential parts incorporated
upstream
- Remove the no longer existing (and never very useful) dkimsend.sh from
debian/docs

See Also

Package Description
python-dmidecode_3.12.2-3ubuntu1_i386.deb Python extension module for dmidecode
python-dns_2.3.6-3_all.deb DNS client module for Python
python-dnslib_0.9.7+hg20170303-1_all.deb Module to encode/decode DNS wire-format packets (Python 2)
python-dnsq_1.1.2-1_all.deb Python DNS query tool
python-doc8-doc_0.6.0-4_all.deb style checker for Sphinx (or other) RST documentation - doc
python-doc8_0.6.0-4_all.deb style checker for Sphinx (or other) RST documentation - Python 2.x
python-docker_1.9.0-1_all.deb Python wrapper to access docker.io's control socket
python-dockerpty_0.4.1-1_all.deb Pseudo-tty handler for docker Python client (Python 2.x)
python-dockerpycreds_0.2.1-1_all.deb Python bindings for the docker credentials store API
python-docopt_0.6.2-1build1_all.deb command-line interface description language
python-dogpile.core_0.6.2-5_all.deb transitional dummy package for python-dogpile.core
python-dogtail_0.9.9-1_all.deb GUI test tool and automation framework
python-doit-doc_0.30.3-2_all.deb Automation tool for executing any kind of task in a build-tools fashion - doc
python-dolfin_2016.2.0-5build3_i386.deb Python interface for DOLFIN (Python 2)
python-dominate_2.3.1-1_all.deb Python 2 library for creating and manipulating HTML documents
Advertisement
Advertisement