python-cycler_0.10.0-1_all.deb


Advertisement

Description

python-cycler - composable kwarg iterator (Python 2)

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name python-cycler
Package version 0.10.0
Package release 1
Package architecture all
Package type deb
Installed size 34 B
Download size 7.34 KB
Official Mirror archive.ubuntu.com
When using matplotlib and plotting more than one line, it is common to want to
be able to cycle over one  or more artist styles; but the plotting logic can
quickly become very involved.
To address this and allow easy cycling over arbitrary 'kwargs' the `Cycler`
class, a composable kwarg iterator, was developed.

Alternatives

Package Version Architecture Repository
python-cycler_0.10.0-1_all.deb 0.10.0 all Ubuntu Universe
python-cycler - - -

Requires

Name Value
python-six -
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Binary Package python-cycler_0.10.0-1_all.deb
Source Package python-cycler

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-cycler deb package:
    # sudo apt-get install python-cycler

Files

Path
/usr/lib/python2.7/dist-packages/cycler.py
/usr/lib/python2.7/dist-packages/cycler-0.10.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/cycler-0.10.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/cycler-0.10.0.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/cycler-0.10.0.egg-info/top_level.txt
/usr/share/doc/python-cycler/changelog.Debian.gz
/usr/share/doc/python-cycler/copyright

Changelog

2016-04-09 - Sandro Tosi <morph@debian.org>
python-cycler (0.10.0-1) unstable; urgency=medium
[ Sandro Tosi ]
* New upstream release
* debian/control
- update Homepage
- bump Standards-Version to 3.9.7 (no changes needed)
* debian/{control, rules}
- run tests at build time; Closes: #800908
* Build and provide documentation; Closes: #800907
[ Ondřej Nový ]
* Fixed homepage (https)
* Fixed VCS URL (https)
2015-10-04 - Sandro Tosi <morph@debian.org>
python-cycler (0.9.0-1) unstable; urgency=low
* Initial release (Closes: #791376)

See Also

Package Description
python-cyclone_1.1-2_all.deb web server framework for Python Twisted using the Tornado API
python-cylc_7.4.0-1_i386.deb Python libraries for cylc workflow scheduler
python-cymruwhois-doc_1.6-2build1_all.deb python-cymruwhois common documentation
python-cymruwhois_1.6-2build1_all.deb Python library for interfacing with the whois.cymru.com service (Python 2)
python-cypari2_1.0.0-3ubuntu2_i386.deb Python interface to PARI
python-cysignals-bare_1.6.5+ds-2_i386.deb interrupt and signal handling for Cython -- Python - bare
python-cysignals-doc_1.6.5+ds-2_all.deb interrupt and signal handling for Cython -- doc
python-cysignals-pari_1.6.5+ds-2_i386.deb interrupt and signal handling for Cython -- Python - PARI/GP
python-d2to1_0.2.12-1_all.deb Python support for distutils2-like setup.cfg files as package metadata
python-daap_0.7.1-4_i386.deb DAAP client implemented in Python
python-daemon_2.1.2-1_all.deb library for making a Unix daemon process — Python 2
python-daemonize_2.3.1-1_all.deb enable your code to run as a daemon process - Python 2.x
python-dap_2.2.6.7-2_all.deb DAP (Data Access Protocol) client and server
python-darts.lib.utils.lru-doc_0.5-4_all.deb Simple dictionary with LRU behaviour in Python (common documentation)
python-darts.lib.utils.lru_0.5-4_all.deb Simple dictionary with LRU behaviour in Python2
Advertisement
Advertisement