python-beaker_1.9.0-1_all.deb


Advertisement

Description

python-beaker - cache and session library

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name python-beaker
Package version 1.9.0
Package release 1
Package architecture all
Package type deb
Installed size 206 B
Download size 38.39 KB
Official Mirror archive.ubuntu.com
Beaker is a web session and general caching library that includes WSGI
middleware for use in web applications.
As a general caching library, Beaker can handle storing for various times any
Python object that can be pickled with optional back-ends on a fine-grained
basis.
Features:
* Fast, robust performance
* Multiple reader/single writer lock system to avoid duplicate simultaneous
cache creation
* Cache back-ends include dbm, file, memory, memcached, and database (using
SQLAlchemy for multiple-db vendor support)
* Signed cookies to prevent session hijacking/spoofing
* Cookie-only sessions to remove the need for a database or file backend
(ideal for clustered systems)
* Extensible Container object to support new back-ends
* Caches can be divided into namespaces (to represent templates, objects,
etc.) then keyed for different copies
* Create functions for automatic call-backs to create new cache copies after
expiration
* Fine-grained toggling of back-ends, keys, and expiration per Cache object

Alternatives

Package Version Architecture Repository
python-beaker_1.9.0-1_all.deb 1.9.0 all Ubuntu Universe
python-beaker - - -

Requires

Name Value
python -
python-funcsigs -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-beaker_1.9.0-1_all.deb
Source Package beaker

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-beaker deb package:
    # sudo apt-get install python-beaker

Files

Path
/usr/lib/python2.7/dist-packages/Beaker-1.9.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/Beaker-1.9.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/Beaker-1.9.0.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/Beaker-1.9.0.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/Beaker-1.9.0.egg-info/pbr.json
/usr/lib/python2.7/dist-packages/Beaker-1.9.0.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/Beaker-1.9.0.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/beaker/__init__.py
/usr/lib/python2.7/dist-packages/beaker/_compat.py
/usr/lib/python2.7/dist-packages/beaker/cache.py
/usr/lib/python2.7/dist-packages/beaker/container.py
/usr/lib/python2.7/dist-packages/beaker/converters.py
/usr/lib/python2.7/dist-packages/beaker/cookie.py
/usr/lib/python2.7/dist-packages/beaker/exceptions.py
/usr/lib/python2.7/dist-packages/beaker/middleware.py
/usr/lib/python2.7/dist-packages/beaker/session.py
/usr/lib/python2.7/dist-packages/beaker/synchronization.py
/usr/lib/python2.7/dist-packages/beaker/util.py
/usr/lib/python2.7/dist-packages/beaker/crypto/__init__.py
/usr/lib/python2.7/dist-packages/beaker/crypto/jcecrypto.py
/usr/lib/python2.7/dist-packages/beaker/crypto/noencryption.py
/usr/lib/python2.7/dist-packages/beaker/crypto/nsscrypto.py
/usr/lib/python2.7/dist-packages/beaker/crypto/pbkdf2.py
/usr/lib/python2.7/dist-packages/beaker/crypto/pyca_cryptography.py
/usr/lib/python2.7/dist-packages/beaker/crypto/pycrypto.py
/usr/lib/python2.7/dist-packages/beaker/crypto/util.py
/usr/lib/python2.7/dist-packages/beaker/ext/__init__.py
/usr/lib/python2.7/dist-packages/beaker/ext/database.py
/usr/lib/python2.7/dist-packages/beaker/ext/google.py
/usr/lib/python2.7/dist-packages/beaker/ext/memcached.py
/usr/lib/python2.7/dist-packages/beaker/ext/mongodb.py
/usr/lib/python2.7/dist-packages/beaker/ext/redisnm.py
/usr/lib/python2.7/dist-packages/beaker/ext/sqla.py
/usr/share/doc/python-beaker/NEWS.Debian.gz
/usr/share/doc/python-beaker/changelog.Debian.gz
/usr/share/doc/python-beaker/copyright
/usr/share/python/dist/python-beaker

Changelog

2017-07-03 - Piotr Ożarowski <piotr@debian.org>
beaker (1.9.0-1) unstable; urgency=medium
* New upstream release
- now supports MongoDB and Redis as backends - add python{,3}-pymongo
and python{,3}-redis to Suggests and Build-Depends
* Standards-Version bumped to 4.0.0 (no changes needed)
2016-11-05 - Piotr Ożarowski <piotr@debian.org>
beaker (1.8.1-1) unstable; urgency=medium
* New upstream release
2016-07-30 - Piotr Ożarowski <piotr@debian.org>
beaker (1.8.0-1) unstable; urgency=low
[ Ondřej Nový ]
* Fixed homepage (https)
* Fixed VCS URL (https)
[ Piotr Ożarowski ]
* New upstream release
* debian/rules rewritten, now uses dh sequencer and pybuild
* Homepage updated
* Update Standards-Version to 3.9.8 (no change needed)
* Remove Oleksandr from Uploaders, thank for all your work! (closes: 820141)
2014-10-19 - Piotr Ożarowski <piotr@debian.org>
beaker (1.6.4-2) unstable; urgency=low
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
[ Piotr Ożarowski ]
* Upload to unstable
* Switch to debhelper compat level 9
* Add dh-python to Build-Depends
* Use default compression in dh_builddeb
* Update Standards-Version to 3.9.6 (no change needed)
2012-09-13 - Piotr Ożarowski <piotr@debian.org>
beaker (1.6.4-1) experimental; urgency=low
* New upstream release
* Upload to experimental due to Wheezy freeze
2012-08-24 - David Prévot <taffit@debian.org>
beaker (1.6.3-1.1) unstable; urgency=low
* Non-maintainer upload.
* Fix security issue, with PyCrypto not securing data such that an attacker
could possibly determine parts of the encrypted payload. Patch by Miloslav
Trmac of Redhat. [CVE-2012-3458] Closes: #684890
2012-05-06 - Piotr Ożarowski <piotr@debian.org>
beaker (1.6.3-1) unstable; urgency=low
[ Andrey Rahmatullin ]
* Update Standards-Version to 3.9.1 (no change needed)
* Switch from dh_pysupport to dh_python2
[ Piotr Ożarowski ]
* New upstream release
- delete_cookie's expire date calculated via timedelta instead or
.replace(year=2003). Closes: #661670
* Remove egg-info/* files in clean target (regenerated in install)
- debhelper compatibility level bumped to 7 (debian/clean file used)
* Source format changed to 3.0 (quilt)
* Standards-Version bumped to 3.9.3 (no changes needed)
2010-09-23 - Piotr Ożarowski <piotr@debian.org>
beaker (1.5.4-4) unstable; urgency=low
* Upload to unstable
2010-09-12 - Piotr Ożarowski <piotr@debian.org>
beaker (1.5.4-3) experimental; urgency=low
* Rebuild against newer python3 package (python3.1 now uses
/usr/lib/python3/)
* Minimum python3-all version bumped to 3.1.2-8
2010-09-06 - Piotr Ożarowski <piotr@debian.org>
beaker (1.5.4-2) experimental; urgency=low
* Provide python3-beaker
* Provide pydist files

See Also

Package Description
python-beanbag-doc_1.9.2-1.1_all.deb Documentation for Python BeanBag module
python-beanbag_1.9.2-1.1_all.deb Helper module for accessing REST APIs - python2
python-beanstalkc_0.4.0-1_all.deb simple beanstalkd client library for Python
python-beautifulsoup_3.2.1-1_all.deb error-tolerant HTML parser for Python
python-behave-doc_1.2.5-2_all.deb behaviour-driven development, documentation
python-behave_1.2.5-2_all.deb behaviour-driven development for Python 2
python-bernhard_0.2.4-1_all.deb client for the Reiamnn event stream processor - Python 2.X
python-betamax-doc_0.8.0-1_all.deb VCR imitation designed only for python-requests - Documentation
python-betamax_0.8.0-1_all.deb VCR imitation designed only for python-requests - Python 2.X
python-bibtex_1.2.7-1_i386.deb Python interfaces to BibTeX and the GNU Recode library
python-bibtexparser-doc_0.6.2-2_all.deb documentation for BibtexParser
python-bibtexparser_0.6.2-2_all.deb Python library to parse bibtex files
python-billiard-doc_3.5.0.3-1_all.deb Multiprocessing Pool Extensions for Python (Documentation)
python-billiard_3.5.0.3-1_i386.deb Multiprocessing Pool Extensions for Python
python-binaryornot_0.4.0+dfsg-0.1_all.deb check if a file is binary or text (Python 2 module)
Advertisement
Advertisement