pyrite-publisher_2.1.1-11_i386.deb


Advertisement

Description

pyrite-publisher - Convert html and text documents to palm DOC format

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name pyrite-publisher
Package version 2.1.1
Package release 11
Package architecture i386
Package type deb
Installed size 347 B
Download size 105.02 KB
Official Mirror archive.ubuntu.com
Pyrite Publisher can convert a variety of input formats into several
different variations on the palm doc format.
This version includes support for a gui interface; see
/usr/share/doc/pyrite-publisher/README.GUI for details.

Alternatives

Package Version Architecture Repository
pyrite-publisher_2.1.1-11_amd64.deb 2.1.1 amd64 Ubuntu Universe
pyrite-publisher - - -

Requires

Name Value
libc6 >= 2.4
python << 2.8
python >= 2.7~
python2.7 -
python:any >= 2.7.5-5~

Download

Type URL
Binary Package pyrite-publisher_2.1.1-11_i386.deb
Source Package pyrite-publisher

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pyrite-publisher deb package:
    # sudo apt-get install pyrite-publisher

Files

Path
/usr/bin/pyrpub
/usr/lib/pyrite-publisher/pyrite_publisher-2.1.1.egg-info
/usr/lib/pyrite-publisher/pyrpub
/usr/lib/pyrite-publisher/PyritePublisher/_Doc.so
/usr/lib/pyrite-publisher/PyritePublisher/__init__.py
/usr/lib/pyrite-publisher/PyritePublisher/config.py
/usr/lib/pyrite-publisher/PyritePublisher/dbprotocol.py
/usr/lib/pyrite-publisher/PyritePublisher/doc_compress.py
/usr/lib/pyrite-publisher/PyritePublisher/doc_database.py
/usr/lib/pyrite-publisher/PyritePublisher/dtkmain.py
/usr/lib/pyrite-publisher/PyritePublisher/dtkplugins.py
/usr/lib/pyrite-publisher/PyritePublisher/entitydefs.py
/usr/lib/pyrite-publisher/PyritePublisher/gui_wxwin.py
/usr/lib/pyrite-publisher/PyritePublisher/metrics.py
/usr/lib/pyrite-publisher/PyritePublisher/plugin.py
/usr/lib/pyrite-publisher/PyritePublisher/plugin_CSV.py
/usr/lib/pyrite-publisher/PyritePublisher/plugin_HTML.py
/usr/lib/pyrite-publisher/PyritePublisher/plugin_RichReader.py
/usr/lib/pyrite-publisher/PyritePublisher/plugin_TaggedText.py
/usr/lib/pyrite-publisher/PyritePublisher/plugin_TealDoc.py
/usr/lib/pyrite-publisher/PyritePublisher/plugin_Text.py
/usr/lib/pyrite-publisher/PyritePublisher/plugin_URLStream.py
/usr/lib/pyrite-publisher/PyritePublisher/plugin_WebInput.py
/usr/lib/pyrite-publisher/PyritePublisher/plugin_basicdoc.py
/usr/lib/pyrite-publisher/PyritePublisher/plugin_copydoc.py
/usr/lib/pyrite-publisher/PyritePublisher/plugin_dbfieldguess.py
/usr/lib/pyrite-publisher/PyritePublisher/plugin_docoutput.py
/usr/lib/pyrite-publisher/PyritePublisher/plugin_frotz.py
/usr/lib/pyrite-publisher/PyritePublisher/plugin_instjpilot.py
/usr/lib/pyrite-publisher/PyritePublisher/plugin_instpisock.py
/usr/lib/pyrite-publisher/PyritePublisher/plugin_jfile.py
/usr/lib/pyrite-publisher/PyritePublisher/plugin_pdbinput.py
/usr/lib/pyrite-publisher/PyritePublisher/plugin_pdboutput.py
/usr/lib/pyrite-publisher/PyritePublisher/plugin_textoutput.py
/usr/lib/pyrite-publisher/PyritePublisher/plugin_ztxtoutput.py
/usr/lib/pyrite-publisher/PyritePublisher/pp_meta.py
/usr/lib/pyrite-publisher/PyritePublisher/prc.py
/usr/lib/pyrite-publisher/PyritePublisher/ztxt.py
/usr/share/doc-base/pyrite-publisher
/usr/share/doc/pyrite-publisher/NEWS.gz
/usr/share/doc/pyrite-publisher/README.GUI
/usr/share/doc/pyrite-publisher/README.txt.gz
/usr/share/doc/pyrite-publisher/changelog.Debian.gz
/usr/share/doc/pyrite-publisher/copyright
/usr/share/doc/pyrite-publisher/pyrite-publisher-rich.pdb.gz
/usr/share/doc/pyrite-publisher/pyrite-publisher-teal.pdb.gz
/usr/share/doc/pyrite-publisher/pyrite-publisher-ztxt.pdb.gz
/usr/share/doc/pyrite-publisher/pyrite-publisher.css
/usr/share/doc/pyrite-publisher/pyrite-publisher.html
/usr/share/doc/pyrite-publisher/pyrite-publisher.pdb.gz
/usr/share/man/man1/pyrpub.1.gz
/usr/share/python/runtime.d/pyrite-publisher.rtupdate

Changelog

2015-10-21 - Daniel Stender <debian@danielstender.com>
pyrite-publisher (2.1.1-11) unstable; urgency=medium
* QA upload.
* deb/control:
+ changed Section to "text" ("otherosfs" isn't accurate).
+ changed Priority to "optional" (usually if does not conflict).
+ bumped Debhelper dep to >= 9 (updated also deb/compat).
+ added dh-python to build-deps.
+ bumped standards version to 3.9.6.
+ added Homepage.
+ added Vcs fields (set up collab-maint repo).
+ added ${misc:Depends} to Depends.
* deb/copyright: rewritten to match DEP-5.
* deb/docs: don't copy whole folder doc/pyrite-publisher (Closes: #289229).
* deb/rules: rewritten for private modules with dh sequencer and Pybuild.
* deb/pyrite-publisher.doc-base: corrected Section, updated.
* deb/watch: updated (Closes: #449938).
* Dropped deb/dirs, deb/pycompat (deprecated).
* Added:
+ deb/gbp.conf.
+ deb/source/local-options (unapply-patches).
+ deb/links (link pyrpub to /usr/bin).
+ complete-manpage.patch (Closes: #290561).
* Wrap-and-sort -a -s.
2014-08-18 - Olly Betts <olly@survex.com>
pyrite-publisher (2.1.1-10) unstable; urgency=medium
* QA upload.
* Update to use source format "3.0 (quilt)" to allow sane patch handling:
+ Existing changes from debian diff now in direct-changes.patch.
* Update to use wxPython 3.0:
+ New patch: wxpy3.0-compat.patch
* Update man page (new patch: man-page-fixes.patch):
+ Say "pyrpub" not "dtk" in the synopsis.  (Closes: #290156)
+ Document that "pyrpub" with no arguments starts the GUI.
2014-07-13 - Matthias Klose <doko@debian.org>
pyrite-publisher (2.1.1-9) unstable; urgency=medium
* QA upload.
* Build using dh_python2
2013-07-13 - Luca Falavigna <dktrkranz@debian.org>
pyrite-publisher (2.1.1-8) unstable; urgency=low
* QA upload.
- Set Maintainer to Debian QA Group.
* debian/rules:
- Remove obsolete dh_python call (Closes: #715303).
2011-10-20 - Olly Betts <olly@survex.com>
pyrite-publisher (2.1.1-7.1) unstable; urgency=low
* Non-maintainer upload at request of maintainer.
* Update "Suggests:" from python-wxgtk2.6 to python-wxgtk2.8.
(Closes: #645567)
* README.Debian: Remove, since this package now supports all python versions
in the usual way (looks like that was fixed in 2.1.1-5.1).
* Add ${shlibs:Depends} to "Depends:" to fix lintian error
missing-dependency-on-libc.
2006-10-23 - Daniel Martin <fizbin@debian.org>
pyrite-publisher (2.1.1-7) unstable; urgency=low
* Don't spout spurious messages when exiting normally.
2006-10-22 - Daniel Martin <fizbin@debian.org>
pyrite-publisher (2.1.1-6) unstable; urgency=low
* Switch string.join(a,b) to b.join(a) to fix error from not importing
string. (Closes: 387284)
* Remove no-longer-necessary notebook_sizer in gui.
* Add better warning/error messages when trying to use the gui without
an appropriate wxpython installed.
2006-08-04 - Pierre Habouzit <madcoder@debian.org>
pyrite-publisher (2.1.1-5.2) unstable; urgency=low
* Non-maintainer upload.
* Strip old pre/postrm that are not needed anymore (Closes: #381390).
(previous NMU should have done that, fixing my mess).
2006-08-02 - Pierre Habouzit <madcoder@debian.org>
pyrite-publisher (2.1.1-5.1) unstable; urgency=low
* Non-maintainer upload.
* Bump DH_COMPAT to 5.
* Compile for current python instead of hardcoding python2.3.
* Bump Standards-Version to 3.7.2.
* Update package for the new python policy (Closes: #380916).
* Fix various lintian warnings (especialy wrong doc-base).
2005-11-02 - Daniel Martin <fizbin@debian.org>
pyrite-publisher (2.1.1-5) unstable; urgency=low
* New wxwindows and python package. (closes: Bug#328408)

See Also

Package Description
pyro-doc_3.16-1_all.deb documentation for Pyro
pyro-examples_3.16-1_all.deb examples for Pyro
pyro-gui_3.16-1_all.deb graphical tool for Pyro
pyro4-doc_4.61-1_all.deb distributed object middleware for Python (RPC), documentation
pyro4-examples_4.61-1_all.deb distributed object middleware for Python (RPC), examples
pyro4_4.61-1_all.deb distributed object middleware for Python (RPC)
pyro_3.16-1_all.deb distributed object system for Python
pyroman_0.5.0-1_all.deb Very fast firewall configuration tool
pyromaths_11.05.1b2-0ubuntu1_all.deb Generator for math worksheets for french college
pyroom_0.4.1-6_all.deb distractionless fullscreen text editor
pysassc_0.12.3-2ubuntu4_all.deb SASS for Python: command line utility for libsass
pysatellites_2.4-2_all.deb simulates the launching of satellites
pyscanfcs_0.2.3-3ubuntu3_i386.deb scientific tool for perpendicular line scanning FCS
pyscrabble-common_1.6.2-10_all.deb multiplayer scrabble implementation - common files
pyscrabble-server_1.6.2-10_all.deb scrabble implementation written in Python - server part
Advertisement
Advertisement