pypy-zmq_16.0.2-2build2_i386.deb


Advertisement

Description

pypy-zmq - PyPy bindings for 0MQ library

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name pypy-zmq
Package version 16.0.2
Package release 2build2
Package architecture i386
Package type deb
Installed size 601 B
Download size 105.67 KB
Official Mirror archive.ubuntu.com
Python bindings for 0MQ. 0MQ is a small, fast, and free
software library that gives you message-passing concurrency
for applications in most common languages.
The 0MQ lightweight messaging kernel is a library which
extends the standard socket interfaces with features
traditionally provided by specialised messaging middleware
products. 0MQ sockets provide an abstraction of asynchronous
message queues, multiple messaging patterns, message
filtering (subscriptions), seamless access to multiple
transport protocols and more.
This package contains the extension built for the PyPy interpreter.

Alternatives

Package Version Architecture Repository
pypy-zmq_16.0.2-2build2_amd64.deb 16.0.2 amd64 Ubuntu Universe
pypy-zmq - - -

Requires

Name Value
libc6 >= 2.3.6-6~
libzmq5 >= 4.1.2
pypy >= 2.2
pypy-abi-41 -

Download

Type URL
Binary Package pypy-zmq_16.0.2-2build2_i386.deb
Source Package pyzmq

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pypy-zmq deb package:
    # sudo apt-get install pypy-zmq

Files

Path
/usr/lib/pypy/dist-packages/pyzmq-16.0.2.egg-info
/usr/lib/pypy/dist-packages/zmq/__init__.py
/usr/lib/pypy/dist-packages/zmq/decorators.py
/usr/lib/pypy/dist-packages/zmq/error.py
/usr/lib/pypy/dist-packages/zmq/auth/__init__.py
/usr/lib/pypy/dist-packages/zmq/auth/base.py
/usr/lib/pypy/dist-packages/zmq/auth/certs.py
/usr/lib/pypy/dist-packages/zmq/auth/ioloop.py
/usr/lib/pypy/dist-packages/zmq/auth/thread.py
/usr/lib/pypy/dist-packages/zmq/backend/__init__.py
/usr/lib/pypy/dist-packages/zmq/backend/select.py
/usr/lib/pypy/dist-packages/zmq/backend/cffi/__init__.py
/usr/lib/pypy/dist-packages/zmq/backend/cffi/_cdefs.h
/usr/lib/pypy/dist-packages/zmq/backend/cffi/_cffi.py
/usr/lib/pypy/dist-packages/zmq/backend/cffi/_cffi_ext.pypy-41-i386-linux-gnu.so
/usr/lib/pypy/dist-packages/zmq/backend/cffi/_poll.py
/usr/lib/pypy/dist-packages/zmq/backend/cffi/_verify.c
/usr/lib/pypy/dist-packages/zmq/backend/cffi/constants.py
/usr/lib/pypy/dist-packages/zmq/backend/cffi/context.py
/usr/lib/pypy/dist-packages/zmq/backend/cffi/devices.py
/usr/lib/pypy/dist-packages/zmq/backend/cffi/error.py
/usr/lib/pypy/dist-packages/zmq/backend/cffi/message.py
/usr/lib/pypy/dist-packages/zmq/backend/cffi/socket.py
/usr/lib/pypy/dist-packages/zmq/backend/cffi/utils.py
/usr/lib/pypy/dist-packages/zmq/devices/__init__.py
/usr/lib/pypy/dist-packages/zmq/devices/basedevice.py
/usr/lib/pypy/dist-packages/zmq/devices/monitoredqueue.pxd
/usr/lib/pypy/dist-packages/zmq/devices/monitoredqueue.py
/usr/lib/pypy/dist-packages/zmq/devices/monitoredqueuedevice.py
/usr/lib/pypy/dist-packages/zmq/devices/proxydevice.py
/usr/lib/pypy/dist-packages/zmq/eventloop/__init__.py
/usr/lib/pypy/dist-packages/zmq/eventloop/future.py
/usr/lib/pypy/dist-packages/zmq/eventloop/ioloop.py
/usr/lib/pypy/dist-packages/zmq/eventloop/zmqstream.py
/usr/lib/pypy/dist-packages/zmq/eventloop/minitornado/__init__.py
/usr/lib/pypy/dist-packages/zmq/eventloop/minitornado/concurrent.py
/usr/lib/pypy/dist-packages/zmq/eventloop/minitornado/ioloop.py
/usr/lib/pypy/dist-packages/zmq/eventloop/minitornado/log.py
/usr/lib/pypy/dist-packages/zmq/eventloop/minitornado/stack_context.py
/usr/lib/pypy/dist-packages/zmq/eventloop/minitornado/util.py
/usr/lib/pypy/dist-packages/zmq/eventloop/minitornado/platform/__init__.py
/usr/lib/pypy/dist-packages/zmq/eventloop/minitornado/platform/auto.py
/usr/lib/pypy/dist-packages/zmq/eventloop/minitornado/platform/common.py
/usr/lib/pypy/dist-packages/zmq/eventloop/minitornado/platform/interface.py
/usr/lib/pypy/dist-packages/zmq/eventloop/minitornado/platform/posix.py
/usr/lib/pypy/dist-packages/zmq/eventloop/minitornado/platform/windows.py
/usr/lib/pypy/dist-packages/zmq/green/__init__.py
/usr/lib/pypy/dist-packages/zmq/green/core.py
/usr/lib/pypy/dist-packages/zmq/green/device.py
/usr/lib/pypy/dist-packages/zmq/green/poll.py
/usr/lib/pypy/dist-packages/zmq/green/eventloop/__init__.py
/usr/lib/pypy/dist-packages/zmq/green/eventloop/ioloop.py
/usr/lib/pypy/dist-packages/zmq/green/eventloop/zmqstream.py
/usr/lib/pypy/dist-packages/zmq/log/__init__.py
/usr/lib/pypy/dist-packages/zmq/log/handlers.py
/usr/lib/pypy/dist-packages/zmq/ssh/__init__.py
/usr/lib/pypy/dist-packages/zmq/ssh/forward.py
/usr/lib/pypy/dist-packages/zmq/ssh/tunnel.py
/usr/lib/pypy/dist-packages/zmq/sugar/__init__.py
/usr/lib/pypy/dist-packages/zmq/sugar/attrsettr.py
/usr/lib/pypy/dist-packages/zmq/sugar/constants.py
/usr/lib/pypy/dist-packages/zmq/sugar/context.py
/usr/lib/pypy/dist-packages/zmq/sugar/frame.py
/usr/lib/pypy/dist-packages/zmq/sugar/poll.py
/usr/lib/pypy/dist-packages/zmq/sugar/socket.py
/usr/lib/pypy/dist-packages/zmq/sugar/stopwatch.py
/usr/lib/pypy/dist-packages/zmq/sugar/tracker.py
/usr/lib/pypy/dist-packages/zmq/sugar/version.py
/usr/lib/pypy/dist-packages/zmq/tests/__init__.py
/usr/lib/pypy/dist-packages/zmq/tests/test_auth.py
/usr/lib/pypy/dist-packages/zmq/tests/test_cffi_backend.py
/usr/lib/pypy/dist-packages/zmq/tests/test_constants.py
/usr/lib/pypy/dist-packages/zmq/tests/test_context.py
/usr/lib/pypy/dist-packages/zmq/tests/test_decorators.py
/usr/lib/pypy/dist-packages/zmq/tests/test_device.py
/usr/lib/pypy/dist-packages/zmq/tests/test_error.py
/usr/lib/pypy/dist-packages/zmq/tests/test_etc.py
/usr/lib/pypy/dist-packages/zmq/tests/test_future.py
/usr/lib/pypy/dist-packages/zmq/tests/test_imports.py
/usr/lib/pypy/dist-packages/zmq/tests/test_includes.py
/usr/lib/pypy/dist-packages/zmq/tests/test_ioloop.py
/usr/lib/pypy/dist-packages/zmq/tests/test_log.py
/usr/lib/pypy/dist-packages/zmq/tests/test_message.py
/usr/lib/pypy/dist-packages/zmq/tests/test_monitor.py
/usr/lib/pypy/dist-packages/zmq/tests/test_monqueue.py
/usr/lib/pypy/dist-packages/zmq/tests/test_multipart.py
/usr/lib/pypy/dist-packages/zmq/tests/test_pair.py
/usr/lib/pypy/dist-packages/zmq/tests/test_poll.py
/usr/lib/pypy/dist-packages/zmq/tests/test_pubsub.py
/usr/lib/pypy/dist-packages/zmq/tests/test_reqrep.py
/usr/lib/pypy/dist-packages/zmq/tests/test_retry_eintr.py
/usr/lib/pypy/dist-packages/zmq/tests/test_security.py
/usr/lib/pypy/dist-packages/zmq/tests/test_socket.py
/usr/lib/pypy/dist-packages/zmq/tests/test_ssh.py
/usr/lib/pypy/dist-packages/zmq/tests/test_version.py
/usr/lib/pypy/dist-packages/zmq/tests/test_win32_shim.py
/usr/lib/pypy/dist-packages/zmq/tests/test_z85.py
/usr/lib/pypy/dist-packages/zmq/tests/test_zmqstream.py
/usr/lib/pypy/dist-packages/zmq/utils/__init__.py
/usr/lib/pypy/dist-packages/zmq/utils/buffers.pxd
/usr/lib/pypy/dist-packages/zmq/utils/compiler.json
/usr/lib/pypy/dist-packages/zmq/utils/config.json
/usr/lib/pypy/dist-packages/zmq/utils/constant_names.py
/usr/lib/pypy/dist-packages/zmq/utils/garbage.py
/usr/lib/pypy/dist-packages/zmq/utils/getpid_compat.h
/usr/lib/pypy/dist-packages/zmq/utils/interop.py
/usr/lib/pypy/dist-packages/zmq/utils/ipcmaxlen.h
/usr/lib/pypy/dist-packages/zmq/utils/jsonapi.py
/usr/lib/pypy/dist-packages/zmq/utils/monitor.py
/usr/lib/pypy/dist-packages/zmq/utils/pyversion_compat.h
/usr/lib/pypy/dist-packages/zmq/utils/sixcerpt.py
/usr/lib/pypy/dist-packages/zmq/utils/strtypes.py
/usr/lib/pypy/dist-packages/zmq/utils/win32.py
/usr/lib/pypy/dist-packages/zmq/utils/z85.py
/usr/lib/pypy/dist-packages/zmq/utils/zmq_compat.h
/usr/lib/pypy/dist-packages/zmq/utils/zmq_constants.h
/usr/share/doc/pypy-zmq/changelog.Debian.gz
/usr/share/doc/pypy-zmq/copyright

Changelog

2017-08-05 - Matthias Klose <doko@ubuntu.com>
pyzmq (16.0.2-2build2) artful; urgency=medium
* No-change rebuild to build to drop python3.5.
2017-05-16 - Bhavani Shankar <bhavi@ubuntu.com>
pyzmq (16.0.2-2build1) artful; urgency=medium
* Rebuild for python 3.6 support.
2016-12-22 - Julian Taylor <jtaylor.debian@googlemail.com>
pyzmq (16.0.2-2) unstable; urgency=medium
* skip some randomly failing or hanging tests, the package is still
functional enough for its rdependencies
* don't create dbgsym packages
2016-10-30 - Julian Taylor <jtaylor.debian@googlemail.com>
pyzmq (16.0.2-1) unstable; urgency=medium
* New upstream release.
* update build dependencies for new minimum python 2.7 and 3.3
2016-08-24 - Julian Taylor <jtaylor.debian@googlemail.com>
pyzmq (15.4.0-1) unstable; urgency=medium
* New upstream release.
* remove upstream applied patches:
- handle-no-tornado
- noncopysend-test.patch
- thread_auth_fixes
* remove obsolete debian/copyright sections
* add pytest to build depends
* remove python3 test special case, obsolete by pytest
* update adt-tests to pytest
2016-04-20 - Julian Taylor <jtaylor@ubuntu.com>
pyzmq (15.2.0-1) unstable; urgency=medium
[ Ondřej Nový ]
* Fixed VCS URL (https)
[ Julian Taylor ]
* New upstream release.
* debian/patches/skip_large_send: skip high memory using test
* debian/patches/thread_auth_fixes: attempt to fix test hangs on ports
* remove asyncio.py from python2, syntax not compatible
* bump standard to 3.9.7, no changes necessary
2016-01-10 - Stefano Rivera <stefanor@debian.org>
pyzmq (15.1.0-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Add LGPL-3 exemption for linking.
* Build-Depend on python{,3}-tornado.
* Delete _test_asyncio.py from Python 2.x packages, to avoid a byte
compilation failure at install time.
* Patch upstream tests to allocate a buffer for zmq_getsockopt to write to.
* Handle the lack of a pypy-tornado by skipping the tests.
* Drop the absolute import patch, and instead discover tests by module, not
path.
2015-09-17 - Vincent Bernat <bernat@debian.org>
pyzmq (14.4.0-4) unstable; urgency=medium
[ Vincent Bernat ]
* Also B-D on python3-cffi-backend-dbg.
[ Julian Taylor ]
* fix test import failure due to missing python3 gevent
(Closes: #800732)
* remove obsolete XS-Testsuite
* bump to debian/compat 9
2015-09-15 - Vincent Bernat <bernat@debian.org>
pyzmq (14.4.0-3) unstable; urgency=medium
* CFFI backend was relying on the presence of gcc to get the multiarch
triplet. Get this information from sys instead. This should fix the
autopkgtest.
2015-08-29 - Vincent Bernat <bernat@debian.org>
pyzmq (14.4.0-2) unstable; urgency=medium
* Add missing python{,3}-cffi, python-cffi-backend-dbg,
python-gevent{,-dbg} and python-numpy-dbg build-dependencies to run
tests.  Closes: #796930.
* Bump Standard To 3.9.6.
* Add myself to uploaders.
* Remove runtime dependency on gcc and libzmq3-dev.

See Also

Package Description
pypy_5.8.0+dfsg-2_i386.deb fast alternative implementation of Python - PyPy interpreter
pyqi_0.3.2+dfsg-2_all.deb Python framework for wrapping general commands in multiple interfaces
pyqso_1.0.0-1_all.deb logging tool for amateur radio operators
pyqt4-dev-tools_4.11.4+dfsg-2build2_i386.deb Development tools for PyQt4
pyqt4.qsci-dev_2.9.3+dfsg-5_all.deb Development files for Python Qscintilla2 (Qt4)
pyqt5-dev-tools_5.7+dfsg-6_i386.deb Development tools for PyQt5
pyqt5-dev_5.7+dfsg-6_all.deb Development files for PyQt5
pyqt5-doc_5.7+dfsg-6_all.deb Documentation for PyQt5
pyqt5-examples_5.7+dfsg-6_all.deb Examples and demos for PyQt5
pyqt5.qsci-dev_2.9.3+dfsg-5_all.deb Development files for Python Qscintilla2 (Qt5)
pyracerz_0.2-8_all.deb multiplayer top view 2D racing game
pyragua_0.2.5-6_all.deb Very lightweight Python editor
pyrenamer_0.6.0-1.2_all.deb mass file renamer written in PyGTK
pyrex-mode_0.9.9-1_all.deb emacs-lisp pyrex-mode for pyrex
pyrit-opencl_0.4.0-1_i386.deb OpenCL extension module for Pyrit
Advertisement
Advertisement