pypy-pyasn1_0.1.9-2_all.deb


Advertisement

Description

pypy-pyasn1 - ASN.1 library for Python (PyPy module)

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name pypy-pyasn1
Package version 0.1.9
Package release 2
Package architecture all
Package type deb
Installed size 191 B
Download size 27.41 KB
Official Mirror archive.ubuntu.com
This  is  an implementation  of  ASN.1  types  and codecs  in  Python
programming language. It has been first written to support particular
protocol (SNMP) but then generalized  to be suitable for a wide range
of protocols based on ASN.1 specification.
This package contains the PyPy module.

Alternatives

Package Version Architecture Repository
pypy-pyasn1_0.1.9-2_all.deb 0.1.9 all Ubuntu Universe
pypy-pyasn1 - - -

Requires

Name Value
pypy -

Download

Type URL
Binary Package pypy-pyasn1_0.1.9-2_all.deb
Source Package pyasn1

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pypy-pyasn1 deb package:
    # sudo apt-get install pypy-pyasn1

Files

Path
/usr/lib/pypy/dist-packages/pyasn1/__init__.py
/usr/lib/pypy/dist-packages/pyasn1/debug.py
/usr/lib/pypy/dist-packages/pyasn1/error.py
/usr/lib/pypy/dist-packages/pyasn1-0.1.9.egg-info/PKG-INFO
/usr/lib/pypy/dist-packages/pyasn1-0.1.9.egg-info/dependency_links.txt
/usr/lib/pypy/dist-packages/pyasn1-0.1.9.egg-info/top_level.txt
/usr/lib/pypy/dist-packages/pyasn1-0.1.9.egg-info/zip-safe
/usr/lib/pypy/dist-packages/pyasn1/codec/__init__.py
/usr/lib/pypy/dist-packages/pyasn1/codec/ber/__init__.py
/usr/lib/pypy/dist-packages/pyasn1/codec/ber/decoder.py
/usr/lib/pypy/dist-packages/pyasn1/codec/ber/encoder.py
/usr/lib/pypy/dist-packages/pyasn1/codec/ber/eoo.py
/usr/lib/pypy/dist-packages/pyasn1/codec/cer/__init__.py
/usr/lib/pypy/dist-packages/pyasn1/codec/cer/decoder.py
/usr/lib/pypy/dist-packages/pyasn1/codec/cer/encoder.py
/usr/lib/pypy/dist-packages/pyasn1/codec/der/__init__.py
/usr/lib/pypy/dist-packages/pyasn1/codec/der/decoder.py
/usr/lib/pypy/dist-packages/pyasn1/codec/der/encoder.py
/usr/lib/pypy/dist-packages/pyasn1/compat/__init__.py
/usr/lib/pypy/dist-packages/pyasn1/compat/binary.py
/usr/lib/pypy/dist-packages/pyasn1/compat/octets.py
/usr/lib/pypy/dist-packages/pyasn1/type/__init__.py
/usr/lib/pypy/dist-packages/pyasn1/type/base.py
/usr/lib/pypy/dist-packages/pyasn1/type/char.py
/usr/lib/pypy/dist-packages/pyasn1/type/constraint.py
/usr/lib/pypy/dist-packages/pyasn1/type/error.py
/usr/lib/pypy/dist-packages/pyasn1/type/namedtype.py
/usr/lib/pypy/dist-packages/pyasn1/type/namedval.py
/usr/lib/pypy/dist-packages/pyasn1/type/tag.py
/usr/lib/pypy/dist-packages/pyasn1/type/tagmap.py
/usr/lib/pypy/dist-packages/pyasn1/type/univ.py
/usr/lib/pypy/dist-packages/pyasn1/type/useful.py
/usr/share/doc/pypy-pyasn1/changelog.Debian.gz
/usr/share/doc/pypy-pyasn1/copyright

Changelog

2016-09-10 - Vincent Bernat <bernat@debian.org>
pyasn1 (0.1.9-2) unstable; urgency=medium
[ Ondřej Nový ]
* Fixed VCS URL (https)
[ Vincent Bernat ]
* Switch to pybuild for build. It's far easier to get proper pypy
support this way.  This happens to closes: #837025 (FTBFS).
2015-10-07 - Tristan Seligmann <mithrandi@debian.org>
pyasn1 (0.1.9-1) unstable; urgency=medium
* Add pydist files.
* New upstream release.
* Add myself to uploaders.
2015-09-04 - Tristan Seligmann <mithrandi@debian.org>
pyasn1 (0.1.8-2) unstable; urgency=medium
* Team upload.
* Add pypy-pyasn1 package.
* Remove deprecated DEB_COMPRESS_EXCLUDE.
* Bump debhelper compat level (no changes needed).
2015-07-28 - Vincent Bernat <bernat@debian.org>
pyasn1 (0.1.8-1) unstable; urgency=medium
* New upstream release
* Bump Standards-Version to 3.9.6.
* Run unittests with Python 3 too.
2013-09-24 - Vincent Bernat <bernat@debian.org>
pyasn1 (0.1.7-1) unstable; urgency=low
[ Vincent Bernat ]
* New upstream release.
* Bump Standards-Version to 3.9.4.
* Examples are not provided any more. Ship more documentation instead.
* Add python3-pyasn1 package for Python 3 support.
* Update debian/copyright to reflect licensing change.
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
[ Yaroslav Halchenko ]
* Team upload
* New upstream release (Closes: #691421)
* debian/rules:
- run tests (test/suite.py) upon build
2012-05-21 - Arnaud Fontaine <arnau@debian.org>
pyasn1 (0.1.3-1) unstable; urgency=low
* Team upload.
[ Deepak Tripathi ]
* debian/watch
+ updated source to sf.net redirector.
[Arnaud Fontaine]
* New upstream release. Closes: #651686.
+ PyASN1 manual has been renamed, thus update doc-base.
* Fix FTBFS if built twice by adding debian/source/options to ignore
changes to .egg-info directory. Closes: #671249.
* Switch from python-support to dh_python2.
* debian/watch: fix regex to not match pyasn1-modules.
* debian/copyright: switch to machine-readable format.
* debian/control:
+ Add doc-base to Suggests.
+ Bump Standards-Version to 3.9.3. No changes needed.
+ Build-Depends on python-all rather than only python.
2010-05-14 - Deepak Tripathi <apenguinlinux@gmail.com>
pyasn1 (0.0.11a-1) unstable; urgency=low
* New upstream release (Closes: #579556).
* Bumped Standard version to 3.8.4 (No changes).
* debian/control:
+ Added myself to Uploaders.
+ Added ${misc:Depends}.
+ Aemoved python-dev and added python.
* debian/copyright
+ Added debian's copyright information.
+ Formated and updated copy information.
* Added debian/python-pyasn1.doc-base.
* debian/source:
+ Switch to dpkg-source 3.0 (quilt) format.
[Arnaud Fontaine]
* debian/control:
+ Remove myself from Maintainer as Jan Lübbe is now the maintainer.
2008-05-29 - Arnaud Fontaine <arnau@debian.org>
pyasn1 (0.0.8a-1) unstable; urgency=low
[ Arnaud Fontaine ]
* New upstream release.
* New email address.
* Remove useless debian/control.in.
* debian/control:
+ Update Standards-Version to 3.7.3. No changes needed.
[ Piotr Ożarowski ]
* debian/control:
+ Add Vcs-Browser and Homepage fields.
+ Rename XS-Vcs-Svn field to Vcs-Svn.
[ Sandro Tosi ]
* debian/control:
- Uniformise Vcs-Browser field.
* debian/control
- switch Vcs-Browser field to viewsvn
2007-08-26 - Jan Luebbe <jluebbe@debian.org>
pyasn1 (0.0.7a-1) unstable; urgency=low
* New upstream release
* Update my maintainer address
2007-04-16 - Arnaud Fontaine <arnaud@andesi.org>
pyasn1 (0.0.6a-1) unstable; urgency=low
[ Arnaud Fontaine ]
* New upstream release.
* Add egg support.
[ Piotr Ozarowski ]
* Added XS-Vcs-Svn field

See Also

Package Description
pypy-pyparsing_2.1.10+dfsg1-1_all.deb Python parsing module, Python3 package
pypy-pytest_3.1.3-1ubuntu1_all.deb Simple, powerful testing in PyPy
pypy-rply_0.7.4-3_all.deb pure Python based parser that also works with RPython (PyPy)
pypy-schema_0.6.6-2_all.deb simple data validation library (PyPy)
pypy-setuptools-scm_1.15.6-1_all.deb blessed package to manage your versions by scm tags for PyPy
pypy-setuptools_36.2.7-2_all.deb PyPy Distutils Enhancements
pypy-simplejson_3.11.1-1build1_all.deb simple, fast, extensible JSON encoder/decoder for Python - PyPy
pypy-six_1.10.0-4_all.deb Python 2 and 3 compatibility library (PyPy interface)
pypy-sqlparse_0.2.2-1_all.deb non-validating SQL parser for PyPy
pypy-tk_5.8.0+dfsg-2_i386.deb Tkinter module for PyPy (an alternative Python interpreter)
pypy-unidecode_0.04.19-1_all.deb ASCII transliterations of Unicode text (PyPy module)
pypy-wand_0.4.4-1.1_all.deb Python interface for ImageMagick library (PyPy build)
pypy-zmq_16.0.2-2build2_i386.deb PyPy bindings for 0MQ library
pypy_5.8.0+dfsg-2_i386.deb fast alternative implementation of Python - PyPy interpreter
pyqi_0.3.2+dfsg-2_all.deb Python framework for wrapping general commands in multiple interfaces
Advertisement
Advertisement