pyosmium_2.12.4-1_all.deb


Advertisement

Description

pyosmium - Osmium library bindings for Python - utilities

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name pyosmium
Package version 2.12.4
Package release 1
Package architecture all
Package type deb
Installed size 20 B
Download size 5.40 KB
Official Mirror archive.ubuntu.com
The PyOsmium module allows you to access some of the features of the Osmium
library from Python code.
PyOsmium has extensive support for all types of OSM entities: nodes, ways,
relations, and changesets. It allows reading from OSM files in XML and PBF
formats, including change files and full history files. Its easy to use
handler interface allows you to quickly write data filtering and conversion
functions.
This package contains the PyOsmium utilities.

Alternatives

Package Version Architecture Repository
pyosmium_2.12.4-1_all.deb 2.12.4 all Ubuntu Universe
pyosmium - - -

Requires

Name Value
python-pyosmium >= 2.12.4-1

Download

Type URL
Binary Package pyosmium_2.12.4-1_all.deb
Source Package pyosmium

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pyosmium deb package:
    # sudo apt-get install pyosmium

Files

Path
/usr/bin/pyosmium-get-changes
/usr/bin/pyosmium-up-to-date
/usr/share/doc/pyosmium/changelog.Debian.gz
/usr/share/doc/pyosmium/copyright
/usr/share/man/man1/pyosmium-get-changes.1.gz
/usr/share/man/man1/pyosmium-up-to-date.1.gz

Changelog

2017-08-20 - Bas Couwenberg <sebastic@debian.org>
pyosmium (2.12.4-1) unstable; urgency=medium
* New upstream release.
2017-06-25 - Bas Couwenberg <sebastic@debian.org>
pyosmium (2.12.3-2) unstable; urgency=medium
* Bump Standards-Version to 4.0.0, no changes.
* Add autopkgtest to test installability.
* Enable PIE hardening buildflags.
2017-06-18 - Bas Couwenberg <sebastic@debian.org>
pyosmium (2.12.3-1) unstable; urgency=medium
* Move from experimental to unstable.
2017-05-26 - Bas Couwenberg <sebastic@debian.org>
pyosmium (2.12.3-1~exp1) experimental; urgency=medium
* New upstream release.
2017-05-05 - Bas Couwenberg <sebastic@debian.org>
pyosmium (2.12.2-1~exp1) experimental; urgency=medium
* New upstream release.
* Bump minimum required libosmium2-dev to 2.12.2.
* Update hardening-no-fortify-functions overrides for index.so.
2017-04-12 - Bas Couwenberg <sebastic@debian.org>
pyosmium (2.12.1-1~exp1) experimental; urgency=medium
* New upstream release.
* Bump minimum required libosmium2-dev to 2.12.1.
* Build & install upstream manpages for pyosmium utilities.
* Drop unused override for hardening-no-fortify-functions.
2017-03-20 - Bas Couwenberg <sebastic@debian.org>
pyosmium (2.12.0-1~exp1) experimental; urgency=medium
* New upstream release.
* Bump minimum required libosmium2-dev to 2.12.0.
* Add pyosmium binary package for utilities.
* Add man pages for pyosmium utilities.
* Add unused override for hardening-no-fortify-functions.
2017-01-17 - Bas Couwenberg <sebastic@debian.org>
pyosmium (2.11.0-1) unstable; urgency=medium
* Move from experimental to unstable.
2017-01-15 - Bas Couwenberg <sebastic@debian.org>
pyosmium (2.11.0-1~exp1) experimental; urgency=medium
* New upstream release.
* Drop patches, included upstream.
* Update copyright years for Sarah Hoffmann.
* Bump minimum required libosmium2-dev to 2.11.0.
2017-01-15 - Bas Couwenberg <sebastic@debian.org>
pyosmium (2.10.2-2~exp1) experimental; urgency=medium
* Add upstream patch to fix FTBFS with libosmium 2.11.0.

See Also

Package Description
pyotherside-doc_1.4.0-2build1_all.deb asynchronous Python 3 Bindings for Qt 5 (documentation)
pyotherside-tests_1.4.0-2build1_i386.deb Asynchronous Python 3 Bindings for Qt 5 (tests)
pyotherside_1.4.0-2build1_all.deb transitional dummy package
pyp_2.12-2_all.deb sed/awk-like tool with Python language
pypar2_1.4-7_all.deb graphical frontend for the par2 utility
pypass_0.2.0-1_all.deb lightweight directory-based password manager in python
pype_2.9.4-2_all.deb Python programmers editor
pypi2deb_1.20170623_all.deb PyPI to Debian converter
pypibrowser_1.5-2.1_all.deb graphical interface for browsing the Python Package Index
pyppd_1.0.2-4_all.deb CUPS PostScript Printer Driver's compressor and generator
pyprompter_0.9.1-2.1ubuntu4_all.deb intelligent predictive wxPython text editor
pypump-shell_0.7-1_all.deb interface to the pump.io APIs (pypump-shell program)
pypy-appdirs_1.4.3-1_all.deb determining appropriate platform-specific directories (PyPy)
pypy-asn1crypto_0.22.0-1_all.deb Fast ASN.1 parser and serializer (PyPy)
pypy-attr_17.2.0-1_all.deb Attributes without boilerplate (PyPy)
Advertisement
Advertisement