psad_2.4.3-1.1_i386.deb


Advertisement

Description

psad - Port Scan Attack Detector

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name psad
Package version 2.4.3
Package release 1.1
Package architecture i386
Package type deb
Installed size 698 B
Download size 148.07 KB
Official Mirror archive.ubuntu.com
PSAD is a collection of four lightweight system daemons (in Perl and
C) designed to work with iptables to detect port scans. It features:
* a set of highly configurable danger thresholds (with sensible
defaults provided);
* verbose alert messages that include the source, destination,
scanned port range, beginning and end times, TCP flags, and
corresponding Nmap options;
* reverse DNS information;
* alerts via email;
* automatic blocking of offending IP addresses via dynamic firewall
configuration.
When combined with fwsnort and the iptables string match extension,
PSAD is capable of detecting many attacks described in the Snort rule
set that involve application layer data.

Alternatives

Package Version Architecture Repository
psad_2.4.3-1.1_amd64.deb 2.4.3 amd64 Ubuntu Universe
psad - - -

Requires

Name Value
bsd-mailx -
default-mta -
iptables -
libc6 >= 2.4
libcarp-clan-perl -
libdate-calc-perl -
libiptables-chainmgr-perl -
libiptables-parse-perl -
libnet-ip-perl -
libunix-syslog-perl -
lsb-base -
mail-transport-agent -
mailutils -
mailx -
net-tools -
perl:any -
psmisc -
rsyslog -
system-log-daemon -
whois -

Download

Type URL
Binary Package psad_2.4.3-1.1_i386.deb
Source Package psad

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install psad deb package:
    # sudo apt-get install psad

Files

Path
/etc/default/psad
/etc/init.d/psad
/etc/psad/auto_dl
/etc/psad/icmp6_types
/etc/psad/icmp_types
/etc/psad/ip_options
/etc/psad/pf.os
/etc/psad/posf
/etc/psad/protocols
/etc/psad/psad.conf
/etc/psad/signatures
/etc/psad/snort_rule_dl
/usr/bin/nf2csv
/usr/sbin/fwcheck_psad
/usr/sbin/kmsgsd
/usr/sbin/psad
/usr/sbin/psadwatchd
/usr/share/doc/psad/BENCHMARK
/usr/share/doc/psad/CREDITS.gz
/usr/share/doc/psad/FW_EXAMPLE_RULES
/usr/share/doc/psad/FW_HELP
/usr/share/doc/psad/NEWS.Debian.gz
/usr/share/doc/psad/README.Debian
/usr/share/doc/psad/README.gz
/usr/share/doc/psad/SCAN_LOG
/usr/share/doc/psad/changelog.Debian.gz
/usr/share/doc/psad/copyright
/usr/share/man/man1/nf2csv.1.gz
/usr/share/man/man8/fwcheck_psad.8.gz
/usr/share/man/man8/kmsgsd.8.gz
/usr/share/man/man8/psad.8.gz
/usr/share/man/man8/psadwatchd.8.gz

Changelog

2017-08-06 - Adrian Bunk <bunk@debian.org>
psad (2.4.3-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Add the missing dependency on net-tools. (Closes: #867914)
2016-09-30 - Franck Joncourt <franck.joncourt@gmail.com>
psad (2.4.3-1) unstable; urgency=low
* New upstream release 2.4.3
* Acknowledged NMU.
* d/control:
+ Removed Daniel Gubser <guterm@debian.org> from Uploaders.
Thanks for his work.
+ Removed bastille package from suggests.
+ Added myself as Maintainer and updated my email address accordingly.
+ Bumped up Standards-Version to 3.9.8. No changes.
+ Removed dependency on dpkg-dev - not needed anymore
+ Updated version dependency on debhelper from 7 to 9.
+ Use secure URI (https) for VCS field
* Added GPG signature verification to debian/watch file. Upstream GPG
signature is stored in debian/upstream/signing-key.asc.
* d/psad.init:
+ Add LSB dependency on netfilter-persistent (should-start)
+ Closes: #771337 init-scripts: iptables-persistent initialized after psad
+ Kill both psad_fw_read and psad process when stopping psad according to
PID found in /var/run/psad.
* d/copyright:
+ Updated copyright years
+ Used secure URL to reference copyright format
* d/patches:
+ New patch to fix typo in manpages
+ Improve patch headers
2016-07-02 - Christian Hofstaedtler <zeha@debian.org>
psad (2.2.3-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Drop obsolete initscripts dependency.
It was introduced in commit 445de4eda7 for the /run transition, but
this only applied to pre-wheezy upgrades. (Closes: #804977)
Patch by Martin Pitt <martin.pitt@ubuntu.com>.
2014-08-25 - Franck Joncourt <franck@debian.org>
psad (2.2.3-1) unstable; urgency=low
* Imported Upstream version 2.2.3
- Closes: #724267 - permissions of /etc/hosts.deny are modified
* Bumped up debian policy to 3.9.5 (no changes)
* Updated Vcs URIs to use canonical names.
2014-01-17 - Franck Joncourt <franck@debian.org>
psad (2.2.2-1) unstable; urgency=low
* Imported Upstream version 2.2.2
2013-07-04 - gregor herrmann <gregoa@debian.org>
psad (2.2.1-2.1) unstable; urgency=low
* Non-maintainer upload with maintainer's permission.
* Fix "prompting due to modified conffiles which were not modified by
the user":
d/psad.preinst: also revert changes to conffile when we install with an
old version.
(Closes: #675231)
2013-01-06 - Franck Joncourt <franck@debian.org>
psad (2.2.1-2) unstable; urgency=low
* Enabled back the kmsgsd daemon.
- Refreshed patch fixes_build.diff.
- d.rules: Added back the kmsgsd daemon.
* d.rules: Added missing protocols files into /etc/psad.
2013-01-03 - Franck Joncourt <franck@debian.org>
psad (2.2.1-1) unstable; urgency=low
* Acknowledged NMU (2.2-3.1).
* d.rules : do not install the kmsgd daemon anymore since it is not
used anymore.
* Allowed the makefile to use the hardening flags :
- d.rules : added the hardening stanza
- fixes_build.diff : updated the Makefile to use the CFLAGS, CPPFLAGS
and LDFLAGS.
- d.control : Added BD on dpkg-dev (>= 1.16.1~)
* Imported Upstream version 2.2.1
- Removed applied patch t_upstream_hyphen.diff.
* Bumped up Standards-Version to 3.9.4:
- Added dependency ind.control against initscripts (>= 2.88dsf-13.3)
to ensure the run directory is available.
* d.control: Removed BD against lsb-base.
2012-11-18 - gregor herrmann <gregoa@debian.org>
psad (2.2-3.1) unstable; urgency=low
* Non-maintainer upload with maintainer's approval.
* Fix "modifies conffiles (policy 10.7.3): /etc/psad/psad.conf", second try:
- add back changes to d.psad.preinst that revert changes to
/etc/psad/psad.conf
- but only for upgrades from versions before 2.2-3
(Closes: #688891)

See Also

Package Description
pscan_1.2-9_i386.deb Format string security checker for C files
psensor-common_1.1.5-1ubuntu3_all.deb common files for Psensor and Psensor server
psensor-server_1.1.5-1ubuntu3_i386.deb Psensor server for monitoring hardware sensors remotely
psensor_1.1.5-1ubuntu3_i386.deb display graphs for monitoring hardware temperature
pseudo_1.8.1+git20161012-2_i386.deb advanced tool for simulating superuser privileges
psfex_3.17.1+dfsg-3_i386.deb Point Spread Function model extractor
psgml_1.4.0-7_all.deb Emacs major mode for editing SGML documents
psi-plus-common_0.16.330-1.3_all.deb common files for Psi+
psi-plus-l10n_0.16.330-1_all.deb localization files for Psi+
psi-plus-plugins_0.16.330-1.3_i386.deb plugins for Psi+
psi-plus-skins_0.16.330-1.3_all.deb skins for Psi+
psi-plus-sounds_0.16.330-1.3_all.deb sound files for Psi+
psi-plus-webkit_0.16.330-1.3_i386.deb Qt-based XMPP/Jabber client (WebKit version)
psi-plus_0.16.330-1.3_i386.deb Qt-based XMPP/Jabber client (basic version)
psi-translations_1.11_all.deb Translations for psi
Advertisement
Advertisement