postgresql-9.6-plr_8.3.0.17-1_i386.deb


Advertisement

Description

postgresql-9.6-plr - Procedural language interface between PostgreSQL and R

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name postgresql-9.6-plr
Package version 8.3.0.17
Package release 1
Package architecture i386
Package type deb
Installed size 377 B
Download size 211.69 KB
Official Mirror archive.ubuntu.com
R is a language and environment for statistical computing and graphics,
providing a wide variety of statistical and graphical techniques (linear and
nonlinear modelling, statistical tests, time series analysis, classification,
clustering, and so on).
PostgreSQL is an open source SQL database server.
This package provides a procedural language interface to R from
PostgreSQL. Procedural languages are used to write functions
which can be called in database queries.

Alternatives

Package Version Architecture Repository
postgresql-9.6-plr_8.3.0.17-1_amd64.deb 8.3.0.17 amd64 Ubuntu Universe
postgresql-9.6-plr - - -

Requires

Name Value
libc6 >= 2.4
postgresql-9.6 -
r-base-core >= 2.10

Provides

Name Value
postgresql-plr -

Download

Type URL
Binary Package postgresql-9.6-plr_8.3.0.17-1_i386.deb
Source Package plr

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install postgresql-9.6-plr deb package:
    # sudo apt-get install postgresql-9.6-plr

Files

Path
/usr/lib/postgresql/9.6/lib/plr.so
/usr/share/doc/postgresql-9.6-plr/changelog.Debian.gz
/usr/share/doc/postgresql-9.6-plr/copyright
/usr/share/doc/postgresql-9.6-plr/index.html
/usr/share/doc/postgresql-9.6-plr/plr-US.pdf.gz
/usr/share/doc/postgresql-9.6-plr/plr-aggregate-funcs.html
/usr/share/doc/postgresql-9.6-plr/plr-data.html
/usr/share/doc/postgresql-9.6-plr/plr-func-naming.html
/usr/share/doc/postgresql-9.6-plr/plr-funcs.html
/usr/share/doc/postgresql-9.6-plr/plr-global-data.html
/usr/share/doc/postgresql-9.6-plr/plr-install.html
/usr/share/doc/postgresql-9.6-plr/plr-license.html
/usr/share/doc/postgresql-9.6-plr/plr-module-funcs.html
/usr/share/doc/postgresql-9.6-plr/plr-overview.html
/usr/share/doc/postgresql-9.6-plr/plr-pgsql-support-funcs.html
/usr/share/doc/postgresql-9.6-plr/plr-spi-rsupport-funcs-compat.html
/usr/share/doc/postgresql-9.6-plr/plr-spi-rsupport-funcs-normal.html
/usr/share/doc/postgresql-9.6-plr/plr-spi-rsupport-funcs.html
/usr/share/doc/postgresql-9.6-plr/plr-trigger-func.html
/usr/share/doc/postgresql-9.6-plr/plr-window-funcs.html
/usr/share/doc/postgresql-doc-9.6/extension/README.plr
/usr/share/postgresql/9.6/extension/plr--8.3.0.17.sql
/usr/share/postgresql/9.6/extension/plr--unpackaged--8.3.0.17.sql
/usr/share/postgresql/9.6/extension/plr.control
/usr/share/postgresql/9.6/extension/plr.sql

Changelog

2016-11-16 - Christoph Berg <christoph.berg@credativ.de>
plr (1:8.3.0.17-1) unstable; urgency=medium
* Team upload.
* New upstream version.
* Compile docs at build time.
* Remove obsolete README.Debian file.
2016-09-26 - Christoph Berg <myon@debian.org>
plr (1:8.3.0.16-2) unstable; urgency=medium
* Upload with 9.6 support.
* Update watchfile URL.
2016-01-10 - Christoph Berg <myon@debian.org>
plr (1:8.3.0.16-1) unstable; urgency=medium
* New upstream version with 9.5 support.
* Don't remove docs on clean.
* Remove special handling for libR on lucid.
2014-09-05 - Christoph Berg <myon@debian.org>
plr (1:8.3.0.15-5) UNRELEASED; urgency=medium
* Work around missing /usr/lib/libR.so on lucid. Code was already
present in debian/postinst, but not installed into all binaries.
Patch by Robert Stone, thanks!
2014-07-25 - Christoph Berg <myon@debian.org>
plr (1:8.3.0.15-4) unstable; urgency=medium
* Upload to unstable for 9.4.
2014-07-05 - Christoph Berg <myon@debian.org>
plr (1:8.3.0.15-3) experimental; urgency=medium
* B-D on pg-common >= 158~ in experimental (9.3+9.4).
* Drop quilt B-D.
* Set team as maintainer.
2014-02-10 - Christoph Berg <christoph.berg@credativ.de>
plr (1:8.3.0.15-2) unstable; urgency=medium
[ Martin Pitt ]
* Add postgresql-server-dev-all and pkg-config test dependencies as the test
uses pg_buildext and pkg-config.
* debian/tests/installcheck: Temporarily modify test script to use CREATE
EXTENSION instead of sourcing the build tree's plr.psql. We want to test
the installed package and avoid building.
[ Christoph Berg ]
* Add expected/plr_1.out to catch the 8.4 test results.
2013-08-16 - Christoph Berg <myon@debian.org>
plr (1:8.3.0.15-1) unstable; urgency=low
* New upstream version.
* Use "8.4+" in debian/pgversions and B-D on postgresql-server-dev-all
>= 148.  Closes: #725572.
2013-03-31 - Christoph Berg <myon@debian.org>
plr (1:8.3.0.14-1) experimental; urgency=low
* New upstream version.
2013-01-31 - Christoph Berg <myon@debian.org>
plr (1:8.3.0.13.1-1) experimental; urgency=low
[ Andreas Tille ]
* debian/control[.in]
- Fixed Vcs fields
- Standards-Version: 3.9.3 (no changes needed)
[ Christoph Berg ]
* New upstream version.
* Add autopkgtest regression test. (Expected failure on 8.4.)
* debian/pgversions: Add 9.2 and 9.3.
* debian/rules: Use system pg_buildext again (>= 140).

See Also

Package Description
postgresql-9.6-plsh_1.20140221-5_i386.deb PL/sh procedural language for PostgreSQL 9.6
postgresql-9.6-plv8_1.4.10.ds-1_i386.deb Procedural language interface between PostgreSQL and JavaScript
postgresql-9.6-postgis-2.3-scripts_2.3.3+dfsg-1_all.deb Geographic objects support for PostgreSQL 9.6 -- scripts
postgresql-9.6-postgis-2.3_2.3.3+dfsg-1_i386.deb Geographic objects support for PostgreSQL 9.6
postgresql-9.6-postgis-scripts_2.3.3+dfsg-1_all.deb transitional dummy package
postgresql-9.6-powa_3.1.0-1_i386.deb PostgreSQL Workload Analyzer -- PostgreSQL 9.6 extension
postgresql-9.6-prefix_1.2.5-1_i386.deb Prefix Range module for PostgreSQL
postgresql-9.6-preprepare_0.8-1_i386.deb pre prepare your PostgreSQL statements server side
postgresql-9.6-prioritize_1.0.4-1.3_i386.deb Get and set the nice priorities of PostgreSQL backends
postgresql-9.6-python-multicorn_1.3.3-2ubuntu2_i386.deb multicorn extension for Postgres 9.6 to write FDWs with python2
postgresql-9.6-python3-multicorn_1.3.3-2ubuntu2_i386.deb multicorn extension for Postgres 9.6 to write FDWs with python3
postgresql-9.6-repack_1.3.4-3_i386.deb reorganize tables in PostgreSQL databases with minimal locks
postgresql-9.6-repmgr_3.3.1-1_i386.deb replication manager for PostgreSQL 9.6
postgresql-9.6-slony1-2_2.2.5-2_i386.deb replication system for PostgreSQL: PostgreSQL 9.6 server plug-in
postgresql-9.6-unit_4.0_i386.deb SI Units for PostgreSQL
Advertisement
Advertisement