policycoreutils-dev_2.7-2_i386.deb


Advertisement

Description

policycoreutils-dev - SELinux core policy utilities (development utilities)

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name policycoreutils-dev
Package version 2.7
Package release 2
Package architecture i386
Package type deb
Installed size 339 B
Download size 99.16 KB
Official Mirror archive.ubuntu.com
Security-enhanced Linux is a patch of the Linux® kernel and a number
of utilities with enhanced security functionality designed to add
mandatory access controls to Linux.  The Security-enhanced Linux
kernel contains new architectural components originally developed to
improve the security of the Flask operating system. These
architectural components provide general support for the enforcement
of many kinds of mandatory access control policies, including those
based on the concepts of Type Enforcement®, Role-based Access Control,
and Multi-level Security.
This package contains the management tools used to develop policy in an
SELinux environment.

Alternatives

Package Version Architecture Repository
policycoreutils-dev_2.7-2_amd64.deb 2.7 amd64 Ubuntu Universe
policycoreutils-dev - - -

Requires

Name Value
libc6 >= 2.4
policycoreutils >= 2.7
python3-selinux >= 2.7
python3-sepolgen = 2.7-2
python3-sepolicy = 2.7-2
python3:any >= 3.3.2-2~
semodule-utils >= 2.7

Replaces

Name Value
policycoreutils << 2.4

Download

Type URL
Binary Package policycoreutils-dev_2.7-2_i386.deb
Source Package selinux-python

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install policycoreutils-dev deb package:
    # sudo apt-get install policycoreutils-dev

Files

Path
/usr/bin/sepolgen
/usr/bin/sepolgen-ifgen
/usr/bin/sepolgen-ifgen-attr-helper
/usr/bin/sepolicy
/usr/lib/python3/dist-packages/sepolicy/generate.py
/usr/share/bash-completion/completions/sepolicy
/usr/share/doc/policycoreutils-dev/NEWS.Debian.gz
/usr/share/doc/policycoreutils-dev/changelog.Debian.gz
/usr/share/doc/policycoreutils-dev/copyright
/usr/share/man/man8/sepolgen.8.gz
/usr/share/man/man8/sepolicy-booleans.8.gz
/usr/share/man/man8/sepolicy-communicate.8.gz
/usr/share/man/man8/sepolicy-generate.8.gz
/usr/share/man/man8/sepolicy-interface.8.gz
/usr/share/man/man8/sepolicy-manpage.8.gz
/usr/share/man/man8/sepolicy-network.8.gz
/usr/share/man/man8/sepolicy-transition.8.gz
/usr/share/man/man8/sepolicy.8.gz

Changelog

2017-09-10 - Laurent Bigonville <bigon@debian.org>
selinux-python (2.7-2) unstable; urgency=medium
* debian/control: Bump {build-}dependencies to match the new release
* debian/rules:
- Drop LSPP_PRIV export, this was needed for the newrole exec
- Drop unused/commented exports
- Do not append CPPFLAGS to CFLAGS, the build system is honoring the
CPPFLAGS after all
* Revive and refresh debian/patches/0023-sepolicy-help-path.patch
* debian/copyright: Update the copyright file
* Bump Standards-Version to 4.1.0 (no further changes)
* Bump debhelper compatibility to 10
2017-08-21 - Laurent Bigonville <bigon@debian.org>
selinux-python (2.7-1) experimental; urgency=medium
* New upstream release
- Drop all the patches, they are either merged upstream or not releavant
anymore since policycoreutils has been split in smaller components
- Drop all references to the packages that are not anymore built by this
source packages, this package builds the python, sandbox and gui related
packages. python3-sepolgen is now part of this source package.
- debian/control: Bump {build-}dependencies to match the new release
* debian/watch: Add support for rc releases and use macros
* debian/patches/python3-shebang.patch: Invoke segenxml.py with python3
* debian/control: Bump Standards-Version to 4.0.0 (no further changes)
* debian/control: Remove Manoj from the uploader list and add myself
instead. Thanks to him for all the work in the past.
* debian/control: Make policycoreutils-python-utils arch:all
2017-01-10 - Laurent Bigonville <bigon@debian.org>
policycoreutils (2.6-3) unstable; urgency=medium
* Team upload.
* d/p/Handle-python-error-returns-correctly.patch: Fix a bug that was
preventing to override file contexts already defined in the policy
2016-11-28 - Laurent Bigonville <bigon@debian.org>
policycoreutils (2.6-2) unstable; urgency=medium
* Team upload.
* Upload to unstable
2016-11-23 - Laurent Bigonville <bigon@debian.org>
policycoreutils (2.6-1) experimental; urgency=medium
* Team upload.
* New upstream release
- Drop d/p/Dont_use_subprocess_getstatusoutput_in_Python_2_code.patch,
d/p/sandbox-dbus-run-session.patch, d/p/CVE-2016-7545.patch,
d/p/sandbox-gobject-gtk.patch, applied upstream
- Refreshed the other patches
- debian/control: Bump {build-}dependencies to match the new release
- debian/control: Drop libapol-dev and libqpol-dev build-dependencies
- debian/python-sepolicy.install: Drop .so file, this is now a pure python
module.
- Install new restorecon_xattr executable and manpage
* debian/control: Drop libcgroup-dev build-dependency, no longer used
* debian/gbp.conf: Rename git-buildpackage section to buildpackage
* Switch to python3, disable system-config-selinux for now as it doesn't
support that version.
* d/p/policycoreutils-Use-new-sepolicy-icon-in-.desktop-fi.patch: Use new
icon for sepolicy (From upstream)
* d/p/Sandbox-Use-next-over-the-sepolicy.info-result.patch,
d/p/policycoreutils-Make-sepolicy-work-with-python3.patch,
d/p/policycoreutils-Use-GObject-introspection-binding-in.patch Add some
fixes for python3 (From upstream)
* debian/control: Add lsb-base dependency to please lintian

See Also

Package Description
policycoreutils-gui_2.7-2_all.deb SELinux core policy utilities (graphical utilities)
policycoreutils-python-utils_2.7-2_all.deb SELinux core policy utilities (Python utilities)
policycoreutils-sandbox_2.7-2_i386.deb SELinux core policy utilities (graphical sandboxes)
policycoreutils_2.7-1_i386.deb SELinux core policy utilities
policyd-rate-limit_0.7.1-1_all.deb postfix policy daemon limiting the number of mails a user can send
policyd-weight_0.1.15.2-12_all.deb Perl policy daemon for the Postfix MTA
polipo_1.1.1-7_i386.deb lightweight, caching web proxy
polkit-kde-1_5.10.5-0ubuntu1_all.deb transitional dummy package
polkit-kde-agent-1_5.10.5-0ubuntu1_i386.deb KDE dialogs for PolicyKit
polled-camera-tool_1.11.11-2_i386.deb Robot OS polled_camera package tool
pollen_4.21-0ubuntu1_i386.deb Entropy-as-a-Service web server
polygen-data_1.0.6.ds2-16_all.deb grammar definitions for PolyGen
polygen_1.0.6.ds2-16_all.deb generator of random sentences from grammar definitions
polyglot_2.0.4-1_i386.deb chess engine protocol adaptor, connects UCI engines to xboard
polygraph_4.3.2-5_i386.deb performance testing tool for caching proxies and more
Advertisement
Advertisement