pngcrush_1.7.85-1build1_i386.deb


Advertisement

Description

pngcrush - optimizes PNG (Portable Network Graphics) files

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name pngcrush
Package version 1.7.85
Package release 1build1
Package architecture i386
Package type deb
Installed size 117 B
Download size 45.48 KB
Official Mirror archive.ubuntu.com
Pngcrush is an optimizer for PNG (Portable Network Graphics) files.
Its main purpose is to reduce the size of the PNG IDAT data stream by trying
various compression levels and PNG filter methods. It also can be used to
remove unwanted ancillary chunks, or to add certain chunks including gAMA,
tRNS, and textual chunks.

Alternatives

Package Version Architecture Repository
pngcrush_1.7.85-1build1_amd64.deb 1.7.85 amd64 Ubuntu Universe
pngcrush - - -

Requires

Name Value
libc6 >= 2.11
libpng16-16 >= 1.6.2-1
zlib1g >= 1:1.1.4

Download

Type URL
Binary Package pngcrush_1.7.85-1build1_i386.deb
Source Package pngcrush

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pngcrush deb package:
    # sudo apt-get install pngcrush

Files

Path
/usr/bin/pngcrush
/usr/share/doc/pngcrush/README.Debian
/usr/share/doc/pngcrush/changelog.Debian.gz
/usr/share/doc/pngcrush/copyright
/usr/share/man/man1/pngcrush.1.gz

Changelog

2016-04-23 - Matthias Klose <doko@ubuntu.com>
pngcrush (1.7.85-1build1) yakkety; urgency=medium
* No-change rebuild for libpng soname change.
2015-06-04 - Margarita Manterola <marga@debian.org>
pngcrush (1.7.85-1) unstable; urgency=medium
* New upstream release.
- Reworded confusing output words (Closes: #411032)
- Removed --bit_depth options (Closes: #546267)
- Fixes color changing bug with small palletes (Closes: #787744)
- Fixes crash related to argv checks (Closes: #716149)
* New maintainer.
- Remove kapil@ from Uploaders (Closes: #738478).
* Updated packaging location to git instead of svn.
* Fixed watch file.
* Updated standards version.
2013-07-01 - Zack Weinberg <zackw@panix.com>
pngcrush (1.7.65-0.1) unstable; urgency=low
* NMU to fix the more serious problems with this dormant package.
* New upstream release (Closes: #657855, #612934).
- Should now build with libpng 1.5 (Closes: #648128).
- No longer crashes when adding more than two text chunks (Closes: #678436).
- Upstream has switched to .xz tarballs, follow suit.
- patches/*: Normalize file names.
- patches/local_Makefile_adjustments.diff: Refresh.
Use -Wl,--as-needed to pull in -lm only if actually required.
Do not attempt to override configuration macros defined by the
system pngconf.h.
- patches/local_version_skew_warning_only_if_verbose.diff: Refresh.
* Build-depend on libpng-dev (Closes: #662471).
* Bump to debhelper compatibility level 9 and dh-ify.
* Install upstream changelog.
* Standards-Version: 3.9.4 (no further changes required).
2010-03-12 - Nelson A. de Oliveira <naoliv@debian.org>
pngcrush (1.7.9-1) unstable; urgency=low
* New upstream release (1.7.9-nolib);
- Fix crash if argument of -m is out of range (Closes: #561492).
* Updated Standards-Version to 3.8.4 (no changes needed);
* Convert package to the new format 3.0 (quilt);
- Remove now unneeded debian/README.source.
* Updated patches to conform to DEP-3.
2009-08-18 - Nelson A. de Oliveira <naoliv@debian.org>
pngcrush (1.7.0-1) unstable; urgency=low
* New upstream release (1.7.0-nolib);
* Add README.source;
* Updated Standards-Version to 3.8.3 (no changes needed);
* Refreshed debian/patches/pngcrush_relocate_warning;
2009-06-09 - Nelson A. de Oliveira <naoliv@debian.org>
pngcrush (1.6.19-1) unstable; urgency=low
* New upstream release (1.6.19-nolib)
- Fix erroneous png_error message about "original PNG could not be
recovered" (Closes: #532281)
* Upstream changelog is now distributed as an HTML file:
- Updated debian/rules to install ChangeLog.html
* Refreshed debian/patches/pngcrush_relocate_warning.
2009-06-03 - Kapil Hari Paranjape <kapil@debian.org>
pngcrush (1.6.17-1) unstable; urgency=low
* New upstream release (1.6.17-nolib).
- debian/patches/add_Makefile: renamed to patch_Makefile
since upstream now provides a makefile. Patch refreshed
and comments added.
- debian/patches/pngcrush_relocate_warning: patch refreshed and
comments added.
- create output with new timestamp by default instead of copying
the input file timestamp; (viz. #510491).
- see upstream Changelog for more details.
* debian/copyright: Updated to reflect new dates for new sources.
* debian/control: Standards Version bumped to 3.8.1. No other
changes required.
* debian/pngcrush.sgml: document the new options "-newtimestamp"
and "-oldtimestamp" which supersede the old option "-time_stamp".
* Remove misleading reference to CVE-2009-0040 in previous changelog
entry.
2009-03-03 - Kapil Hari Paranjape <kapil@debian.org>
pngcrush (1.6.15-1) unstable; urgency=low
* New upstream release (1.6.15-nolib).
* Fix previous changelog entry to note change
to debian/pngcrush.sgml
* debian/patches/pngcrush_relocate_warning: refreshed.

See Also

Package Description
pngmeta_1.11-7.1build1_i386.deb Display metadata information from PNG images
pngnq_1.0-2.3_i386.deb tool for optimizing PNG (Portable Network Graphics) images
pngphoon_1.2-1build1_i386.deb Creates a png file with the current phase of the moon
pngquant_2.5.0-2_i386.deb PNG (Portable Network Graphics) image optimising utility
pngtools_0.4-1.3_i386.deb series of tools for PNG (Portable Network Graphics) images
pnmixer_0.7-1_i386.deb Simple mixer application for system tray
pnopaste-cli_1.6-2_all.deb Pastebin with syntax highlighting (cli tool)
pnopaste_1.6-2_all.deb Pastebin with syntax highlighting
pnscan_1.12-1_i386.deb Multi threaded port scanner
po4a_0.52-1_all.deb tools to ease the translation of documentation
poa_2.0+20060928-6_i386.deb Partial Order Alignment for multiple sequence alignment
poc-streamer_0.4.2-3.1ubuntu1_i386.deb MP3/Ogg multicast/HTTP streamer and MP3 cutting tool
pocillo-icon-theme_0.8.3_all.deb Tango-esque folder icon set called Pocillo
pocketsphinx-doc_0.8.0+real5prealpha-1ubuntu2_all.deb Speech recognition tool (documentation)
pocketsphinx-en-us_0.8.0+real5prealpha-1ubuntu2_all.deb Speech recognition tool - US English language model
Advertisement
Advertisement