pluma_1.18.2-1_i386.deb


Advertisement

Description

pluma - official text editor of the MATE desktop environment

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name pluma
Package version 1.18.2
Package release 1
Package architecture i386
Package type deb
Installed size 1.67 KB
Download size 426.96 KB
Official Mirror archive.ubuntu.com
Pluma is a text editor which supports most standard editor features,
extending this basic functionality with other features not usually
found in simple text editors. Pluma is a graphical application which
supports editing multiple text files in one window (known sometimes as
tabs or MDI).
Pluma fully supports international text through its use of the
Unicode UTF-8 encoding in edited files. Its core feature set includes syntax
highlighting of source code, auto indentation and printing and print preview
support.
Pluma is also extensible through its plugin system, which currently
includes support for spell checking, comparing files, viewing CVS
ChangeLogs, and adjusting indentation levels.

Alternatives

Package Version Architecture Repository
pluma_1.18.2-1_amd64.deb 1.18.2 amd64 Ubuntu Universe
pluma - - -

Requires

Name Value
iso-codes -
libatk1.0-0 >= 1.12.4
libc6 >= 2.4
libcairo2 >= 1.2.4
libenchant1c2a >= 1.6.0
libgdk-pixbuf2.0-0 >= 2.22.0
libgirepository-1.0-1 >= 0.9.3
libglib2.0-0 >= 2.37.3
libgtk-3-0 >= 3.19.12
libgtksourceview-3.0-1 >= 2.91.4
libice6 >= 1:1.0.0
libpango-1.0-0 >= 1.14.0
libpeas-1.0-0 >= 1.0.0
libsm6 -
libx11-6 -
libxml2 >= 2.7.4
mate-desktop-common -
pluma-common = 1.18.2-1

Provides

Name Value
mate-text-editor -

Replaces

Name Value
mate-text-editor << 1.5.0

Download

Type URL
Binary Package pluma_1.18.2-1_i386.deb
Source Package pluma

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pluma deb package:
    # sudo apt-get install pluma

Files

Path
/usr/bin/pluma
/usr/lib/i386-linux-gnu/pluma/plugins/changecase.plugin
/usr/lib/i386-linux-gnu/pluma/plugins/docinfo.plugin
/usr/lib/i386-linux-gnu/pluma/plugins/externaltools.plugin
/usr/lib/i386-linux-gnu/pluma/plugins/filebrowser.plugin
/usr/lib/i386-linux-gnu/pluma/plugins/libchangecase.so
/usr/lib/i386-linux-gnu/pluma/plugins/libdocinfo.so
/usr/lib/i386-linux-gnu/pluma/plugins/libfilebrowser.so
/usr/lib/i386-linux-gnu/pluma/plugins/libmodelines.so
/usr/lib/i386-linux-gnu/pluma/plugins/libsort.so
/usr/lib/i386-linux-gnu/pluma/plugins/libspell.so
/usr/lib/i386-linux-gnu/pluma/plugins/libtaglist.so
/usr/lib/i386-linux-gnu/pluma/plugins/libtime.so
/usr/lib/i386-linux-gnu/pluma/plugins/libtrailsave.so
/usr/lib/i386-linux-gnu/pluma/plugins/modelines.plugin
/usr/lib/i386-linux-gnu/pluma/plugins/pythonconsole.plugin
/usr/lib/i386-linux-gnu/pluma/plugins/quickopen.plugin
/usr/lib/i386-linux-gnu/pluma/plugins/snippets.plugin
/usr/lib/i386-linux-gnu/pluma/plugins/sort.plugin
/usr/lib/i386-linux-gnu/pluma/plugins/spell.plugin
/usr/lib/i386-linux-gnu/pluma/plugins/taglist.plugin
/usr/lib/i386-linux-gnu/pluma/plugins/time.plugin
/usr/lib/i386-linux-gnu/pluma/plugins/trailsave.plugin
/usr/lib/i386-linux-gnu/pluma/plugins/externaltools/__init__.py
/usr/lib/i386-linux-gnu/pluma/plugins/externaltools/capture.py
/usr/lib/i386-linux-gnu/pluma/plugins/externaltools/filelookup.py
/usr/lib/i386-linux-gnu/pluma/plugins/externaltools/functions.py
/usr/lib/i386-linux-gnu/pluma/plugins/externaltools/library.py
/usr/lib/i386-linux-gnu/pluma/plugins/externaltools/linkparsing.py
/usr/lib/i386-linux-gnu/pluma/plugins/externaltools/manager.py
/usr/lib/i386-linux-gnu/pluma/plugins/externaltools/outputpanel.py
/usr/lib/i386-linux-gnu/pluma/plugins/pythonconsole/__init__.py
/usr/lib/i386-linux-gnu/pluma/plugins/pythonconsole/config.py
/usr/lib/i386-linux-gnu/pluma/plugins/pythonconsole/console.py
/usr/lib/i386-linux-gnu/pluma/plugins/quickopen/__init__.py
/usr/lib/i386-linux-gnu/pluma/plugins/quickopen/popup.py
/usr/lib/i386-linux-gnu/pluma/plugins/quickopen/virtualdirs.py
/usr/lib/i386-linux-gnu/pluma/plugins/quickopen/windowhelper.py
/usr/lib/i386-linux-gnu/pluma/plugins/snippets/Completion.py
/usr/lib/i386-linux-gnu/pluma/plugins/snippets/Document.py
/usr/lib/i386-linux-gnu/pluma/plugins/snippets/Exporter.py
/usr/lib/i386-linux-gnu/pluma/plugins/snippets/Helper.py
/usr/lib/i386-linux-gnu/pluma/plugins/snippets/Importer.py
/usr/lib/i386-linux-gnu/pluma/plugins/snippets/LanguageManager.py
/usr/lib/i386-linux-gnu/pluma/plugins/snippets/Library.py
/usr/lib/i386-linux-gnu/pluma/plugins/snippets/Manager.py
/usr/lib/i386-linux-gnu/pluma/plugins/snippets/Parser.py
/usr/lib/i386-linux-gnu/pluma/plugins/snippets/Placeholder.py
/usr/lib/i386-linux-gnu/pluma/plugins/snippets/Snippet.py
/usr/lib/i386-linux-gnu/pluma/plugins/snippets/SubstitutionParser.py
/usr/lib/i386-linux-gnu/pluma/plugins/snippets/WindowHelper.py
/usr/lib/i386-linux-gnu/pluma/plugins/snippets/__init__.py
/usr/lib/pluma/pluma-bugreport.sh
/usr/share/applications/pluma.desktop
/usr/share/doc/pluma/changelog.Debian.gz
/usr/share/doc/pluma/copyright
/usr/share/man/man1/pluma.1.gz

Changelog

2017-07-25 - Mike Gabriel <sunweaver@debian.org>
pluma (1.18.2-1) unstable; urgency=medium
[ Aron Xu ]
* New upstream release.
[ Martin Wimpress ]
* debian/control: Dependencies updated for MATE 1.17.
* debian/rules: Remove obsolete --with-gtk=3.0
* debian/pluma.install: Remove obsolete usr/lib/*/pluma/plugin-loaders/*.so
* debian/gir1.2-pluma.install: Add GObject introspection data for Pluma.
* debian/patches: Drop 2000_disable_python_plugins.patch.
Upstream migrated to libpeas.
* debian/copyright: Update copyright attributions.
* debian/control: Dependencies updated for MATE 1.18.
[ Vangelis Mouhtsis ]
* debian/compat:
+ Update compat version.
* debian/control:
+ Bump debhelper version to (>= 10.3~).
* debian/control:
+ Bump Standards-Version: to 4.0.0. No changes needed.
* debian/rules:
+ Add new block for override_dh_missing.
* debian/rules:
+ Disable autoreconf, handled by autogen.sh.
[ Mike Gabriel ]
* debian/rules:
+ Remove Python byte-code before installing files into the pluma
bin:package.
* debian/{control,gir1.2-pluma-1.0.install}:
+ Rename GIR package to a name that matches its TypeLib file name.
* debian/control:
+ Add D (pluma-dev): gir1.2-pluma-1.0 (same binary version as
pluma-dev).
+ GIR packages are in section 'introspection'.
+ The corresponding dev:package must be in section libdevel (i.e.
pluma-dev).
+ Add B:/R: to gir-1.2-pluma-1.0 for pluma-dev (<< 1.18.2-1~).
* debian/{pluma-dev,gir1.2-pluma-1.0}.install:
+ Move /usr/share/gir-1.0/ into pluma-dev.
2017-04-26 - Mike Gabriel <sunweaver@debian.org>
pluma (1.16.1-1) unstable; urgency=medium
* New upstream release.
* lintian:
+ Comment out privacy-breach-generic for snippets's mallard.xml. It will
be needed again with pluma 1.18.
2016-10-03 - Mike Gabriel <sunweaver@debian.org>
pluma (1.16.0-1) unstable; urgency=medium
[ Martin Wimpress ]
* New upstream release.
* debian/copyright:
+ Update copyright attributions.
[ Vangelis Mouhtsis ]
* debian/changelog:
+ Fix missing changelog items for 1.15.2-0ubuntu1 upload.
* debian/control:
+ Dependencies updated for MATE 1.16.
* debian/watch:
+ Update version matching again to _not_ support development releases.
2016-09-09 - Martin Wimpress <code@flexion.org>
pluma (1.15.2-0ubuntu1) yakkety; urgency=medium
* New upstream development release.
* debian/control:
+ Dependencies updated for MATE 1.15.
* debian/patches:
+ Rebase 2000_disable_python_plugins.patch.
* debian/watch:
+ Update version matching to support development releases.
2016-08-22 - Mike Gabriel <sunweaver@debian.org>
pluma (1.14.1-1) unstable; urgency=medium
[ Martin Wimpress ]
* New upstream release.
* debian/patches:
+ Refactor 2000_disable_python_plugins.patch.
[ Vangelis Mouhtsis ]
* debian/{control,rules}:
+ dbgsym: Don't build dbg:packages anymore.
See https://wiki.debian.org/AutomaticDebugPackages
2016-05-25 - Mike Gabriel <sunweaver@debian.org>
pluma (1.14.0-1) unstable; urgency=medium
[ Martin Wimpress ]
* New upstream release.
* debian/control:
+ B-D: libgtk-3-dev
+ B-D: libgtksourceview-3.0-dev 
+ Versioned B-D: libmate-desktop-dev (>= 1.14)
+ Versioned B-D: mate-common (>= 1.14)
+ Drop all Python support, including deprecated
dependency on python-gtksourceview2. (Closes: #822591).
* debian/rules:
+ Drop --with python2.
+ MateConf dropped upstream.
+ Drop all Python support.
+ Add --with-gtk=3.0
* debian/patches:
+ Drop 0000_prevent_shell_code_injection.patch. Applied upstream.
+ Add 2000_disable_python_plugins.patch.
* debian/copyright:
+ Update copyright attributions.
[ Mike Gabriel ]
* debian/control:
+ Bump Standards: to 3.9.8. No changes needed.

See Also

Package Description
plume-creator_0.66+dfsg1-3.1build2_i386.deb open-source tool for novelists
pluxml_5.5-2_all.deb light blog/CMS engine powered by XML
plymouth-disabler_0.1_all.deb disable plymouth by installing .override files
plymouth-theme-breeze_5.10.5-0ubuntu1_i386.deb Breeze theme for Plymouth
plymouth-theme-edubuntu_15.12.1_all.deb Plymouth is an application that runs very early
plymouth-theme-hamara_1.0_all.deb boot animation, logger and I/O multiplexer - Hamara theme
plymouth-theme-kubuntu-logo_17.10ubuntu3_all.deb graphical boot animation and logger - kubuntu-logo theme
plymouth-theme-kubuntu-text_17.10ubuntu3_all.deb graphical boot animation and logger - kubuntu-text theme
plymouth-theme-lubuntu-logo_0.69_all.deb plymouth theme for Lubuntu
plymouth-theme-lubuntu-text_0.69_all.deb plymouth text theme for Lubuntu
plymouth-theme-sabily-text_1.3_all.deb plymouth theme for Sabily (text theme)
plymouth-theme-sabily_1.3_all.deb plymouth theme for Sabily (graphical theme)
plymouth-theme-ubuntu-budgie-logo_0.8.3_all.deb graphical boot animation and logger - Ubuntu Budgie logo theme
plymouth-theme-ubuntu-budgie-text_0.8.3_all.deb graphical boot animation and logger - Ubuntu Budgie text theme
plymouth-theme-ubuntu-gnome-logo_17.10.3_all.deb graphical boot animation and logger - ubuntu-gnome-logo theme
Advertisement
Advertisement