pki-tools_10.3.5+12-4ubuntu1_i386.deb


Advertisement

Description

pki-tools - Certificate System - PKI Tools

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name pki-tools
Package version 10.3.5+12
Package release 4ubuntu1
Package architecture i386
Package type deb
Installed size 1022 B
Download size 576.71 KB
Official Mirror archive.ubuntu.com
This package contains PKI executables that can be used to help make
Certificate System into a more complete and robust PKI solution.
This package is a part of the PKI Core used by the Certificate System.

Alternatives

Package Version Architecture Repository
pki-tools_10.3.5+12-4ubuntu1_amd64.deb 10.3.5+12 amd64 Ubuntu Universe
pki-tools - - -

Requires

Name Value
ldap-utils -
libc6 >= 2.4
libjackson2-annotations-java -
libldap-2.4-2 >= 2.4.7
libnspr4 >= 2:4.10.9
libnss3 >= 2:3.13.4-2~
libnss3-tools -
pki-base = 10.3.5+12-4ubuntu1
python:any -

Conflicts

Name Value
strongswan-pki -
strongswan-starter -

Download

Type URL
Binary Package pki-tools_10.3.5+12-4ubuntu1_i386.deb
Source Package dogtag-pki

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pki-tools deb package:
    # sudo apt-get install pki-tools

Files

Path
/usr/bin/AtoB
/usr/bin/AuditVerify
/usr/bin/BtoA
/usr/bin/CMCEnroll
/usr/bin/CMCRequest
/usr/bin/CMCResponse
/usr/bin/CMCRevoke
/usr/bin/CRMFPopClient
/usr/bin/DRMTool
/usr/bin/ExtJoiner
/usr/bin/GenExtKeyUsage
/usr/bin/GenIssuerAltNameExt
/usr/bin/GenSubjectAltNameExt
/usr/bin/HttpClient
/usr/bin/KRATool
/usr/bin/OCSPClient
/usr/bin/PKCS10Client
/usr/bin/PKCS12Export
/usr/bin/PrettyPrintCert
/usr/bin/PrettyPrintCrl
/usr/bin/TokenInfo
/usr/bin/p7tool
/usr/bin/pki
/usr/bin/revoker
/usr/bin/setpin
/usr/bin/sslget
/usr/bin/tkstool
/usr/share/doc/pki-tools/README
/usr/share/doc/pki-tools/changelog.Debian.gz
/usr/share/doc/pki-tools/copyright
/usr/share/java/pki/pki-tools.jar
/usr/share/lintian/overrides/pki-tools
/usr/share/man/man1/AtoB.1.gz
/usr/share/man/man1/AuditVerify.1.gz
/usr/share/man/man1/BtoA.1.gz
/usr/share/man/man1/CMCEnroll.1.gz
/usr/share/man/man1/DRMTool.1.gz
/usr/share/man/man1/KRATool.1.gz
/usr/share/man/man1/PrettyPrintCert.1.gz
/usr/share/man/man1/PrettyPrintCrl.1.gz
/usr/share/man/man1/pki-audit.1.gz
/usr/share/man/man1/pki-ca-kraconnector.1.gz
/usr/share/man/man1/pki-ca-profile.1.gz
/usr/share/man/man1/pki-cert.1.gz
/usr/share/man/man1/pki-client.1.gz
/usr/share/man/man1/pki-group-member.1.gz
/usr/share/man/man1/pki-group.1.gz
/usr/share/man/man1/pki-key.1.gz
/usr/share/man/man1/pki-pkcs12-cert.1.gz
/usr/share/man/man1/pki-pkcs12-key.1.gz
/usr/share/man/man1/pki-pkcs12.1.gz
/usr/share/man/man1/pki-securitydomain.1.gz
/usr/share/man/man1/pki-tps-profile.1.gz
/usr/share/man/man1/pki-user-cert.1.gz
/usr/share/man/man1/pki-user-membership.1.gz
/usr/share/man/man1/pki-user.1.gz
/usr/share/man/man1/pki.1.gz
/usr/share/pki/java-tools/DRMTool.cfg
/usr/share/pki/java-tools/KRATool.cfg
/usr/share/pki/native-tools/setpin.conf

Changelog

2017-09-21 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.3.5+12-4ubuntu1) artful; urgency=medium
* rules: Add a link to jboss-logging.jar.
* control: Use tomcat8.0.
* control: Add libcommons-httpclient-java to build-depends, and
pki-base-java depends.
2017-05-18 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.3.5+12-4) unstable; urgency=medium
* pki-tomcatd.init: If no instance is configured, the initscript
machinery would return error value 5 or 6. This messes up systemd, so
just use 'exit 1' on every non-zero return value. (LP: #1664453)
* pki-server.postinst: Clarify pki-tomcatd initial start failure
message a bit.
* Depend libresteasy-java << 3.1.0, because the new on doesn't work
even after fixing the build.
* pki-tools.links: Fix the convenience links DRMTool -> KRATool.
(Closes: #857209)
* pki-base.postinst: Force recreating pki.version if upgrading from
older than 10.3.5-1. (LP: #1691655)
2017-02-16 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.3.5+12-3) unstable; urgency=medium
* server.postrm: Remove /etc/default/pki-tomcat on purge.
* create-target-wants.diff: Create target.wants-directories in the
python deployment scriptlet too.
2017-02-15 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.3.5+12-2) unstable; urgency=medium
* base, server, tools: Add new manpages.
* use-resteasy-legacy.diff: Fix javadoc build.
2017-02-15 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.3.5+12-1) unstable; urgency=medium
* New upstream snapshot. Version number is derived from the Fedora
release, 10.3.5+12 maps to pki-core 10.3.5-12 on Fedora.
* sync-rpm-10.3.5-7.diff: Dropped.
* use-resteasy-legacy.diff, control: Port to resteasy 3.1.0-2 which
ships resteasy-legacy.jar. (LP: #1664457)
2017-01-18 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.3.5-7) unstable; urgency=medium
* debian-support: Fix an upgrade script to use /etc/default instead of
/etc/sysconfig.
* debian-support: Fix nuxwdog to use /etc/default in each case.
* create-target-wants.diff: Create the systemd target.wants
directories on demand.
* pki-server.dirs: Drop target.wants-directories, they'd just get
deleted by systemd helpers and are now created on demand anyway.
2016-12-01 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.3.5-6) unstable; urgency=medium
* sync-rpm-10.3.5-7.diff: Pull changes from upstream branch needed by
newer freeipa.
* tools.install: Add CMCEnroll manpage.
2016-10-27 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.3.5-5) unstable; urgency=medium
* server: Add /etc/dogtag to dirs, clean up stuff created by pkispawn
on purge.
* control: Add libscannotation-java to server depends.
* use-bash.diff: Revert some of 4708983b8 to use bash instead of sh in
some places where checkbashisms reported warnings.
* fix-cve-2016-1240.diff: Fix CVE-2016-1240 in scripts/operations
which has code copied from the tomcat initscript.
* pki-{ca,kra,ocsp,tks,tps}.postrm: Remove logfiles on purge.
2016-10-03 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.3.5-4) unstable; urgency=medium
* tests: Add simple autopkgtest that runs setup-ds and pkispawn.
* server.postinst: Tell pki-server migrate to migrate to tomcat8.
* debian-support.diff: Fix some jar symlinks, and drop extra / from
config dirs.
* control: Add libcommons-collections3-java, libcommons-dbcp-java,
libcommons-pool-java, libjboss-logging-java, libsymkey-java to pki-
server Depends.
2016-09-30 - Timo Aaltonen <tjaalton@debian.org>
dogtag-pki (10.3.5-3) unstable; urgency=medium
* rules: Fix path to tomcat8 catalina and util jars, add api and
util-scan jars.

See Also

Package Description
pki-tps-client_10.3.5+12-4ubuntu1_i386.deb Certificate System - Token Processing System client
pki-tps_10.3.5+12-4ubuntu1_all.deb Certificate System - Token Processing System
pkpgcounter_3.50-7.1_all.deb computes number of pages or quantity of ink needed to print documents
pktools-dev_2.6.7.1+ds-1build2_i386.deb GDAL add-on tools to perform useful raster processing - development files
pktools_2.6.7.1+ds-1build2_i386.deb GDAL add-on tools to perform useful raster processing
pktstat_1.8.5-5_i386.deb top-like utility for network connections usage
pkwalify_1.22.99~git3d3f0ea-1_all.deb perl kwalify validator
placnet_1.03-2_all.deb Plasmid Constellation Network project
plainbox-insecure-policy_0.25-1_all.deb policykit policy required to use plainbox (insecure version)
plainbox-provider-checkbox_0.25-2_i386.deb CheckBox provider for PlainBox
plainbox-provider-resource-generic_0.23-1.1_i386.deb CheckBox generic resource jobs provider
plainbox_0.25-1_all.deb toolkit for software and hardware integration testing
plait_1.6.2-1ubuntu1_all.deb command-line jukebox
plan_1.10.1-5_i386.deb X/Motif day planner
planarity_3.0.0.5-1_i386.deb Program for planarity-related graph algorithms
Advertisement
Advertisement