pinentry-tty_1.0.0-2_i386.deb


Advertisement

Description

pinentry-tty - minimal dumb-terminal PIN or pass-phrase entry for GnuPG

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name pinentry-tty
Package version 1.0.0
Package release 2
Package architecture i386
Package type deb
Installed size 76 B
Download size 29.02 KB
Official Mirror archive.ubuntu.com
This package contains a program that allows for secure entry of PINs or
pass phrases.  That means it tries to take care that the entered
information is not swapped to disk or temporarily stored anywhere.
This functionality is particularly useful for entering pass phrases
when using encryption software such as GnuPG or e-mail clients using
the same.  It uses an open protocol and is therefore not tied to
particular software.
The program contained in this package implements a PIN entry prompt
that interacts directly with the controlling terminal.  It has
minimal dependencies, meaning that it is useful for users working
with dumb terminals or similarly constrained environments.  There are
sibling packages that implement PIN entry dialogs that use curses for
friendlier text-mode inputs on non-dumb terminals, and other sibling
packages that provide PIN entry dialogs using an X tool kit.

Alternatives

Package Version Architecture Repository
pinentry-tty_1.0.0-2_amd64.deb 1.0.0 amd64 Ubuntu Universe
pinentry-tty - - -

Requires

Name Value
libassuan0 >= 2.0.1
libc6 >= 2.4
libgpg-error0 >= 1.14

Provides

Name Value
pinentry -

Download

Type URL
Binary Package pinentry-tty_1.0.0-2_i386.deb
Source Package pinentry

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pinentry-tty deb package:
    # sudo apt-get install pinentry-tty

Files

Path
/usr/bin/pinentry-tty
/usr/share/doc/pinentry-tty/AUTHORS
/usr/share/doc/pinentry-tty/NEWS.gz
/usr/share/doc/pinentry-tty/changelog.Debian.gz
/usr/share/doc/pinentry-tty/copyright
/usr/share/man/man1/pinentry-tty.1.gz

Changelog

2017-02-06 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
pinentry (1.0.0-2) unstable; urgency=medium
* fix documentation typos (Closes: #665879)
* pinentry-gnome3: Ask for new passwords twice (Closes: #851277)
* normalize window title behavior across graphical variants
* pinentry-gtk-2: busy-wait while pointer is already grabbed (Closes: #850708)
* pinentry-gtk-2: retry input grab based on real time delay (Closes: #851707)
2016-12-05 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
pinentry (1.0.0-1) unstable; urgency=medium
* New upstream release.
* removed most patches, already imported upstream.
2016-11-08 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
pinentry (0.9.7-9) unstable; urgency=medium
* more upstream patches (pinentry-gnome3 now falls back to curses when
screen is locked)
2016-11-05 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
pinentry (0.9.7-8) unstable; urgency=medium
* more patches from upstream
* reduce work for the buildds by avoiding some duplicated builds.
2016-11-04 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
pinentry (0.9.7-7) unstable; urgency=medium
* update debian/watch to use https
* cleanup patches from upstream
* pinentry-gnome3: improve fallback to curses (Closes: #841909)
2016-10-11 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
pinentry (0.9.7-6) unstable; urgency=medium
* included several patches from upstream
* bumped to debhelper 10
* p-gnome3 Recommends: dbus-user-session (addresses: #801247)
* added texinfo to build-dependencies for /usr/bin/makeinfo
* added bindnow hardening flag
* bumped standards-version to 3.9.8 (no changes needed)
2016-02-21 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
pinentry (0.9.7-5) unstable; urgency=medium
* use https for Vcs-* fields
* bump standards-version to 3.9.7
2016-02-20 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
pinentry (0.9.7-4) unstable; urgency=medium
* avoid pinentry failures when bound to libsecret and the secret service
is not running.  Thanks, Stef Walter.
2016-02-04 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
pinentry (0.9.7-3) unstable; urgency=medium
* build -tty, -curses, and -qt without libsecret (Closes: #787883)
2016-02-04 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
pinentry (0.9.7-2) unstable; urgency=medium
* avoid use-after-free in QT pw quality calculation (patch from upstream)

See Also

Package Description
pinentry-x2go_0.7.5.9-2_i386.deb OpenPGP (smart)card authentication dialog window for X2Go Client
pinfo_0.6.9-5.1build2_i386.deb An alternative info-file viewer
pingus-data_0.7.6-4_all.deb Data files for pingus, a free Lemmings(TM) clone
pingus_0.7.6-4_i386.deb Free Lemmings(TM) clone
pink-pony-data_1.4.1-2build1_all.deb 3D racing game with ponies - game data
pink-pony_1.4.1-2build1_i386.deb 3D racing game with ponies
pinot_1.05-1.2build3_i386.deb meta-search engine for local files and web queries
pinpoint_0.1.8-3_i386.deb hacker-friendly presentation program
pinta_1.6-2_all.deb Simple drawing/painting program
pinto_0.97+dfsg-4ubuntu1_all.deb application for curating a repository of Perl modules
pinyin-database_1.2.99-4_all.deb PinYin database used by ibus-pinyin
pioneers-console-data_15.4-1_all.deb Settlers of Catan board game - data files for console parts
pioneers-console_15.4-1_i386.deb Settlers of Catan board game - console parts
pioneers-data_15.4-1_all.deb Settlers of Catan board game - data files
pioneers-meta-server_15.4-1_all.deb Transitional dummy package to pioneers-metaserver
Advertisement
Advertisement