pianobooster_0.6.7~svn156-1_i386.deb


Advertisement

Description

pianobooster - learn the piano just by playing a game

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name pianobooster
Package version 0.6.7~svn156
Package release 1
Package architecture i386
Package type deb
Installed size 602 B
Download size 193.88 KB
Official Mirror archive.ubuntu.com
Piano Booster is a new way to learn the piano just by playing a game.
It takes elements of the game Guitar Hero but now it uses a real piano
keyboard and the game has been turned sideways so the notes scroll along
a musical stave. So instead of pressing buttons on a fake guitar you end
up learning to play a real musical instrument: the piano.
To run Piano Booster you need a MIDI Piano Keyboard and a MIDI interface
for the PC. If you don't have a MIDI keyboard you can still try out
PianoBooster, using the PC keyboard ('x' is middle C), but a MIDI piano
is really recommended).

Alternatives

Package Version Architecture Repository
pianobooster_0.6.7~svn156-1_amd64.deb 0.6.7~svn156 amd64 Ubuntu Universe
pianobooster - - -

Requires

Name Value
libasound2 >= 1.0.16
libc6 >= 2.4
libgcc1 >= 1:3.0
libgl1 -
libgl1-mesa-glx -
libqt4-opengl >= 4:4.5.3
libqt4-xml >= 4:4.5.3
libqtcore4 >= 4:4.7.0~beta1
libqtgui4 >= 4:4.5.3
libstdc++6 >= 5.2

Download

Type URL
Binary Package pianobooster_0.6.7~svn156-1_i386.deb
Source Package pianobooster

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install pianobooster deb package:
    # sudo apt-get install pianobooster

Files

Path
/usr/games/pianobooster
/usr/share/applications/pianobooster.desktop
/usr/share/doc/pianobooster/README.Debian.gz
/usr/share/doc/pianobooster/README.txt.gz
/usr/share/doc/pianobooster/changelog.Debian.gz
/usr/share/doc/pianobooster/copyright
/usr/share/games/pianobooster/translations/pianobooster_blank.qm
/usr/share/games/pianobooster/translations/pianobooster_es.qm
/usr/share/games/pianobooster/translations/pianobooster_gl.qm
/usr/share/games/pianobooster/translations/pianobooster_ja.qm
/usr/share/man/man6/pianobooster.6.gz
/usr/share/menu/pianobooster
/usr/share/pixmaps/pianobooster.png
/usr/share/pixmaps/pianobooster.xpm

Changelog

2016-11-17 - Miriam Ruiz <miriam@debian.org>
pianobooster (0.6.7~svn156-1) unstable; urgency=medium
[ Miriam Ruiz ]
* Adapted changes for Debian
* Refreshed patches
* Added typos.patch and i18n.patch
* Upgraded Standards-Version from 3.9.6 to 3.9.8
* Added Daniel Gimpelevich to Uploaders
2016-10-23 - Daniel Gimpelevich <daniel@gimpelevich.san-francisco.ca.us>
pianobooster (0.6.7~svn156-0ppa2~trusty) trusty; urgency=medium
* New Upstream Release.
* Dropped link-pthread-and-GL-explicitly.patch, merged upstream
* Dropped i18n.patch pending rebase
* Reflected upstream i18n in debian/rules and debian/pianobooster.install
* Rebased rtmidi-1.0.15.patch
* Updated manpage
* Added paths.patch and armel.patch
2015-11-27 - Miriam Ruiz <miriam@debian.org>
pianobooster (0.6.4.0-1) UNRELEASED; urgency=medium
* New Upstream Release.
* Added build dependency: qt4-linguist-tools
* Upgraded Standards-Version from 3.9.4 to 3.9.6
2013-07-02 - Markus Koschany <apo@gambaru.de>
pianobooster (0.6.4b-2) unstable; urgency=low
* Team upload.
* Bump Standards-Version to 3.9.4, no changes.
* Use canonical VCS-URI.
* Remove quilt from Build-Depends because source format 3.0 uses quilt by
default.
* Remove superfluous substvar ${shlibs:Depends} from performous-dbg.
* Add link-pthread-and-GL-explicitly.patch and fix FTBFS by linking the
missing libraries in CMakelist.txt explicitly. (Closes: #713691)
* Fix lintian error and do not set the library RPATH in debian/rules anymore.
Use the normal library search path instead.
* Update debian/copyright to copyright format 1.0. Fix spelling mistakes.
* pianobooster.desktop: Add keywords.
* Update debian/watch.
2012-12-04 - Miriam Ruiz <miriam@debian.org>
pianobooster (0.6.4b-1) unstable; urgency=low
[ Miriam Ruiz ]
* New upstream release
* Upgraded Standards-Version from 3.9.2 to 3.9.3
* Upgraded debian/compat to 9.
* Added patch: linker_opts.patch
* Modified debian/rules to use fortified libc functions.
See: http://wiki.debian.org/Hardening
* Changed my email address in debian/control to miriam@debian.org
[ Martin Erik Werner ]
* Use -DCMAKE_BUILD_TYPE=Debug to get a better debug package. Closes: #664473
[ Paul Wise ]
* Install a MIDI synthesizer and sounds by default. Closes: #650700
2012-05-23 - gregor herrmann <gregoa@debian.org>
pianobooster (0.6.4-3.1) unstable; urgency=low
* Non-maintainer upload.
* Fix "ftbfs with GCC-4.7": add patch to set linker flag -mwindows only on
Windows. (Closes: #667322)
2011-12-03 - Miriam Ruiz <little_miry@yahoo.es>
pianobooster (0.6.4-3) unstable; urgency=low
[ Miriam Ruiz ]
* Added Galician translation and improved Spanish. Thanks to Miguel Bouzada.
2011-11-30 - Miriam Ruiz <little_miry@yahoo.es>
pianobooster (0.6.4-2) unstable; urgency=low
[ Miriam Ruiz ]
* Added support for translations: i18n.patch
* Added Spanish translation
* Fixed desktop file
* Set the Games Team as Maintainer
2011-11-29 - Miriam Ruiz <little_miry@yahoo.es>
pianobooster (0.6.4-1) unstable; urgency=low
* Initial release. Closes: #650398

See Also

Package Description
picard-tools_2.8.1+dfsg-2_all.deb Command line tools to manipulate SAM and BAM files
picard_1.4.2-1_i386.deb Next-Generation MusicBrainz audio files tagger
pick_1.8.0-1_i386.deb utility to choose one option from a set of choices
picmi_17.04.3-0ubuntu1_i386.deb Number logic game
picocom_2.2-2_i386.deb minimal dumb-terminal emulation program
picolisp_17.6-1_i386.deb Lisp interpreter and application server framework
picosat_960-1_i386.deb SAT solver with proof and core support
picprog_1.9.1-3_i386.deb Microchip PIC serial programmer software
pictor-unload_2.38-0ubuntu1_all.deb tool for unloading and renaming pictures from flash media
pictor_2.38-0ubuntu1_all.deb web application for browsing your pictures
picviz_0.5-1ubuntu1_i386.deb Parallel coordinates plotter
pidcat_2.1.0-1_all.deb Colored adb logcat that shows entries for specific apps
pidentd_3.0.19.ds1-8_i386.deb TCP/IP IDENT protocol server with DES support
pidgin-audacious_2.0.0-5ubuntu2_i386.deb pidgin integration with Audacious
pidgin-awayonlock_0.5.2-1_i386.deb pidgin plugin to set as away on screensaver activation
Advertisement
Advertisement