php-pclzip_2.8.2-4_all.deb


Advertisement

Description

php-pclzip - ZIP archive manager class for PHP

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name php-pclzip
Package version 2.8.2
Package release 4
Package architecture all
Package type deb
Installed size 222 B
Download size 27.08 KB
Official Mirror archive.ubuntu.com
This library offers compression and extraction functions for ZIP
formatted archives (WinZip, PKZIP). It gives you the ability to
manipulate ZIP formatted archives. You can create, list and extract
the contents of any ZIP file.
PclZip defines an object oriented interface to ZIP archives through
a PHP class. This class manages the archive properties and offers
access method and actions on it.

Alternatives

Package Version Architecture Repository
php-pclzip_2.8.2-4_all.deb 2.8.2 all Ubuntu Universe
php-pclzip - - -

Requires

Name Value
php-common -

Download

Type URL
Binary Package php-pclzip_2.8.2-4_all.deb
Source Package php-pclzip

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php-pclzip deb package:
    # sudo apt-get install php-pclzip

Files

Path
/usr/share/doc/php-pclzip/changelog.Debian.gz
/usr/share/doc/php-pclzip/copyright
/usr/share/doc/php-pclzip/readme.txt.gz
/usr/share/lintian/overrides/php-pclzip
/usr/share/php/pclzip.lib.php

Changelog

2016-03-02 - David Prévot <taffit@debian.org>
php-pclzip (2.8.2-4) unstable; urgency=medium
* Drop now unused libphp-pclzip transitional package
* PHP 7.0 transition: depend on php-common instead of php5-common
* Update Standards-Version to 3.9.7
2014-01-21 - David Prévot <taffit@debian.org>
php-pclzip (2.8.2-3) unstable; urgency=medium
* Update Maintainer and Uploaders (Closes: #682305)
* Proofread Description
* Document Vcs
* Convert copyright to format 1.0
* Depend on php5-common instead of php5 | php5-cli
* Update Standards-Version to 3.9.5
* Rename package as php-pclzip
* Handle patch with gbp pq
* Use readme.txt as upstream changelog
2010-02-25 - Federico Gimenez Nieto <fgimenez@coit.es>
libphp-pclzip (2.8.2-2) unstable; urgency=low
* Fixed watch file
* Added 3.0 (quilt) source format
* debian/control:
- Bumped Standards-Version: 3.8.4
- Removed dpatch build dependency
- Added ${misc:Depends} to Depends
- Upgraded version of debhelper build dependency to 7.0.50
* debian/rules: modifications to use debhelper command sequencer
with overrides
* debian/compat: upgraded to 7
* Added debian/install file
* Removed debian/dirs file
2009-10-22 - Federico Gimenez Nieto <fgimenez@coit.es>
libphp-pclzip (2.8.2-1) unstable; urgency=low
* New upstream release
2009-08-27 - Federico Gimenez Nieto <fgimenez@coit.es>
libphp-pclzip (2.8.1-1) unstable; urgency=low
* New maintainer (Closes: #529666)
* New upstream release
* debian/watch: fixed path, upstream version mangling and regexp for links
* debian/control:
- moved Homepage from long description to its own field
- fixed section (web -> php)
- modified original package description (trying to make it more readable)
- removed dependencies: libapache-mod-php5 (obsolete package) and 
php5-cgi, libapache2-mod-php5 (already implied by the dependency on 
php5)
- Added dependency on dpatch (at Build-Depends)
- Updated standards version to 3.8.3
* debian/copyright: 
- removed reference to symlink license
- added copyright information about packagers
- fixed license number (2 -> 2.1)
* debian/rules: 
- moved commands for binary-arch to binary-indep
- removed targets: configure, configure-stamp, build-stamp, binary-arch
- removed unused calls for binary-indep target: dh_link, dh_strip, 
dh_shlibdeps, dh_installexamples
- added call to dh_install at install target (removed mv command)
and debian/libphp-pclzip.install file 
- modified mv command for installed doc, now copies the original doc 
file with the destination name, removed debian/docs file
- added patch (dpatch) for writing in $TMPDIR or (if not defined) in /tmp 
the temporary files used by the library instead of writing in the 
current directory (using template at /usr/share/dpatch/dpatch.make)
- moved all dh_install*foo calls to the install target
* Added debian/README.source refering to dpatch README (as for policy 4.14)
2007-11-01 - Jose Carlos Medeiros <debian@psabs.com.br>
libphp-pclzip (2.6-1) unstable; urgency=low
* New upstream release
* debian/watch updated.
2007-05-17 - Jose Carlos Medeiros <debian@psabs.com.br>
libphp-pclzip (2.5-2) unstable; urgency=low
* Bump Standards-Version: 3.7.2.
* Removed php4 references due to php4-removal.
2006-03-14 - Jose Carlos Medeiros <debian@psabs.com.br>
libphp-pclzip (2.5-1) unstable; urgency=low
* New upstream release
* Removed debian/compat file, created var DH_COMPAT in debian/rules.
* Updated to DH_COMPAT=5.
* Added denpendencies of php5.
2005-10-17 - Jose Carlos Medeiros <debian@psabs.com.br>
libphp-pclzip (2.4-1) unstable; urgency=low
* New upstream release.
* Changed package to Standards-Version: 3.6.2.
* Updated address of FSF in debian/copyright file.
2005-09-21 - Jose Carlos Medeiros <debian@psabs.com.br>
libphp-pclzip (2.3-1) unstable; urgency=low
* Initial Release. (closes: #329397)

See Also

Package Description
php-pecl-http-dev_3.1.0+2.6.0-4build2_all.deb pecl_http module for PHP Extended HTTP Support [dummy]
php-pecl-http_3.1.0+2.6.0-4build2_all.deb pecl_http module for PHP Extended HTTP Support [dummy]
php-php-gettext_1.0.12-0.1_all.deb read gettext MO files directly, without requiring anything other than PHP
php-phpdbg_7.1+54ubuntu1_all.deb server-side, HTML-embedded scripting language (PHPDBG binary) (default)
php-phpdocumentor-reflection-common_1.0-3_all.deb Common reflection classes - phpDocumentor component
php-phpdocumentor-reflection-docblock_2.0.4-2_all.deb DocBlock parser - phpDocumentor component
php-phpdocumentor-reflection_1.1.0-1_all.deb Reflection library to do Static Analysis for PHP Projects
php-phpdocumentor-type-resolver_0.2.1-1_all.deb TypeResolver and FqsenResolver - phpDocumentor component
php-phpseclib_2.0.6-1_all.deb implementations of an arbitrary-precision integer arithmetic library
php-phpspec-prophecy_1.7.0-1_all.deb object mocking framework - phpspec component
php-pimple_3.0.2-2ubuntu1_all.deb simple dependency injection container -- class
php-pinba_1.1.0-3build1_i386.deb Pinba module for PHP
php-propro-dev_2.0.1+1.0.2-1build1_all.deb propro module for PHP development headers [dummy]
php-propro_2.0.1+1.0.2-1build1_i386.deb propro module for PHP
php-proxy-manager_2.1.1-1_all.deb library providing utilities to operate with Object Proxies
Advertisement
Advertisement