php-mail_1.3.0-1_all.deb


Advertisement

Description

php-mail - Class that provides multiple interfaces for sending emails

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name php-mail
Package version 1.3.0
Package release 1
Package architecture all
Package type deb
Installed size 125 B
Download size 23.73 KB
Official Mirror archive.ubuntu.com
PEAR's Mail package defines an interface for implementing mailers under the
PEAR hierarchy. It also provides supporting functions useful to multiple
mailer backends. Currently supported backends include: PHP's native mail()
function, sendmail, and SMTP. This package also provides a RFC822 email
address list validation utility class.

Alternatives

Package Version Architecture Repository
php-mail_1.3.0-1_all.deb 1.3.0 all Ubuntu Universe
php-mail - - -

Requires

Name Value
php-common -

Download

Type URL
Binary Package php-mail_1.3.0-1_all.deb
Source Package php-mail

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php-mail deb package:
    # sudo apt-get install php-mail

Files

Path
/usr/share/doc/php-mail/changelog.Debian.gz
/usr/share/doc/php-mail/copyright
/usr/share/doc/php-mail/package.xml.gz
/usr/share/php/Mail.php
/usr/share/php/.registry/mail.reg
/usr/share/php/Mail/RFC822.php
/usr/share/php/Mail/mail.php
/usr/share/php/Mail/mock.php
/usr/share/php/Mail/null.php
/usr/share/php/Mail/sendmail.php
/usr/share/php/Mail/smtp.php
/usr/share/php/Mail/smtpmx.php

Changelog

2016-03-06 - Prach Pongpanich <prach@debian.org>
php-mail (1.3.0-1) unstable; urgency=medium
* Imported Upstream version 1.3.0
* Bump standards version to 3.9.7
* Rebuild with pkg-php-tools >= 1.32 for the PHP 7.0 transition
* Drop all patches (Closes: #808615)
2014-10-03 - Prach Pongpanich <prachpub@gmail.com>
php-mail (1.2.0-7) unstable; urgency=medium
[ Thijs Kinkhorst ]
* Remove self from uploaders.
[ Prach Pongpanich ]
* Use pear run-tests instead of phpunit
* Add DEP-8 compliant tests
* Bump Standards-Version to 3.9.6
2013-11-26 - Prach Pongpanich <prachpub@gmail.com>
php-mail (1.2.0-6) unstable; urgency=low
* Refresh patches/Fixes-unit-testing (Closes: #730316)
* Use phppear-substvar in control file
* Don't ship tests
* Bump Standards-Version to 3.9.5
2013-06-22 - Thomas Goirand <zigo@debian.org>
php-mail (1.2.0-5) unstable; urgency=low
[ Thomas Goirand ]
* Fix the fix of unit testing (Closes: #713780): fixes FTBFS.
[ Prach Pongpanich ]
* Use canonical URI in Vcs-* fields
* Switch debian/copyright to format 1.0
* Add myself as uploader
* Bump debhelper compat to 9
* Bump Standards-Version to 3.9.4
2012-05-10 - Thomas Goirand <zigo@debian.org>
php-mail (1.2.0-4) unstable; urgency=low
* Fixes the smtp non-existant host unit testing script.
* Standards-Version: 3.9.3 (no-change).
* Activated unit testings.
* Fixed missing depends: php-net-smtp (Closes: #672393).
* Now using pkg-php-pear@lists.alioth.d.o as maintainer.
2011-12-30 - Thomas Goirand <zigo@debian.org>
php-mail (1.2.0-3) unstable; urgency=low
* Switching to debhelper 8 sequenceur and pkg-php-tools.
* Bumped Standards-Version.
* Changed Vcs fields to use Git on Alioth instead of SVN.
* Removed useless debian/dirs.
* Switched to source format 3.0 (quilt).
* Removed useless build-depends on quilt.
* Added a patch to remove the warning "Assigning the return value of new by
reference is deprecated" (Closes: #653544).
* removed useless debian/README.source.
* Switched debian/copyright to the DEP5 format.
2010-05-16 - Thijs Kinkhorst <thijs@debian.org>
php-mail (1.2.0-2) unstable; urgency=low
* Fix bashism in debian/rules (Closes: #581459).
2010-05-09 - Thijs Kinkhorst <thijs@debian.org>
php-mail (1.2.0-1) unstable; urgency=low
* New upstream release.
+ Incorporates escapeshellcmd patch.
+ Changed licence to BSD (closes: #332613).
* Checked for policy 3.8.4, changed section to php.
2009-11-19 - Raphael Geissert <geissert@debian.org>
php-mail (1.1.14-2) unstable; urgency=high
* Use escapeshellarg instead of escapeshellcmd to escape email addresses
on sendmail.php (Closes: #557121)
- Thanks to Dennis P. NIkolaenko <dennis@nikolaenko.ru> for the report
2008-05-04 - Thijs Kinkhorst <thijs@debian.org>
php-mail (1.1.14-1) unstable; urgency=low
[ Martin Lohmeier ]
* new upstream version (Closes: #421841)
* add debian/watch
* add Homepage to debian/control
[ Thijs Kinkhorst ]
* Make debian/copyright current.
* Make use of modern-day PEAR package building.

See Also

Package Description
php-mailparse_3.0.2+2.1.6-12-gae1ef14-1build1_i386.deb Email message manipulation for PHP
php-markdown_1.6.0-2_all.deb PHP library for rendering Markdown data
php-mbstring_7.1+54ubuntu1_all.deb MBSTRING module for PHP [default]
php-mcrypt_7.1+54ubuntu1_all.deb libmcrypt module for PHP [default]
php-mdb2-driver-mysql_1.5.0b4-2_all.deb mysql MDB2 driver
php-mdb2-driver-pgsql_1.5.0b4-2_all.deb pgsql MDB2 driver
php-mdb2_2.5.0b5-2_all.deb database abstraction layer
php-memcache_3.0.9~20160311.4991c2f-5build1_i386.deb memcache extension module for PHP
php-memcached_3.0.1+2.2.0-1build1_i386.deb memcached extension module for PHP, uses libmemcached
php-mf2_0.3.0-0.1_all.deb Microformats2 is the simplest way to markup structured information in HTML
php-mime-type_1.3.1-1build1_all.deb Utility class for dealing with MIME types
php-mockery-doc_0.9.5-1_all.deb mock object framework for PHPUnit - documentation
php-mockery_0.9.5-1_all.deb mock object framework for PHPUnit and other testing framework
php-mongodb_1.2.3-1build1_i386.deb MongoDB driver for PHP
php-monolog_1.23.0-1_all.deb send logs to various destination and web services
Advertisement
Advertisement