php-libvirt-php_0.5.2~30-g64dca6f-3build1_i386.deb


Advertisement

Description

php-libvirt-php - libvirt bindings for PHP

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name php-libvirt-php
Package version 0.5.2~30
Package release g64dca6f-3build1
Package architecture i386
Package type deb
Installed size 290 B
Download size 74.14 KB
Official Mirror archive.ubuntu.com
libvirt-php is a php module that provides PHP bindings for libvirt
virtualization toolkit and therefore you can access libvirt directly
from your PHP scripts with no need to have virt-manager or
libvirt-based CLI/GUI tools installed.

Alternatives

Package Version Architecture Repository
php-libvirt-php_0.5.2~30-g64dca6f-3build1_amd64.deb 0.5.2~30 amd64 Ubuntu Universe
php-libvirt-php - - -

Requires

Name Value
libc6 >= 2.15
libvirt0 >= 1.2.8~rc2
libxml2 >= 2.7.4
php-common >= 1:7.0+33~
phpapi-20160303 -

Download

Type URL
Binary Package php-libvirt-php_0.5.2~30-g64dca6f-3build1_i386.deb
Source Package libvirt-php

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php-libvirt-php deb package:
    # sudo apt-get install php-libvirt-php

Files

Path
/etc/php/7.1/mods-available/libvirt-php.ini
/usr/lib/php/20160303/libvirt-php.so
/usr/share/doc/php-libvirt-php/changelog.Debian.gz
/usr/share/doc/php-libvirt-php/copyright

Changelog

2017-04-28 - Nishanth Aravamudan <nish.aravamudan@canonical.com>
libvirt-php (0.5.2~30-g64dca6f-3build1) artful; urgency=medium
* No-change rebuild for PHP7.1. 
2016-08-29 - Ondřej Surý <ondrej@debian.org>
libvirt-php (0.5.2~30-g64dca6f-3) unstable; urgency=medium
* Don't rely on absolute paths in tools/Makefile.am
2016-08-29 - Ondřej Surý <ondrej@debian.org>
libvirt-php (0.5.2~30-g64dca6f-2) unstable; urgency=medium
* Explicitly set PHPCDIR and PHPEDIR variable on make install
(Closes: #835733)
2016-04-15 - Ondřej Surý <ondrej@debian.org>
libvirt-php (0.5.2~30-g64dca6f-1) unstable; urgency=medium
* Imported Upstream version 0.5.2~30-g64dca6f
* Remove the patch, it's no longer needed
2016-04-15 - Ondřej Surý <ondrej@debian.org>
libvirt-php (0.5.2~29-ge5e5f4c-1) unstable; urgency=medium
* Imported Upstream version 0.5.2~29-ge5e5f4c
* This is a pre-release version from git://libvirt.org/libvirt-php
2016-03-25 - Ondřej Surý <ondrej@debian.org>
libvirt-php (0.5.1-31-ga005c2d-1) unstable; urgency=medium
* Imported Upstream version 0.5.1-31-ga005c2d with PHP 7.0 support
* Convert the package to PHP 7.0 packaging
* Filter out debian/ directory from upstream tarball
* Enable autoreconf and autotools-dev dh addons
* Set some default paths in php.ini
* Cleanup upstream installed cruft
2014-06-24 - Ondřej Surý <ondrej@debian.org>
libvirt-php (0.4.8-1) unstable; urgency=medium
* Initial release

See Also

Package Description
php-log_1.12.9-2_all.deb Logging Framework
php-mail-mime_1.10.0-2_all.deb PHP PEAR module for creating MIME messages
php-mail_1.3.0-1_all.deb Class that provides multiple interfaces for sending emails
php-mailparse_3.0.2+2.1.6-12-gae1ef14-1build1_i386.deb Email message manipulation for PHP
php-markdown_1.6.0-2_all.deb PHP library for rendering Markdown data
php-mbstring_7.1+54ubuntu1_all.deb MBSTRING module for PHP [default]
php-mcrypt_7.1+54ubuntu1_all.deb libmcrypt module for PHP [default]
php-mdb2-driver-mysql_1.5.0b4-2_all.deb mysql MDB2 driver
php-mdb2-driver-pgsql_1.5.0b4-2_all.deb pgsql MDB2 driver
php-mdb2_2.5.0b5-2_all.deb database abstraction layer
php-memcache_3.0.9~20160311.4991c2f-5build1_i386.deb memcache extension module for PHP
php-memcached_3.0.1+2.2.0-1build1_i386.deb memcached extension module for PHP, uses libmemcached
php-mf2_0.3.0-0.1_all.deb Microformats2 is the simplest way to markup structured information in HTML
php-mime-type_1.3.1-1build1_all.deb Utility class for dealing with MIME types
php-mockery-doc_0.9.5-1_all.deb mock object framework for PHPUnit - documentation
Advertisement
Advertisement