php-http-request2_2.3.0-1_all.deb


Advertisement

Description

php-http-request2 - Provides an easy way to perform HTTP requests

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name php-http-request2
Package version 2.3.0
Package release 1
Package architecture all
Package type deb
Installed size 479 B
Download size 86.08 KB
Official Mirror archive.ubuntu.com
PHP5 rewrite of HTTP_Request package (with parts of HTTP_Client). Provides
cleaner API and pluggable Adapters:
* Socket adapter, based on old HTTP_Request code,
* Curl adapter, wraps around PHP's cURL extension,
* Mock adapter, to use for testing packages dependent on HTTP_Request2.
Supports POST requests with data and file uploads, basic and digest
authentication, cookies, managing cookies across requests, proxies, gzip and
deflate encodings, redirects, monitoring the request progress with
Observers...

Alternatives

Package Version Architecture Repository
php-http-request2_2.3.0-1_all.deb 2.3.0 all Ubuntu Universe
php-http-request2 - - -

Requires

Name Value
php-common -
php-net-url2 >= 2.2.0
php-pear >= 1.9.2

Download

Type URL
Binary Package php-http-request2_2.3.0-1_all.deb
Source Package php-http-request2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php-http-request2 deb package:
    # sudo apt-get install php-http-request2

Files

Path
/usr/share/doc/php-http-request2/changelog.Debian.gz
/usr/share/doc/php-http-request2/copyright
/usr/share/doc/php-http-request2/package.xml.gz
/usr/share/doc/php-http-request2/examples/upload-rapidshare.php
/usr/share/php/.registry/http_request2.reg
/usr/share/php/HTTP/Request2.php
/usr/share/php/HTTP/Request2/Adapter.php
/usr/share/php/HTTP/Request2/CookieJar.php
/usr/share/php/HTTP/Request2/Exception.php
/usr/share/php/HTTP/Request2/MultipartBody.php
/usr/share/php/HTTP/Request2/Response.php
/usr/share/php/HTTP/Request2/SOCKS5.php
/usr/share/php/HTTP/Request2/SocketWrapper.php
/usr/share/php/HTTP/Request2/Adapter/Curl.php
/usr/share/php/HTTP/Request2/Adapter/Mock.php
/usr/share/php/HTTP/Request2/Adapter/Socket.php
/usr/share/php/HTTP/Request2/Observer/Log.php
/usr/share/php/HTTP/Request2/Observer/UncompressingDownload.php
/usr/share/php/data/HTTP_Request2/generate-list.php
/usr/share/php/data/HTTP_Request2/public-suffix-list.php

Changelog

2016-03-18 - David Prévot <taffit@debian.org>
php-http-request2 (2.3.0-1) unstable; urgency=medium
* Team upload
[ Alexey Borzov ]
* Copyright year update
[ David Prévot ]
* Use standard gbp layout
* Drop patches applied upstream
* Update copyright (years)
* Use proper team name
* Update Standards-Version to 3.9.7
* Build with recent pkg-php-tools for the PHP 7.0 transition
2015-05-23 - David Prévot <taffit@debian.org>
php-http-request2 (2.2.1-2) unstable; urgency=medium
* Team upload, to unstable since Jessie has been released
* Use patches as applied upstream
* Adapt packaging to updated patches
2015-03-20 - David Prévot <taffit@debian.org>
php-http-request2 (2.2.1-1) experimental; urgency=medium
* Team upload, to experimental to respect the freeze
[ Alexey Borzov ]
* Prepare release 2.2.1
[ David Prévot ]
* Document upstream VCS
* Update copyright
* Bump standards version to 3.9.6
* Allow tests to run with recent packages
* Run the testsuite during the build
* Provide DEP-8 tests
2014-01-01 - David Prévot <taffit@debian.org>
php-http-request2 (2.1.1-5) unstable; urgency=medium
* Team upload
[ Sascha Girrulat ]
* add gbp.conf in addition to pkg-php.alioth.debian.org
* update buildsystem addition to pkg-php.alioth.debian.org
* update vcs urls to pkg-php destination
[ David Prévot ]
* Remove useless dh-make-php build-dependency
* Bump standards version to 3.9.5
* Use ${phppear:*} substitutions
* Adapt copyright to comply with format 1.0
* Shorten rules
* Do not ship tests
2013-08-29 - Sascha Girrulat <sascha@girrulat.de>
php-http-request2 (2.1.1-4) unstable; urgency=low
* [578bb68] set section to php
* [18c2168] remove needless d/dirs
* [d02113a] remove needless and empty directory
* [92a00d0] fix bsd license block at d/copyright
* [21a41ad] remove needles d/README.Debian
* [1b29308] remove dh-make template header from d/rules
* (Closes: #651960)
2013-08-13 - Sascha Girrulat <sascha@girrulat.de>
php-http-request2 (2.1.1-3) unstable; urgency=low
* [db31a9f] remove obsolete DMUA tag from d/control
* [51abb00] convert d/copyright to format version 1.0 and add missing license
headers
* [52a9985] bump debhelper dependency to 8.0.0
* [79190de] bump to standards version 3.9.4
* [37327e2] Add d/source/format
* [c79e513] add vcs and homepage information to d/control
* [f3802f9] Add lintian-override for .channel.doc.php.net
2012-06-06 - Sascha Girrulat <sascha@girrulat.de>
php-http-request2 (2.1.1-2) unstable; urgency=low
* [e10c2d5] add dependency to php-net-url2
* [ef53f90] allow DM Uploads
* [a391745] update copyright
2012-06-05 - Sascha Girrulat <sascha@girrulat.de>
php-http-request2 (2.1.1-1) unstable; urgency=low
* Initial Release (Closes: #651960).

See Also

Package Description
php-http-request_1.4.4-5_all.deb Provides an easy way to perform HTTP requests
php-http-webdav-server_1.0.0RC8-1_all.deb WebDAV Server Baseclass
php-http_3.1.0+2.6.0-4build2_i386.deb PECL HTTP module for PHP Extended HTTP Support
php-icinga_2.4.1-1_all.deb PHP library to communicate with and use Icinga
php-igbinary_2.0.1-1build1_i386.deb igbinary PHP serializer
php-image-text_0.7.0-2_all.deb Image_Text - Advanced text maipulations in images
php-imagick_3.4.3~rc2-2ubuntu3_i386.deb Provides a wrapper to the ImageMagick library
php-imap_7.1+54ubuntu1_all.deb IMAP module for PHP [default]
php-interbase_7.1+54ubuntu1_all.deb Interbase module for PHP [default]
php-intl_7.1+54ubuntu1_all.deb Internationalisation module for PHP [default]
php-invoker_1.1.4-3_all.deb Utility class for invoking callables with a timeout
php-jmespath_2.3.0-2_all.deb Declaratively specify how to extract elements from a JSON document
php-json-schema_5.2.1-2_all.deb implementation of JSON schema
php-json_7.1+54ubuntu1_all.deb JSON module for PHP [default]
php-kdyby-events_2.4.0-3_all.deb Events for Nette Framework
Advertisement
Advertisement