php-html-safe_0.10.1-4_all.deb


Advertisement

Description

php-html-safe - strip down all potentially dangerous content within HTML

Property Value
Distribution Ubuntu 17.10 (Artful Aardvark)
Repository Ubuntu Universe i386
Package name php-html-safe
Package version 0.10.1
Package release 4
Package architecture all
Package type deb
Installed size 42 B
Download size 9.07 KB
Official Mirror archive.ubuntu.com
This parser strips down all potentially dangerous content within HTML:
* opening tag without its closing tag
* closing tag without its opening tag
* any of these tags: "base", "basefont", "head", "html", "body", "applet",
"object", "iframe", "frame", "frameset", "script", "layer", "ilayer",
"embed", "bgsound", "link", "meta", "style", "title", "blink", "xml", etc.
* any of these attributes: on*, data*, dynsrc
* javascript:/vbscript:/about: etc. protocols
* expression/behavior etc. in styles
* any other active content
It also tries to convert code to XHTML valid, but htmltidy is far better
solution for this task.

Alternatives

Package Version Architecture Repository
php-html-safe_0.10.1-4_all.deb 0.10.1 all Ubuntu Universe
php-html-safe - - -

Requires

Name Value
php-common -
php-xml-htmlsax3 >= 3.0.0~RC1

Download

Type URL
Binary Package php-html-safe_0.10.1-4_all.deb
Source Package php-html-safe

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php-html-safe deb package:
    # sudo apt-get install php-html-safe

Files

Path
/usr/share/doc/php-html-safe/README.gz
/usr/share/doc/php-html-safe/changelog.Debian.gz
/usr/share/doc/php-html-safe/copyright
/usr/share/doc/php-html-safe/package.xml
/usr/share/php/.registry/html_safe.reg
/usr/share/php/HTML/Safe.php

Changelog

2016-03-02 - David Prévot <taffit@debian.org>
php-html-safe (0.10.1-4) unstable; urgency=medium
* No tests if DEB_BUILD_OPTIONS contains nocheck
* Document upstream VCS
* Simplify CI
* Update Standards-Version to 3.9.7
* Rebuild with latest pkg-php-tools for the PHP 7.0 transition
2014-02-09 - David Prévot <taffit@debian.org>
php-html-safe (0.10.1-3) unstable; urgency=medium
* Remove file from package.xml via dh_auto_configure (Closes: #738374)
* Use README as upstream changelog
* Bump standards version to 3.9.5
* Extend description
* Deactivate failing test
* Activate test suite during package build
* Add DEP-8 compliant tests
2013-07-01 - David Prévot <taffit@debian.org>
php-html-safe (0.10.1-2) unstable; urgency=low
* Use section php, as overridden by ftpmaster
* Move packaging to dh short rules and pkg-php-tools
* Maintain the package inside the PHP PEAR team
* Bump compat to 9
* Bump standards version to 3.9.4
* Convert copyright to format 1.0
2011-03-06 - Romain Beauxis <toots@rastageeks.org>
php-html-safe (0.10.1-1) unstable; urgency=low
* New upstream release.
* Use source format 3.0 (quilt).
* Bumped standards version to 3.9.1 
2010-04-12 - Romain Beauxis <toots@rastageeks.org>
php-html-safe (0.10.0-1) unstable; urgency=low
* New upstream release.
* Bumped standards version to 3.8.4 
2009-11-05 - Romain Beauxis <toots@rastageeks.org>
php-html-safe (0.9.9~beta-2) unstable; urgency=low
* Fixed build-dep: added control.in and using cdbs' 
helper.
Closes: #554183
* Bumped standards version to 3.8.3
* Bumped compat to 7
* Fixed watch file to mangle with the ~ symbol. 
2007-10-09 - Romain Beauxis <toots@rastageeks.org>
php-html-safe (0.9.9~beta-1) unstable; urgency=low
* Initial release (Closes: #445907)

See Also

Package Description
php-htmlawed_1.1.20-1_all.deb htmLawed PHP code to purify & filter HTML
php-htmlpurifier_4.7.0-2_all.deb Standards-compliant HTML filter
php-http-request2_2.3.0-1_all.deb Provides an easy way to perform HTTP requests
php-http-request_1.4.4-5_all.deb Provides an easy way to perform HTTP requests
php-http-webdav-server_1.0.0RC8-1_all.deb WebDAV Server Baseclass
php-http_3.1.0+2.6.0-4build2_i386.deb PECL HTTP module for PHP Extended HTTP Support
php-icinga_2.4.1-1_all.deb PHP library to communicate with and use Icinga
php-igbinary_2.0.1-1build1_i386.deb igbinary PHP serializer
php-image-text_0.7.0-2_all.deb Image_Text - Advanced text maipulations in images
php-imagick_3.4.3~rc2-2ubuntu3_i386.deb Provides a wrapper to the ImageMagick library
php-imap_7.1+54ubuntu1_all.deb IMAP module for PHP [default]
php-interbase_7.1+54ubuntu1_all.deb Interbase module for PHP [default]
php-intl_7.1+54ubuntu1_all.deb Internationalisation module for PHP [default]
php-invoker_1.1.4-3_all.deb Utility class for invoking callables with a timeout
php-jmespath_2.3.0-2_all.deb Declaratively specify how to extract elements from a JSON document
Advertisement
Advertisement